We have detected that cookies are not enabled on your browser. Please enable cookies to ensure the proper experience.
Results 1 to 10 of 10
  1. #1
    Join Date
    Jul 2020
    Location
    Leipzig, Germany
    Posts
    14

    Don't Support old Windows Versions!

    Why you still support Windows 7 and earlier Versions?
    They are no more existend and don't get any updates. Its like making a PS5 game for PS1 consoles.
    Even drivers, software or other games no more support old Versions.

    There will be more and more problems in the future und you have to do implement more legacy code for them. For people who are simple too lazy.

    Its worktime you can spend to make something better for the actual Windows, to replace old code, reduce code size, use new APIs and optimize the engine for the last Version.
    Exactly this is why Windows 10 exist: everyone will get the last Version to reduce problems for devs.

    For the aluminum hats user:
    - You don't need a Microsoft account
    - You can turn off nearly everything like cortana
    - Its a lot more stable than Windows 7
    - Cost you one time 0-10€ for the rest of your life.
    - There will be no Windows 11 and you get always the new Version.

    Don't be selfish because other need to work, wait and more space only for you. There are enough how-to's and it takes only 5min.
    Pinok | Dwarf Runekeeper from Gwaihir [DE]

  2. #2
    Join Date
    Feb 2012
    Posts
    2,433
    Quote Originally Posted by Pinogik View Post
    Why you still support Windows 7 and earlier Versions?
    Because they have customers who still use Windows 7, and they don't want to lose those customers.


    - There will be no Windows 11 and you get always the new Version.
    This is a major issue with Windows 10 actually. New versions mean new problems, and it also means you don't know in advance what you will get because that will change over time.

  3. #3
    Join Date
    May 2018
    Location
    Brazil
    Posts
    69
    Quote Originally Posted by Pinogik View Post
    Why you still support Windows 7 and earlier Versions?
    They are no more existend and don't get any updates. Its like making a PS5 game for PS1 consoles.
    Even drivers, software or other games no more support old Versions.

    There will be more and more problems in the future und you have to do implement more legacy code for them. For people who are simple too lazy.

    Its worktime you can spend to make something better for the actual Windows, to replace old code, reduce code size, use new APIs and optimize the engine for the last Version.
    Exactly this is why Windows 10 exist: everyone will get the last Version to reduce problems for devs.

    For the aluminum hats user:
    - You don't need a Microsoft account
    - You can turn off nearly everything like cortana
    - Its a lot more stable than Windows 7
    - Cost you one time 0-10€ for the rest of your life.
    - There will be no Windows 11 and you get always the new Version.

    Don't be selfish because other need to work, wait and more space only for you. There are enough how-to's and it takes only 5min.
    Well, it's better for them to do that than to lie all the time and blame people's OSes for the problems they cause. This last problem in the patch is proof of that. Even users with Windows 10 had the problem but even so they said it was a problem with old OSes. In reality they try to force people to change their OS with lies. It is more honest to ban these players and suffer the consequences for that than to act like someone who gives alms against their will. I want to remind you that the Runescape game team solved this problem wisely: they created a new version and kept an old version. That was wonderful and it is an idea to be followed when you value all players and not just modern and subservient ones. They update the old version of the game according to the result of the polls that the players answer, that is, they care about people's will, something that the SSG should learn.

  4. #4
    Join Date
    Jul 2012
    Location
    Wisconsin, USA
    Posts
    327
    I agree with the poster because after a specific amount of time other hardware makers stop updating there drivers and such for unsupportive operating systems. This is something like 18-24 months. Once SSG stops supporting non supportive operating systems they can focus more on in this case the 2 Windows operating systems that are left. Thus making it easier.

  5. #5
    Quote Originally Posted by farmhand99 View Post
    I agree with the poster because after a specific amount of time other hardware makers stop updating there drivers and such for unsupportive operating systems. This is something like 18-24 months. Once SSG stops supporting non supportive operating systems they can focus more on in this case the 2 Windows operating systems that are left. Thus making it easier.
    Agreed. As someone who has been in high tech for 40 years, I know that deprecation has to happen. W7 is no longer a system supported by MS. SSG's W10 product has enough problems that it should be the focus. Wasting resources on W7 is losing W10 customers, most likely far more than the folks dragging along on W7.

  6. #6

    Got game arror 107 Need xp SP2 or later

    I have xp SP3 and it says it can't figure it out. I logged in earlier though.

  7. #7
    Ya I'd have to disagree with you all mates. An mmo (And games in general.) should support any and all OS'es and hardware from the point of release to the current date. I mean that's Basic MMO Concepts 101 right there. The core key to any successful mmo is the whole massively part. People need to understand that. Not everybody like Windblows 10. lol So the complaint shouldn't be that it supports older OS'es. The complaint should be it needs better functionality on all of them.
    Shadow Circle Order-(SCO)
    KOOLLAYDTAC - Guardian
    Ravvage - Warg

  8. #8
    Join Date
    Apr 2013
    Location
    Upon these hither shores
    Posts
    279
    Quote Originally Posted by KOOLLAYD View Post
    Ya I'd have to disagree with you all mates. An mmo (And games in general.) should support any and all OS'es and hardware from the point of release to the current date. I mean that's Basic MMO Concepts 101 right there. The core key to any successful mmo is the whole massively part. People need to understand that. Not everybody like Windblows 10. lol So the complaint shouldn't be that it supports older OS'es. The complaint should be it needs better functionality on all of them.
    yeah, about that
    https://www.lotro.com/forums/showthr...26#post8073526

  9. #9
    Quote Originally Posted by elvenes View Post
    Really, the best solution is just to run Linux and specifically WINE in Linux,* regardless of your hardware old or new. WINE will run games that only ran in Windows 98, all the way up to modern games in Windows 10. The 64bit Client will still open the Store in an external Browser, so if you have a quirky hardware system you can always open up an external browser even as you view LOTRO in DX11.

    Even if Microsoft changes Windows 10 enough that it becomes an effective Windows 11, WINE will be there in Linux (and possibly *in* Windows "11") to let you run the Windows 10 version of LOTRO. Microsoft is sharing enough code that we may yet see a WINE for Windows, allowing earlier versions of software that Microsoft has depreciated to be run in WINE in Windows.



    * Technically Mac Users are also running WINE in Linux.

  10. #10
    Join Date
    Apr 2013
    Location
    Upon these hither shores
    Posts
    279
    Linux, where you have to go through hoops and headaches to install anything on it? please... just get a cheap laptop, install win10 on it, and you're good to go. Win10 is not the devil.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

This form's session has expired. You need to reload the page.

Reload