We have detected that cookies are not enabled on your browser. Please enable cookies to ensure the proper experience.
Results 1 to 6 of 6
  1. #1
    Join Date
    Jun 2007
    Location
    California
    Posts
    449

    Black Screen With Perpetual Loading After Log-In

    Hey all,

    I'm running Windows 10 and just downloaded the client again through the SSG downloader after a hiatus. After logging into the launcher and selecting a server, I receive a perpetual black screen with the rotating wheel of "fun" that won't go away (at least not after 20 minutes).

    I've tried a couple things so far:

    1. Followed all the advice in SSG's tech support post here: https://help.standingstonegames.com/...-the-launcher-

    2. Completely shut off my Windows Firewall (no other anti-virus software downloaded or active).

    Other than that I'm at a loss. I'm not very tech-saavy; so, I could definitely use some help and advice. Thank you!
    Foxleaf and his merry mischief-making companion Fox.
    Level 100 Master of Lore and other oddities, including elderberries and aged cheddar.

  2. #2
    Join Date
    Jun 2007
    Location
    California
    Posts
    449
    ... and then I selected the option to use DirectX 10/11 and it worked. Huh.
    Foxleaf and his merry mischief-making companion Fox.
    Level 100 Master of Lore and other oddities, including elderberries and aged cheddar.

  3. #3
    Join Date
    Nov 2010
    Location
    Korea
    Posts
    28

    I am having the same issue with black screen after clicking play and perpetual loading

    Quote Originally Posted by Zandi View Post
    ... and then I selected the option to use DirectX 10/11 and it worked. Huh.
    Could you please elaborate how did you manage to select the option to use Direct X 10/11 without opening the graphic panel in the client??

    Did you log on to the other PC that you can open the client then switch the option??

    It would be very much appreciated if you could explain a bit more...

  4. #4
    Join Date
    Jul 2020
    Location
    New York City
    Posts
    236
    Quote Originally Posted by Lindviore View Post
    Could you please elaborate how did you manage to select the option to use Direct X 10/11 without opening the graphic panel in the client??

    Did you log on to the other PC that you can open the client then switch the option??

    It would be very much appreciated if you could explain a bit more...
    While I don't know which method Zandi used, this one works and doesn't even require the LOTRO launcher application to run first:
    1- Open the file UserPreferences64.ini with a text editor. You will find it in your The Lord of the Rings Online folder which should be in your Documents or My Documents folder. If that file doesn't exist, create it. Look for the line...
    GraphicsCore=X
    ...and change X to D3D10 or D3D11. I suggest D3D11 as it allows for more eye candy options and tends to have fewer display bugs with LOTRO than D3D10.
    2- You must use the 64-bit client for DirectX 11. If you are not already using the 64-bit client, you can force the use of the 64-bit client by editing the UserPreferences.ini file. Look for the line...
    GameClientType=Y
    ...and change Y to 3.

  5. #5
    Join Date
    Nov 2010
    Location
    Korea
    Posts
    28
    Quote Originally Posted by Tralfazz View Post
    While I don't know which method Zandi used, this one works and doesn't even require the LOTRO launcher application to run first:
    1- Open the file UserPreferences64.ini with a text editor. You will find it in your The Lord of the Rings Online folder which should be in your Documents or My Documents folder. If that file doesn't exist, create it. Look for the line...
    GraphicsCore=X
    ...and change X to D3D10 or D3D11. I suggest D3D11 as it allows for more eye candy options and tends to have fewer display bugs with LOTRO than D3D10.
    2- You must use the 64-bit client for DirectX 11. If you are not already using the 64-bit client, you can force the use of the 64-bit client by editing the UserPreferences.ini file. Look for the line...
    GameClientType=Y
    ...and change Y to 3.
    Thanks for your kind explanaton.

    I tried to locate where the graphicscore= line is but there isn't one in my UserPreference.ini file.

    WindowGeometry=@ByteArray(\x1\ xd9\xd0\xcb\0\x1\0\0\0\0\x2X\0 \0\x1\b\0\0\x5'\0\0\x3\x30\0\0 \x2X\0\0\x1\b\0\0\x5'\0\0\x3\x 30\0\0\0\0\0\0)
    PreCache=true
    SelectLastPlayedWorld=false
    GameClientType=3
    LoadOnStartup=false
    AskBeforeDownload=false
    ThrottleDownload=false
    ThrottleDownloadRate=4
    AutoRetrieveUpdates=false
    AutoRetrieveUpdatesInterval=4
    KeepLauncherOpen=false

    I just purchased new alienware PC and would like to play LOTRO again.

  6. #6
    Join Date
    Jun 2007
    Location
    California
    Posts
    449
    So, I downloaded the game again, and then again, and the same issue happened again! There was no UserPreferences.ini file, so I tried to create it, but it didn't fix the problem. In the launcher, resetting the game display settings does not bring up the prompt to use DX10/DX11. I've tried all the other hotfixes I can find on the forums with no luck. I still go straight from hitting Play to a black screen with the blue circling dot.

    I'm genuinely at a loss right now. I do not understand how the download screws up each and every time I've downloaded the game.
    Foxleaf and his merry mischief-making companion Fox.
    Level 100 Master of Lore and other oddities, including elderberries and aged cheddar.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

This form's session has expired. You need to reload the page.

Reload