We have detected that cookies are not enabled on your browser. Please enable cookies to ensure the proper experience.
Results 1 to 2 of 2
  1. #1

    Installing pre reqs?

    I tried launching and got this message. I've rebooted the pc, modem and router. I tried repair data, new config file. I even completely uninstalled the game, wiping the lotro doc folder and the game folder on the hard drive. I now get the message for installing the game at the download data point. What gives?

  2. #2
    I had the same issue couple of months ago, I did everything and nothing, and for me it was the internet router, I had at the time verizon fios, and I just had to get a new verizon router, but instead I switched to another internet provider Optimum. try to get a new internet router from your internet provider. Hope this helps.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

This form's session has expired. You need to reload the page.