We have detected that cookies are not enabled on your browser. Please enable cookies to ensure the proper experience.
Results 1 to 6 of 6
  1. #1
    Join Date
    Apr 2009
    Posts
    778

    The forums as almost as bad as the servers

    While waiting a week for the servers, I'm finally going to bring this up. The forums are terrible. Constantly failing to communicate. Regular "Secure Connect Failed". Posts freeze and die. I get "You need more than 3 characters" when there are more. Failures to connect. Lots and lots of technical glitches that seem to be the equivalent of major lag when it's in the game.

    This has been going on for years, but seems to have gotten worse along with the server issue. Any relationship? Any plans on addressing lotro.com performance?

  2. #2
    Join Date
    Sep 2016
    Posts
    3,888
    The forums and web site have been directly impacted by the data center issues over the past week. During times where things are happening you can expect both the forums and web site to be largely unresponsive. We have been trying to keep our immediate announcements on Twitter and Facebook for this reason (there have been times where access to launcher and web site messaging has been unavailable).
    Community Manager, Lord of the Rings Online
    Follow LOTRO on: Twitter - Facebook - Pinterest - Twitch - YouTube
    Find Cordovan on: Twitter Instagram
    Support: help.standingstonegames.com
    coolcool

  3. #3
    Join Date
    Apr 2009
    Posts
    778
    Quote Originally Posted by Cordovan View Post
    The forums and web site have been directly impacted by the data center issues over the past week. During times where things are happening you can expect both the forums and web site to be largely unresponsive. We have been trying to keep our immediate announcements on Twitter and Facebook for this reason (there have been times where access to launcher and web site messaging has been unavailable).
    Thanks again. That was expected, but it's also good to get past expected to actually know something.

  4. #4

    Unhappy Lag and connection problems

    Quote Originally Posted by groucho42 View Post
    While waiting a week for the servers, I'm finally going to bring this up. The forums are terrible. Constantly failing to communicate. Regular "Secure Connect Failed". Posts freeze and die. I get "You need more than 3 characters" when there are more. Failures to connect. Lots and lots of technical glitches that seem to be the equivalent of major lag when it's in the game.

    This has been going on for years, but seems to have gotten worse along with the server issue. Any relationship? Any plans on addressing lotro.com performance?
    I have noticed this too and hope the most recent series of down-times are going to be successful in getting all the servers up and glitch-free. As a VIP subscriber, the amount of downtime has really irked me...

  5. #5
    Join Date
    Jan 2008
    Location
    This side of the screen.
    Posts
    289
    The forums have been in bad shape for YEARS. Many have complained about it and nothing gets fixed, time to start speaking with your wallet if they won't listen...
    Last edited by IcarusLSC; Jul 22 2020 at 07:55 PM.
    ·Ï¢årµ§·

  6. #6
    Join Date
    Apr 2009
    Posts
    778
    Quote Originally Posted by IcarusLSC View Post
    The forums have been in bad shape for YEARS. Many have complained about it and nothing gets fixed, time to start speaking with your wallet if they won't listen...
    Yes, and so have the servers. However, the lotro.com web site has seen degradation right along with the recent problems with play servers. It doesn't hurt to confirm they're related.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

This form's session has expired. You need to reload the page.

Reload