We have detected that cookies are not enabled on your browser. Please enable cookies to ensure the proper experience.
Results 1 to 4 of 4
  1. #1

    The shadow of Mordor quest/instance

    I am trying to do The Shadow of Mordor quest/instance. I am up to the part where I'm supposed to pick up a class weapon, but cannot. I run my cursor over the whole area several times and the only one that I can actually pick up, which I can't is a bow, because I am a guardian. I cannot delete and start over because I would lose my minas morgul packages. Any suggestions? Or do I sit and wait for GM help...

  2. #2
    Problem was solved!

  3. #3
    Quote Originally Posted by Dathuca View Post
    Problem was solved!
    How did you solve this? I am also stuck here as a rune-keeper.

  4. #4
    I am also stuck on this quest. My character, Narvel, is a guardian and the only weapon that appears to be available is a bow. There are stars that appear to indicate other loot, but nothing is showing up with the hand. I was finally able to get the loot hand to appear above the rune, however have not been able to see a loot hand appear near the shield and I can not find a sword or other type of weapon.

    I had to use the DEL key to target the item, it does not have any type of glow like the bow or rune stone.
    Last edited by Fleana; Nov 07 2019 at 07:55 PM. Reason: added some information

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

This form's session has expired. You need to reload the page.

Reload