We have detected that cookies are not enabled on your browser. Please enable cookies to ensure the proper experience.
Results 1 to 2 of 2
  1. #1

    Mac Client Perfomance Issues

    Things have just not been right lately with the Mac client on my computer and I am starting to lose faith that I can rectify the terrible performance issues I have been experiencing. I did a clean install of Mojave last week (previously Sierra) on the APFS and installed from this site the latest and "greatest" WINE client for Mac, including hi-res graphics. The only other things installed (using homebrew) are:

    • mysql
    • lighttpd
    • nginx
    • php 7.3
    • AdoptOpenJDK 11
    • jenv

    I had one day post-install of acceptable LOTRO performance, meaning about 30 FPS, in 6 man Moria instances running very medium graphics windowed (fullscreen or windowed) with Specular Lighting and Post-processing turned off. I am not sure if I tried to tweak graphics setting, but at any rate, the 2nd, 3rd, and 4th day after the clean install things rapidly degraded in the FPS realm. I see almost no difference now between Very Low and Very High graphics settings, both running around 4-9 FPS when battling worms in the Flaming Deeps. Fil Gashan with 5 other fellows runs around 2-4 FPS. Mind you this is the same whether running in very low or higher graphics settings. This computer is far from a high performance gaming machine, but has run LOTRO for 8 years at a playable framerate. Here are the specs:

    • Mid-2012 Macbook Pro (non-retina unibody)
    • 8 GB 1600 MHz DDR3 RAM
    • 2.7 GHz Intel Core i7 (Quad core)
    • NVIDIA GeForce GT 650M 1GB Vram
    • Intel HD Graphics 4000 1536 MB
    • 1 TB Eluktronics SSD (6 GB/s)
    • 200 MB/s internet connection

    I have fiddled around lately with unchecking "Use Hi-Res Graphics", Detect Optimal Settings (which defaults to "Very High" on this machine), and a bunch of other settings to no avail. I have noticed wine-preloader64 runs at approximately 800% CPU during gameplay. Sometimes it runs at 130% which seems to be in the realm of reasonableness. I feel like something is not working right, like some setting is not taking, or wine is not working right. I do not have WINE installed on this machine (other than the built-in LOTRO WINE), and was wondering if installing wine-stable would in anyway help, or if LOTRO would just ignore that. Maybe Mojave just doesn't support nVidia drivers (which could very well be the case).

    Another thing that is mysterious to me is the loss of plugin settings randomly. A couple of times, I have had to reconfigure settings in Buff Bars on characters, because the settings reset themselves seemingly randomly (perhaps a permission issue).

    What it comes down to is that there is no real support for this client and SSG has put the impetus on the users to figure out exactly all the problems associated with their client. It would be wonderful to have a concise troubleshooting guide, more so than the great advice people have posted already on the forums, to nail down typical problems going on with the Mac client.

    Cheers everyone

  2. #2
    Yep.

    I gotta say that I was running everything fine on my Mac air until update 24 and now using WINE client.

    Game experience is ####. Laggy. Slow. And the lack of caring for mac user experience is a bit off-putting.

    On top of that, this WINE client is still going to become obsolete and unsupported.... so not sure what the point of that is.

    It's a real shame, because I was really enjoying this game, and have done for a couple of years. I am looking elsewhere to get my gaming fix.

    It would be great if SSG could maybe pay attention to this.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

This form's session has expired. You need to reload the page.

Reload