We have detected that cookies are not enabled on your browser. Please enable cookies to ensure the proper experience.
Results 1 to 15 of 15
  1. #1
    Join Date
    Jun 2011
    Posts
    18

    Lotro closes just after logging in

    The problem has appeared today, just after a crash.

    There's no error message. Just that after logging in I see the welcome window for a couple of seconds and then it closes and there's no lotro anymore.

    I'm running Windows 10 and DirectX 10. As DX gives so many problems, I've tried to reinstall it with the directx_Jun2010_redist which I got a few months back, after I read a thread here suggesting that install. The problem was solved then, but it isn't now.

    Any suggestion will be much appreciated!

  2. #2
    Join Date
    Jun 2011
    Posts
    18
    I found this page:

    https://help.standingstonegames.com/...-the-launcher-

    I thought I got lucky because I finally could get past the initial window, but luck ended soon. I seem to have a DirectX problem, but I can't find a way to solve it.

    I followed all the steps fromt the page linked and now I can get to the character selection screen, and even log in into the game, but only at the default resolution (1024x768).

    Even if I've reinstalled DirectX countless times, a message of error always shows up as soon as I change the resolution. The message prompts me to install DirectX 9c, December 2005 (which is actually in the list of DirectX which I've reinstalled).

    Has anyone found a solution for a problem with DX which is not solved reinstalling DX?

  3. #3
    Hi there,

    I've been having tons of issues since the launch of the new servers, which sucks coz I feel I wasted my money subbing for something I can't play reliably.

    In my case, what helped not get an error message from client anymore was adding -disablepatch after the .exe on the lotro launcher shortcut (go to properties & edit the name there)

    Also I'm gonna leave here my ignored thread on getting locked out of characters: https://www.lotro.com/forums/showthr...Ithil-amp-Anor
    Main: Laurelinarien (LM) Council of the Elder Lords
    Other lvl caps: Feantura (RK), Laergwend (Mini), Taurtaren (HNT), Morwinne (CPT), Furcifer (Beorn), Seregeth (WDN), Dagnirion (Champ) & Kitiarya (Burg).
    Lowbies: Brynhilt (GRD) & Daerris [High-Elf CPT]

  4. #4
    Join Date
    Jul 2016
    Location
    UK
    Posts
    2,821
    Quote Originally Posted by Maeg View Post
    I found this page:

    https://help.standingstonegames.com/...-the-launcher-

    I thought I got lucky because I finally could get past the initial window, but luck ended soon. I seem to have a DirectX problem, but I can't find a way to solve it.

    I followed all the steps fromt the page linked and now I can get to the character selection screen, and even log in into the game, but only at the default resolution (1024x768).

    Even if I've reinstalled DirectX countless times, a message of error always shows up as soon as I change the resolution. The message prompts me to install DirectX 9c, December 2005 (which is actually in the list of DirectX which I've reinstalled).

    Has anyone found a solution for a problem with DX which is not solved reinstalling DX?
    Have you tried deleting your LOTRO user preference files ? sometimes the issue is that getting corrupted.

    If it IS a dx issue, that is a bit more tricky; there is a long standing bug in Windows where a corrupted file is sometimes not over written, even though the OS claims it has been; the only way around this is to manually delete the corrupted file, reboot and install the new copy; HOWEVER, since your main system is DX12, I am not sure how to go about doing this (resolute Win7 user).

  5. #5
    Join Date
    Feb 2007
    Location
    USA
    Posts
    6,582
    Quote Originally Posted by Maeg View Post
    a message of error always shows up as soon as I change the resolution. The message prompts me to install DirectX 9c, December 2005 (which is actually in the list of DirectX which I've reinstalled).
    This should fix you up according to the symptom you just described.

  6. #6
    Join Date
    Jun 2011
    Posts
    18
    Quote Originally Posted by Hurin View Post
    This should fix you up according to the symptom you just described.
    Yes!
    It works! Thanks a lot, Hurin!*



    *Ok, there's still the issue that each time I start the client I have to use the default settings (DX9 & 1024x768), and then, in the character selection screen, I'm able to change the resolution and the version of DX. But If I try to restart the game with non-default settings it still crashes.

  7. #7
    Join Date
    Jul 2016
    Location
    UK
    Posts
    2,821
    Quote Originally Posted by Maeg View Post
    Yes!
    It works! Thanks a lot, Hurin!*



    *Ok, there's still the issue that each time I start the client I have to use the default settings (DX9 & 1024x768), and then, in the character selection screen, I'm able to change the resolution and the version of DX. But If I try to restart the game with non-default settings it still crashes.
    Sounds stupid, but try replacing your GFX driver, even if it is with a fresh copy of exactly the same version you were already using.

  8. #8
    Join Date
    Feb 2007
    Location
    USA
    Posts
    6,582
    Yarbro is correct. Next step would be updating your graphics driver. Re-installing if it's already up-to-date.

    I'm going to paste my "bag of tricks" in the order I'd try them in your case. I realize you've likely already done many of these. But I'd still recommend that they be done/re-done to rule things out. Note that deleting your UserPreferences.ini (and remembering to then re-add ForceFakeFullscreen, etc.) at several points throughout the process is recommended. Please don't skip to it, but I'm especially thinking of step #5 below as one that might help. But *after* you reinstall your gpu drivers (etc.).

    1. Delete/rename UserPreferences.ini file in order to reset all LotRO settings in hopes of removing any setting that has somehow become a catalyst for this behavior. LotRO will regenerate a new/default one upon next launch.

    2. Install/reinstall the Visual C++ 2005 and 2010 runtimes from here and here.

    3. Reinstall DirectX runtimes (be careful of checkboxes attempting to foist MS's "Bing Bar" and such on you during download and install).

    (I'd again delete my UserPreferences.ini file again as in step #1 before going any further).

    4. Try "ForceFakeFullscreen=True" in the UserPreferences.ini file as described here.

    5. This is a bit of grasping at straws. . . try installing (newest) nvidia driver if you haven't already. Then. . . go into nvidia control panel (not just Windows display settings) and set your screen resolution to one that is non-native for your monitor. Try LotRO. Then reboot. Go into nvidia control panel and set resolution to monitor's native resolution. Reboot. Try LotRO.

    Believe it or not, there is method to this madness and it apparently helped someone prior even though I only posted it on a hunch.

    6. Adjust "DisplayAdapter=0" in UserPreferences.ini (this is very unlikely to help on a single-GPU system. . . but can't hurt since you can always change it back or delete the UserPreferences.ini altogether).


    . . . change that to 1 or 2 (or 3!) and try each.

    7. Whenever you try a few things that don't actually work, re-deleting/renaming the UserPreferences.ini file to get it back to defaults isn't a bad idea.

    --H

    P.S. Is this a laptop? Desktop? nvidia, amd, or intel gpu?

  9. #9
    Join Date
    Jul 2016
    Location
    UK
    Posts
    2,821
    I have kept an open mind towards electronic and software solutions ever since I found it was an energy saver light bulb buggering up my PC and hifi system nearly 25 years ago.

  10. #10
    Join Date
    Jun 2011
    Posts
    18
    Quote Originally Posted by Yarbro View Post
    Sounds stupid, but try replacing your GFX driver, even if it is with a fresh copy of exactly the same version you were already using.
    I've tried that. Regrettably it didn't work.

    Thanks, anyway!

  11. #11
    Join Date
    Jun 2011
    Posts
    18
    Quote Originally Posted by Hurin View Post
    Yarbro is correct. Next step would be updating your graphics driver. Re-installing if it's already up-to-date.

    I'm going to paste my "bag of tricks" in the order I'd try them in your case. I realize you've likely already done many of these. But I'd still recommend that they be done/re-done to rule things out. Note that deleting your UserPreferences.ini (and remembering to then re-add ForceFakeFullscreen, etc.) at several points throughout the process is recommended. Please don't skip to it, but I'm especially thinking of step #5 below as one that might help. But *after* you reinstall your gpu drivers (etc.).

    1. Delete/rename UserPreferences.ini file in order to reset all LotRO settings in hopes of removing any setting that has somehow become a catalyst for this behavior. LotRO will regenerate a new/default one upon next launch.

    2. Install/reinstall the Visual C++ 2005 and 2010 runtimes from here and here.

    3. Reinstall DirectX runtimes (be careful of checkboxes attempting to foist MS's "Bing Bar" and such on you during download and install).

    (I'd again delete my UserPreferences.ini file again as in step #1 before going any further).

    4. Try "ForceFakeFullscreen=True" in the UserPreferences.ini file as described here.

    5. This is a bit of grasping at straws. . . try installing (newest) nvidia driver if you haven't already. Then. . . go into nvidia control panel (not just Windows display settings) and set your screen resolution to one that is non-native for your monitor. Try LotRO. Then reboot. Go into nvidia control panel and set resolution to monitor's native resolution. Reboot. Try LotRO.

    Believe it or not, there is method to this madness and it apparently helped someone prior even though I only posted it on a hunch.

    6. Adjust "DisplayAdapter=0" in UserPreferences.ini (this is very unlikely to help on a single-GPU system. . . but can't hurt since you can always change it back or delete the UserPreferences.ini altogether).


    . . . change that to 1 or 2 (or 3!) and try each.

    7. Whenever you try a few things that don't actually work, re-deleting/renaming the UserPreferences.ini file to get it back to defaults isn't a bad idea.

    --H

    P.S. Is this a laptop? Desktop? nvidia, amd, or intel gpu?
    Thanks for the tips, I'll try them all tomorrow!

    I'm using a desktop computer, Intel Core i7-8700, 3.20GHz, and the graphic driver is NVIDIA GeForce Game Ready v. 416.94, updated today, date of realease 13 Nov. In my opinion, it shouldn't give me any kind of problem!

  12. #12
    Join Date
    Jul 2016
    Location
    UK
    Posts
    2,821
    Quote Originally Posted by Maeg View Post
    Thanks for the tips, I'll try them all tomorrow!

    I'm using a desktop computer, Intel Core i7-8700, 3.20GHz, and the graphic driver is NVIDIA GeForce Game Ready v. 416.94, updated today, date of realease 13 Nov. In my opinion, it shouldn't give me any kind of problem!
    NV cards dont like dx9 any longer, at least not in LOTRO; they should work on dx10/11, but those dx settings can cause their own problems, especially in the known hotspots like Minas Tiruth.

    NV are trying to drop dx9 support on their cards, tried it once and put back a ballsed up version when too many gamers complained. A bit like M$ ballsed up XP and then Win7, when trying to move people on to their shiniest new OS.

    AMD have hinted at dropping dx9 support as well...........

  13. #13
    Join Date
    Feb 2007
    Location
    USA
    Posts
    6,582
    Quote Originally Posted by Yarbro View Post
    NV cards dont like dx9 any longer, at least not in LOTRO; they should work on dx10/11, but those dx settings can cause their own problems, especially in the known hotspots like Minas Tiruth.

    NV are trying to drop dx9 support on their cards, tried it once and put back a ballsed up version when too many gamers complained. A bit like M$ ballsed up XP and then Win7, when trying to move people on to their shiniest new OS.

    AMD have hinted at dropping dx9 support as well...........
    LotRO in DirectX 9 mode works fine on nvidia cards so long as the fix already mentioned above is implemented (ForceFakeFullscreen).

    Regardless, this person is actually having trouble launching the game in DX10/11 after he switches to it from DX9.

  14. #14
    Join Date
    Jul 2016
    Location
    UK
    Posts
    2,821
    Quote Originally Posted by Hurin View Post
    LotRO in DirectX 9 mode works fine on nvidia cards so long as the fix already mentioned above is implemented (ForceFakeFullscreen).

    Regardless, this person is actually having trouble launching the game in DX10/11 after he switches to it from DX9.
    Sorry, I cross posted with another thread about gfx issues.

    To me it sounds like the files/ some of the files are corrupted and not overwriting; this might be down to system protection settings, Hurin might know more than me, as I refuse to use Win10.

    There is a bug that appeared in Win95 and was still there in Win7 that stopped a file being overwritten sometime if it was corrupted. The ONLY way to fix it was to manually delete the file, reboot and install the new file; since I dont know Win10, I dont know if this bug is still there.

    There are a few registry hacks to remove dx files, but again, they only cover up to Win7, so may not work on Win10.

    One disturbing thought.

    Has something gone wrong with the card?

    Do you have any other games you play, and are they working correctly. If a VRAM chip has gone bad, the card may still work at low rez, where that chip isnt being used; but crash and burn when a high rez is selected and the bad chip get sent data.

  15. #15
    Join Date
    Feb 2007
    Location
    USA
    Posts
    6,582
    Seems like we're losing focus. Maeg, I'll drop back by in a few days. I hope that list of steps helps. Let us know.

    --H

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

This form's session has expired. You need to reload the page.

Reload