We have detected that cookies are not enabled on your browser. Please enable cookies to ensure the proper experience.
Results 1 to 13 of 13
  1. #1
    Join Date
    Jun 2011
    Location
    UK - London
    Posts
    29

    Resolved: Trouble with 4k monitor

    OK so I have a k monitor but want to play LOTRO at 1080 but when I choose the resolution in game and set it to 1080 it just resizes it to take up a quarter of my screen in the corner.

    What do I need to do to sort this out?

    Thanks


    Resolution:

    For me what worked was actually quite simple. I changed the DirectX to version 9 in the LOTRO options and everything worked fine.
    This is quite buggy, you can't change the resolution in the mode that you are using or it crashes so put it into windowed mode, then change the full screen resolution to what you want (1440 for me now) then you can put the game into Full screen mode and it should work fine.

    Of course what works for me might not work for you. Good Luck.
    Last edited by Ravbek; Nov 14 2018 at 05:15 AM.

  2. #2
    Join Date
    Mar 2007
    Posts
    1,884
    Sounds like you are running in Windowed mode. Once in game set it to full screen mode - it's either ALT-ENTER or CTRL-ENTER
    "You can't fight the Enemy with his own Ring without turning into an Enemy" - J.R.R. Tolkien, Letter # 81



  3. #3
    Join Date
    Jun 2011
    Location
    UK - London
    Posts
    29
    It does it in all modes, windowed, full screen and windowed full screen.

  4. #4
    Join Date
    Mar 2007
    Posts
    1,884
    All I can think of is that you'll have to change your desktop res to 1080p before launching the game. That kinda sucks though.
    "You can't fight the Enemy with his own Ring without turning into an Enemy" - J.R.R. Tolkien, Letter # 81



  5. #5
    Join Date
    Jun 2011
    Location
    UK - London
    Posts
    29
    Yep that would kind of suck and it doesn't really work either. LOTRO still see the monitor as 4k.

    Problem is that i've had to use an old GFX card, my newer one broke so I can't play at 4k. I'm now stuck playing in a mid sized window...bit annoying.

  6. #6
    Join Date
    Mar 2007
    Posts
    1,884
    I don't know if it would help but have you tried the option in the launcher to reset the gfx?
    "You can't fight the Enemy with his own Ring without turning into an Enemy" - J.R.R. Tolkien, Letter # 81



  7. #7
    Join Date
    Jun 2011
    Location
    Germany Middle Frankonia
    Posts
    47
    Try this:

    Go to you install dir, right click on lotroclient.exe and select properties. Then change to compatibility tab and click on the button on the bottom (change High DPI settings, I'm not on english Windows so I have to translate everything)

    Change the bottom setting to Application, save and give it a try.

  8. #8
    Join Date
    Jun 2011
    Location
    Heywood, Lancs
    Posts
    1,505
    I had the very same issue a while back when I upgraded to 4K

    Solution is quite simple but took me a while to figure it out

    It's in your Graphics Card settings

    I have a Radeon RX580 so not sure what it is called on an NVidia card

    Go into your monitor settings and ENABLE Super Video Resolution

    Restart Lotro
    Set Res to desired output and run in full screen

    Worked for me, now I can run in all res's upto and including 4096x2160

    The ONLY issue I have now is the Launcher
    At 4K it is tiny and can only just make out the server names 1 at a time

    Wish they could make it scalable
    Core P9 | ROG Crosshair VI Hero | AMD Ryzen 7 1800X | 64Gb RAM | RX 580 8Gb (x2) | LG BD-RE | 512GB Samsung 960 PRO M.2 NVMe SSD | Win10 Pro | WEI - 9.8

  9. #9
    Join Date
    Jun 2011
    Location
    UK - London
    Posts
    29
    Thanks for all your advice. I'll try these things when I get home and let you know if they worked for me.

  10. #10
    Join Date
    Jun 2011
    Location
    UK - London
    Posts
    29
    Unfortunately none of the advise above has worked

    Why is this so broken...

    Malin I can't find the setting in nvidia and the setting which sound similar don't do antying.

  11. #11
    Join Date
    Jun 2011
    Location
    Heywood, Lancs
    Posts
    1,505
    Quote Originally Posted by Ravbek View Post
    Unfortunately none of the advise above has worked

    Why is this so broken...

    Malin I can't find the setting in nvidia and the setting which sound similar don't do antying.
    My bad,

    It's actually called Virtual Super Resolution (see attached screenie)

    https://1drv.ms/u/s!AiVfkh6CX_pOidwHBRcfqy5r_bE5TA

    I had the same issue with several of my games, not just Lotro
    All would appear as full screen but just in top left corner of my main monitor LG 4K UHD

    Once I enabled VSR they shifted to PROPER full screen

    However, VSR does NOT work via Display Port connection
    Core P9 | ROG Crosshair VI Hero | AMD Ryzen 7 1800X | 64Gb RAM | RX 580 8Gb (x2) | LG BD-RE | 512GB Samsung 960 PRO M.2 NVMe SSD | Win10 Pro | WEI - 9.8

  12. #12
    Join Date
    Jun 2011
    Location
    UK - London
    Posts
    29
    Ok more things to try

    I'm using the same monitor and currently have it via display port. i'll try using HDMI later to see if that makes any difference.

  13. #13
    Join Date
    Jun 2011
    Location
    UK - London
    Posts
    29
    Thanks for all the help everyone, I have now been able to solve my problems. Simply using DirectX 9 fixes the issue...although it a bit unstable when changing resolutions.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

This form's session has expired. You need to reload the page.

Reload