We have detected that cookies are not enabled on your browser. Please enable cookies to ensure the proper experience.
Results 1 to 11 of 11
  1. #1

    Launcher is going straight to desktop

    Launcher is going straight to desktop. There is no error message and I have no trouble entering my password. I was last playing on Thursday when my graphics card went bad, flickering and losing lines of the picture on login. I turned off my computer and have replaced my graphics card. I run on Windows 7 Pro. I recall having a similar problem years ago with the login problem and I was told to rename my Turbine folder or something like that.

  2. #2
    Join Date
    Oct 2012
    Location
    Lancashire, UK
    Posts
    1,896
    Don't know if this will work but try clicking on the little down arrow at the top right of the Launcher and select Options and then click the check-box for repair display settings and then OK.

  3. #3
    Join Date
    Feb 2007
    Location
    USA
    Posts
    6,582
    A silent crash to desktop directly from launcher is also a symptom of certain pre-requisites missing/corrupted. The install guide in my signature covers them. But. . . shorter version:

    You need to have these installed. . .

    1. Install DirectX runtimes from here. Be careful to uncheck other "offers" as you download and install.
    2. Install 'Microsoft Visual C++ 2005 Redistributable' (note: not x64 version). Download and install it from here.
    3. Install 'Microsoft Visual C++ 2010 Redistributable' (note: not x64 version). Download and install it from here.


    There is no harm in reinstalling. So, when in doubt, I'd reinstall. Then check for Windows Updates to re-patch them.

  4. #4
    I hesitate reinstalling since my connection is DSL and takes a couple days to download the game.

  5. #5
    I currently am listed as using proxy settings, but have nothing in the address or port settings. Should I try no proxy or add settings for address and port (although I don't know what to put there).

  6. #6
    Join Date
    Feb 2007
    Location
    USA
    Posts
    6,582
    Quote Originally Posted by Elrohir_of_Kellemar View Post
    I hesitate reinstalling since my connection is DSL and takes a couple days to download the game.
    Was only urging the reinstallation of those three items. Not the game.

    --H

  7. #7
    Hmmm,... I am now having this same problem caused by the same thing.

    My video card died. When I installed the new one, everything else seems to work except the LOTRO Launcher.

    The Launcher starts and accepts my logon account and password, however, rather than getting me into the game it silently closes and I am back to the desktop.

    I reinstalled the 3 software goodies mentioned above to no avail.

    Can anyone help?

    Windows 7 64 bit
    Intel i7 3.4 GHz
    8 GB RAM
    8GB Radeon RX580 (new)

  8. #8
    Join Date
    Jul 2016
    Location
    UK
    Posts
    3,112
    Quote Originally Posted by BlackjackBadlag View Post
    Hmmm,... I am now having this same problem caused by the same thing.

    My video card died. When I installed the new one, everything else seems to work except the LOTRO Launcher.

    The Launcher starts and accepts my logon account and password, however, rather than getting me into the game it silently closes and I am back to the desktop.

    I reinstalled the 3 software goodies mentioned above to no avail.

    Can anyone help?

    Windows 7 64 bit
    Intel i7 3.4 GHz
    8 GB RAM
    8GB Radeon RX580 (new)
    Try deleting your LOTRO user folder and let the game create a new one, just in case.

    Also, did you reinstall the dx9 files before or after wiping the previous gfx card drivers and installing the new ones??

  9. #9
    Join Date
    Feb 2007
    Location
    USA
    Posts
    6,582
    Quote Originally Posted by Yarbro View Post
    Try deleting your LOTRO user folder and let the game create a new one, just in case.
    I hope they make a copy first!

    Deleting the folder as a whole will delete keyboard mappings, screenshots, plug-ins (not necessarily a bad thing), music, saved UI layouts, etc.

    It's far safer, as an initial trouble-shooting step, to delete/move/rename the UserPreferences.ini file which contains all game settings likely to have an effect on the issue. Only if that fails would I consider renaming/moving the folder as a whole to then rule out plug-ins, etc.

    Good Luck, Blackjackbadlag!

    --H

  10. #10
    Join Date
    Jan 2007
    Posts
    111

    Smile

    Quote Originally Posted by Hurin View Post
    I hope they make a copy first!

    Deleting the folder as a whole will delete keyboard mappings, screenshots, plug-ins (not necessarily a bad thing), music, saved UI layouts, etc.

    It's far safer, as an initial trouble-shooting step, to delete/move/rename the UserPreferences.ini file which contains all game settings likely to have an effect on the issue. Only if that fails would I consider renaming/moving the folder as a whole to then rule out plug-ins, etc.

    Good Luck, Blackjackbadlag!

    --H
    I also had this issue with my EVGA 4K laptop. Tried all of the other installs with no luck. Went and renamed userpreferences.ini and that did the trick. Back in the game.
    All who wander are not lost... Stix
    .

  11. #11
    My game is now crashing to desktop whenever I log in as soon as my characters start to rendering on the character page.

    Just tried the above mentioned installs, as well as deleting the lotro folder with the ini data?

    Anyone have any ideas other than a complete unisntall and reinstall?

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

This form's session has expired. You need to reload the page.

Reload