We have detected that cookies are not enabled on your browser. Please enable cookies to ensure the proper experience.
Results 1 to 5 of 5
  1. #1

    PatchClientDLL::CheckDatFiles Failed

    Hi, for the past two days, presumably since the latest patch, I cannot log in to the game any more. The launcher starts, then gives this error message:

    PatchClientDLL::CheckDatFiles Failed. [Unable to decrypt and deserialize the data downloaded from the server.]

    What should I do? I have an exemption for LotRO in my virus scanner already; anyway, that hasn't been a problem for a long time.

    I use Windows10.

  2. #2
    Quote Originally Posted by Schlimmli View Post
    Hi, for the past two days, presumably since the latest patch, I cannot log in to the game any more. The launcher starts, then gives this error message:

    PatchClientDLL::CheckDatFiles Failed. [Unable to decrypt and deserialize the data downloaded from the server.]

    What should I do? I have an exemption for LotRO in my virus scanner already; anyway, that hasn't been a problem for a long time.

    I use Windows10.
    I have the exact same thing!
    (I use Windows 7 Ultimate)

  3. #3
    You might try this:

    Quote Originally Posted by Cordovan View Post
    We have reverted a change that we believe caused this. People currently getting an error message when trying to launch the game launcher need to take a step to resolve this issue. There's a longer and shorter way to correct this issue for you. The longer way is to use the Repair option in the launcher, but that does mean a large download. The shorter way is to close the game client entirely (including task bar), go into your LOTRO install file (only do this if you are comfortable doing this) and delete client_highres_aux_2.datx. Then, re-launch the launcher.

    I do not have an english Windows Operation System so things might be called different.

    Close the Lotro Launcher and make sure it isn't just minimized to task bar!

    1. Right click on the shortcut to the LotroLauncher on your Desktop
    2. choose the option below OPEN in the context menu (should be something like Open file path)
    3. sort the content in the folder that should have opened by date or search the name of the file client_highres_aux_2.datx by name (should be the latest or one of the latest files, about 34 MB)
    4. right click on that file and choose Delete from the context menu or left click it once and press DEL-Key on your keyboard to move it to the waste bin
    5. Double click on shortcut to relaunch the game

  4. #4
    Join Date
    Sep 2016
    Posts
    2,079
    If you were impacted by an issue on Wednesday evening and Thursday morning that is causing the following error message when trying to launch the game client:

    PatchClientDLL::CheckDatFiles Failed. [Unable to decrypt and deserialize the data downloaded from the server.]

    There are two things you can do:

    1. A full Repair using the Options in the game launcher. This will be a large download.

    2. You can go into your game's install directory and delete only the following: client_highres_aux_2.datx

    So, close the launcher and remove from task bar if applicable, go into directory, delete the .datx, re-launch the launcher. It'll redownload the .datx in a smaller update and you should be fixed.

    Further help can be found at help.standingstonegames.com.
    Community Manager, Lord of the Rings Online
    Follow LOTRO on: Twitter - Facebook - Google+ - Pinterest - Twitch - YouTube
    Find Cordovan on: Twitter Instagram
    Support: help.standingstonegames.com
    coolcool

  5. #5
    Thanks everyone, I had since found this thread:
    https://www.lotro.com/forums/showthr...PatchClientDLL

    and followed the advice therein to use the repair function, which took forever, but I'm now able to log in again. Hopefully, that will keep.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

This form's session has expired. You need to reload the page.

Reload