We have detected that cookies are not enabled on your browser. Please enable cookies to ensure the proper experience.
Page 2 of 2 FirstFirst 1 2
Results 26 to 29 of 29
  1. #26

    Same Issue

    Hi everybody,

    sorry to push the thread once more, but is there still no solution for this issue?

    I´m having the same issue with the client.

    Downloading everything, showing 100% and than nothing more.
    Reloading the launcher starts the whole sh** again.

    Best regards
    Kerrangg

  2. #27
    Two weeks in, been downloading, erasing, repairing over countless times and it still doesn't work. Luckily I have a pc where I can play the game but I need it on the Mac as well for when I go travelling etc.

    Looks like the company has abandoned its MAC users completely, very little info, no damage control.
    FeelsBadMan

  3. #28
    Same issue on Linux with latest patch.
    Linux is not officially supported but I never had issue until now.

    "Solution" is to upgrade the game under a Windows Virtual Machine... and game is working now, sad.

  4. #29

    Installing game files issue

    Quote Originally Posted by Mundungas View Post
    I'm have been running LOTRO on my late 2013 iMac for several years without much problem. A week or so ago after an update, I started having problems. When I launched the client, it would do the usual functions of Checking files : Patch files dat -- completed, Files Done!, Iterations Done! Dat files .. and then it begins downloading x of 13952 files. If it DOES complete this action and download ALL THIS FILES, it will go to Applying iterations, but I never get to the login screen. Sometimes I will get stuck and lock during this phase. I have DL'd the game ?? times.

    Things I have tried: Deleting and redownloading from Lotro install page. Deleting and load/installing using STEAM. I have kept Time Machine turned off during all this time. I DID update to Mojave today, which made no difference, but the problems started before I did that. No new software/apps were installed when the change occured.

    Ideas?
    This same #### is happening to me and happened after that morgul update, have submitted a ticket and they are useless did not offer solutions to fix the problem?

    Thoughts on how to get this fixed i tried through website and now steam with no luck, the patch just keeps redownloading the dat files over and over again?

 

 
Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

This form's session has expired. You need to reload the page.

Reload