We have detected that cookies are not enabled on your browser. Please enable cookies to ensure the proper experience.
Results 1 to 19 of 19
  1. #1

    Client will not patch

    I'm have been running LOTRO on my late 2013 iMac for several years without much problem. A week or so ago after an update, I started having problems. When I launched the client, it would do the usual functions of Checking files : Patch files dat -- completed, Files Done!, Iterations Done! Dat files .. and then it begins downloading x of 13952 files. If it DOES complete this action and download ALL THIS FILES, it will go to Applying iterations, but I never get to the login screen. Sometimes I will get stuck and lock during this phase. I have DL'd the game ?? times.

    Things I have tried: Deleting and redownloading from Lotro install page. Deleting and load/installing using STEAM. I have kept Time Machine turned off during all this time. I DID update to Mojave today, which made no difference, but the problems started before I did that. No new software/apps were installed when the change occured.

    Ideas?

  2. #2
    Join Date
    Jul 2016
    Location
    UK
    Posts
    2,704
    Quote Originally Posted by Mundungas View Post
    I'm have been running LOTRO on my late 2013 iMac for several years without much problem. A week or so ago after an update, I started having problems. When I launched the client, it would do the usual functions of Checking files : Patch files dat -- completed, Files Done!, Iterations Done! Dat files .. and then it begins downloading x of 13952 files. If it DOES complete this action and download ALL THIS FILES, it will go to Applying iterations, but I never get to the login screen. Sometimes I will get stuck and lock during this phase. I have DL'd the game ?? times.

    Things I have tried: Deleting and redownloading from Lotro install page. Deleting and load/installing using STEAM. I have kept Time Machine turned off during all this time. I DID update to Mojave today, which made no difference, but the problems started before I did that. No new software/apps were installed when the change occured.

    Ideas?
    Since no other Mac players have answered yet....

    Plus a warning, I am not a Mac user, so these are just ideas.


    1/ Turn off AV/ Firewall while you download and install; on the Windows side there are plenty of issues with AV deleting/corrupting files and Firewalls blocking lotro.exe.

    2/ Check to see if you are using the older turbine version of the launcher; SSG replaced it a few months ago with a new version, but DIDNT make it an automatic install, so the new version "lotrolauncher" is in the game folder, but the desktop icon still points to the old "turbinelauncher".

    3/ Due to 1/ sometimes files get corrupted and dont overwrite correctly, so delete the entire game folder and reboot before trying a fresh download.


    The above have all sorted issues with Windows installs; also check out the Mac forums for recent issues with 32bit programs, as Apple are going 64bit only, and you may need to make a few adjustments to the OS settings.

  3. #3
    Quote Originally Posted by Mundungas View Post
    I'm have been running LOTRO on my late 2013 iMac for several years without much problem. A week or so ago after an update, I started having problems. When I launched the client, it would do the usual functions of Checking files : Patch files dat -- completed, Files Done!, Iterations Done! Dat files .. and then it begins downloading x of 13952 files. If it DOES complete this action and download ALL THIS FILES, it will go to Applying iterations, but I never get to the login screen. Sometimes I will get stuck and lock during this phase. I have DL'd the game ?? times.

    Things I have tried: Deleting and redownloading from Lotro install page. Deleting and load/installing using STEAM. I have kept Time Machine turned off during all this time. I DID update to Mojave today, which made no difference, but the problems started before I did that. No new software/apps were installed when the change occured.

    Ideas?
    Hi Mundungas,

    Have you tried in a different user?

    If not, try it.You create a user from System preferences ? user and groups. Make sure to create a user with admin privileges and then try launching the app again.

    Also, when is got to the point where is applying te iteration and get stuck, what happens if you force quit the launcher and open it again?

    Let me know if the new users helps.

    Andrea

  4. #4
    Quote Originally Posted by amosconi View Post
    Hi Mundungas,

    Have you tried in a different user?


    Andrea
    Yes, and sadly, it didn't work. Really strange. I downloaded from Lotro.com's page. It goes thru install of the game. Then it patches (11 GB)... applies iterations, and then once that is thru, it wants to download and patch again.. repeat.

    On the bright side, this has convinced me to order a mid-range priced gaming PC, which will run LOTRO at max plus other newer games. Amazon will deliver it tomorrow.

    M

  5. #5
    Join Date
    Jul 2016
    Location
    UK
    Posts
    2,704
    Quote Originally Posted by Mundungas View Post
    Yes, and sadly, it didn't work. Really strange. I downloaded from Lotro.com's page. It goes thru install of the game. Then it patches (11 GB)... applies iterations, and then once that is thru, it wants to download and patch again.. repeat.

    On the bright side, this has convinced me to order a mid-range priced gaming PC, which will run LOTRO at max plus other newer games. Amazon will deliver it tomorrow.

    M
    Ok, so it goes all the way through without throwing any error messages?

    Check it isnt being auto sandboxed by your AV or Firewall

  6. #6
    Quote Originally Posted by Yarbro View Post
    Ok, so it goes all the way through without throwing any error messages?

    Check it isnt being auto sandboxed by your AV or Firewall
    I have avast and have all "shields" "disabled". Also have Time Machine backup turned off.

    No, no error messages. I have noted that sometimes after patching... there will be a message to the effect that it has patched x number of files, and is at 100% and no further activity is occurring. At that point, I would close then reopen the client and it would start over downloading 11 GB... and I only have 15 mips Uverse service. :\ .

  7. #7
    Join Date
    Jul 2016
    Location
    UK
    Posts
    2,704
    Quote Originally Posted by Mundungas View Post
    I have avast and have all "shields" "disabled". Also have Time Machine backup turned off.

    No, no error messages. I have noted that sometimes after patching... there will be a message to the effect that it has patched x number of files, and is at 100% and no further activity is occurring. At that point, I would close then reopen the client and it would start over downloading 11 GB... and I only have 15 mips Uverse service. :\ .
    I also have Avast, and I have noted it STILL messes with stuff, even when all shields are disabled; however sandboxing can also done by other things like the firewall - Comodo has an auto sandbox feature for example (mine is disabled).

    I would wait next time though, even though the installer may say 100%, it may not have finished cleaning up background tasks, temp files etc; and some installer programs auto roll-back changes if they are interrupted.

    If it hasnt closed all by itself after a couple of minutes, THEN I would try to have a look to see what it was doing.

    One other thing, is to make sure the program has write privileges now Akamai isnt being used, this may be an issue.

  8. #8
    Join Date
    Feb 2007
    Location
    Philadelphia, PA
    Posts
    3,116
    Quote Originally Posted by Mundungas View Post
    I'm have been running LOTRO on my late 2013 iMac for several years without much problem. A week or so ago after an update, I started having problems. When I launched the client, it would do the usual functions of Checking files : Patch files dat -- completed, Files Done!, Iterations Done! Dat files .. and then it begins downloading x of 13952 files. If it DOES complete this action and download ALL THIS FILES, it will go to Applying iterations, but I never get to the login screen. Sometimes I will get stuck and lock during this phase. I have DL'd the game ?? times.

    Things I have tried: Deleting and redownloading from Lotro install page. Deleting and load/installing using STEAM. I have kept Time Machine turned off during all this time. I DID update to Mojave today, which made no difference, but the problems started before I did that. No new software/apps were installed when the change occured.

    Ideas?

    Apologies for the late response. Sigh, Vbulletin no longer notifies me of new posts in the Mac Techincal Support forum . . .

    There was a change in the Launcher with Update 23 which apparently impacts patching of the Mac Client.
    However . . .

    Part of that change included a new feature in the Launcher "Repair Game Data".

    Use the pulldown arrow at the top right of the launcher -- select Options.
    On the options pull-down select the Repair tab, click "Repair Game Data"

    What this does is to erase certain data files and force them to be re-downloaded again. Using this option seems to clear up the "hang" after patching.

    One thing to keep in mind: One of the files erased is the 4.29 Gig "Client_highres.dat" file -- so the re-download can take a while.

    I have not had any problems patching since using the repair option.
    Bill Magill Mac Player Founder/Lifetimer
    Old Timers Guild - Gladden
    Sr. Editor LOTRO-Wiki.com

    Val - Man Minstrel (108)
    Valalin - Dwarf Minsrel (71)
    Valamar - Dwarf Hunter (120)
    Valdicta - Dwarf RK (107)
    Valhad - Elf LM (66)
    Valkeeper - Elf RK (87)
    Valwood - Dwarf RK (81)

    Valhunt - Dwarf Hunter (71)
    Valanne - Beorning (105)
    Ninth - Man Warden (66)

    "Laid back, not so serious, no drama.
    All about the fun!"


  9. #9
    Join Date
    Feb 2007
    Location
    Philadelphia, PA
    Posts
    3,116
    Quote Originally Posted by Yarbro View Post
    If it hasnt closed all by itself after a couple of minutes, THEN I would try to have a look to see what it was doing.
    Sadly, the LOTRO Launce (and game client) do not log any meaningful (i.e. useful) information.
    If fact, much of what is logged is purely . . .
    Bill Magill Mac Player Founder/Lifetimer
    Old Timers Guild - Gladden
    Sr. Editor LOTRO-Wiki.com

    Val - Man Minstrel (108)
    Valalin - Dwarf Minsrel (71)
    Valamar - Dwarf Hunter (120)
    Valdicta - Dwarf RK (107)
    Valhad - Elf LM (66)
    Valkeeper - Elf RK (87)
    Valwood - Dwarf RK (81)

    Valhunt - Dwarf Hunter (71)
    Valanne - Beorning (105)
    Ninth - Man Warden (66)

    "Laid back, not so serious, no drama.
    All about the fun!"


  10. #10

    I am having the exact same problem!

    Same here, once it downloads and applies 8841 patches, it just remains there, saying 'Done applying 8841 patch(s).'

    I have uninstalled the game 3 times and even tried both steam and the websites download link, both running into the same problem.

    this is a link to a screenshot of the launch freeze:

    https://ibb.co/duMwHf

  11. #11
    Join Date
    Feb 2007
    Location
    Philadelphia, PA
    Posts
    3,116
    Quote Originally Posted by Brandon8260 View Post
    Same here, once it downloads and applies 8841 patches, it just remains there, saying 'Done applying 8841 patch(s).'

    I have uninstalled the game 3 times and even tried both steam and the websites download link, both running into the same problem.

    this is a link to a screenshot of the launch freeze:
    Have you read this thread and used the "Repair Game Data" function of the Launcher?
    Bill Magill Mac Player Founder/Lifetimer
    Old Timers Guild - Gladden
    Sr. Editor LOTRO-Wiki.com

    Val - Man Minstrel (108)
    Valalin - Dwarf Minsrel (71)
    Valamar - Dwarf Hunter (120)
    Valdicta - Dwarf RK (107)
    Valhad - Elf LM (66)
    Valkeeper - Elf RK (87)
    Valwood - Dwarf RK (81)

    Valhunt - Dwarf Hunter (71)
    Valanne - Beorning (105)
    Ninth - Man Warden (66)

    "Laid back, not so serious, no drama.
    All about the fun!"


  12. #12
    Quote Originally Posted by Valamar View Post
    Have you read this thread and used the "Repair Game Data" function of the Launcher?

    yeahh tried it a couple times already, is there anything more i can do?

    I will attempt to reinstall it again tonight, i'll keep you posted

    Thanks for the help dude!

  13. #13
    Quote Originally Posted by Valamar View Post
    Have you read this thread and used the "Repair Game Data" function of the Launcher?
    I managed to pass this issue,

    Once all patchs are done, I just had to select "Repair Game Data" around 3 times, after each was complete, the number of patchs got smaller each time.

    Also, this time, I installed the high graphic content,(not actually sure if this did anything though as im sure it was just the repeating of the the above that fixed it).

    Anyway, not able to login after 3 days of attempting to get it to work as maintenance is underway lol

    Thanks guys!

  14. #14
    Join Date
    Feb 2007
    Location
    Philadelphia, PA
    Posts
    3,116
    Quote Originally Posted by Brandon8260 View Post
    I managed to pass this issue,

    Once all patchs are done, I just had to select "Repair Game Data" around 3 times, after each was complete, the number of patchs got smaller each time.
    No idea why that happens, but it seems to do the trick.

    Maybe with the 64-bit client this kind of issue will go away. . .
    Bill Magill Mac Player Founder/Lifetimer
    Old Timers Guild - Gladden
    Sr. Editor LOTRO-Wiki.com

    Val - Man Minstrel (108)
    Valalin - Dwarf Minsrel (71)
    Valamar - Dwarf Hunter (120)
    Valdicta - Dwarf RK (107)
    Valhad - Elf LM (66)
    Valkeeper - Elf RK (87)
    Valwood - Dwarf RK (81)

    Valhunt - Dwarf Hunter (71)
    Valanne - Beorning (105)
    Ninth - Man Warden (66)

    "Laid back, not so serious, no drama.
    All about the fun!"


  15. #15
    Quote Originally Posted by Brandon8260 View Post
    I managed to pass this issue,

    Once all patchs are done, I just had to select "Repair Game Data" around 3 times, after each was complete, the number of patchs got smaller each time.

    Also, this time, I installed the high graphic content,(not actually sure if this did anything though as im sure it was just the repeating of the the above that fixed it).

    Anyway, not able to login after 3 days of attempting to get it to work as maintenance is underway lol

    Thanks guys!

    Okay, I went to run the game, after the maintenance is done, and now i've got to download all 14k patchs again??

    Is this normal? cus it takes hours to complete each time..

  16. #16
    Join Date
    Feb 2007
    Location
    Philadelphia, PA
    Posts
    3,116
    Quote Originally Posted by Brandon8260 View Post
    Okay, I went to run the game, after the maintenance is done, and now i've got to download all 14k patchs again??

    Is this normal? cus it takes hours to complete each time..
    This "maintenance" was, in fact, a "hot-fix" (23.1.3) complete with release notes. https://www.lotro.com/forums/showthr...-Release-Notes
    Bill Magill Mac Player Founder/Lifetimer
    Old Timers Guild - Gladden
    Sr. Editor LOTRO-Wiki.com

    Val - Man Minstrel (108)
    Valalin - Dwarf Minsrel (71)
    Valamar - Dwarf Hunter (120)
    Valdicta - Dwarf RK (107)
    Valhad - Elf LM (66)
    Valkeeper - Elf RK (87)
    Valwood - Dwarf RK (81)

    Valhunt - Dwarf Hunter (71)
    Valanne - Beorning (105)
    Ninth - Man Warden (66)

    "Laid back, not so serious, no drama.
    All about the fun!"


  17. #17
    I'm having all the same problems.

    I've been able to play with no issues up to this point. Opened up the launcher after the recent update, and it stops at a point and says "442 Failed [Unable to decrypt and de-serialize the data downloaded from the server.]"

    Tried the "Repair" function several times with no change. Completely uninstalled and reinstalled the game with no change. Disabled all firewall/antivirus with no change.

    Anything else I can do?

  18. #18

    might be a little late

    Quote Originally Posted by Mundungas View Post
    I'm have been running LOTRO on my late 2013 iMac for several years without much problem. A week or so ago after an update, I started having problems. When I launched the client, it would do the usual functions of Checking files : Patch files dat -- completed, Files Done!, Iterations Done! Dat files .. and then it begins downloading x of 13952 files. If it DOES complete this action and download ALL THIS FILES, it will go to Applying iterations, but I never get to the login screen. Sometimes I will get stuck and lock during this phase. I have DL'd the game ?? times.

    Things I have tried: Deleting and redownloading from Lotro install page. Deleting and load/installing using STEAM. I have kept Time Machine turned off during all this time. I DID update to Mojave today, which made no difference, but the problems started before I did that. No new software/apps were installed when the change occured.

    Ideas?
    Okay so i might be a little late but i finally figured out a way around this. Why i didnt think of this when i started getting this error is beyond me. Basically what is going on is the file for the patch client is named wrong ( very annoying and why they did this is also beyond me ) they named it PatchClient.dylib instead of libpatchclient.dylib.


    [I]Here is how you fix it. [/I]
    right click on lord of the rings and go to options. Click on show in finder. then rick click again and click show package contents. click on contents. then go to MacOS. Right click on PatchClient.dylib and click rename. Rename it to libpatchclient.dylib. Then reopen the launcher and it works just fine. Hope this helps you guys on mac.

  19. #19
    Jumping in here because I have been having the same trouble.
    I did rename that file and the install seemed to get further along this time... then stuck.
    This was after another overnight download (I have tried several times in the past few days!) that was still moving this morning before freezing.
    Now trying the repair option and will keep checking over the next several hours.

    Is there a mirror site for the installer? Or an older version available somewhere to try?
    I used to play without issue before, don't understand why the developer hasn't addressed this properly.

    Anyway, thanks.




    Quote Originally Posted by TheRadicalG3 View Post
    Okay so i might be a little late but i finally figured out a way around this. Why i didnt think of this when i started getting this error is beyond me. Basically what is going on is the file for the patch client is named wrong ( very annoying and why they did this is also beyond me ) they named it PatchClient.dylib instead of libpatchclient.dylib.


    [I]Here is how you fix it. [/I]
    right click on lord of the rings and go to options. Click on show in finder. then rick click again and click show package contents. click on contents. then go to MacOS. Right click on PatchClient.dylib and click rename. Rename it to libpatchclient.dylib. Then reopen the launcher and it works just fine. Hope this helps you guys on mac.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

This form's session has expired. You need to reload the page.

Reload