We have detected that cookies are not enabled on your browser. Please enable cookies to ensure the proper experience.
Results 1 to 4 of 4
  1. #1

    Client won't start - update error

    After having been out of the game for a couple of months, I tried to get back on it earlier this week. Up to 'forward itinerations' no hitches, but then the client crashes. Re-installing did not help. Neither did temporary disabling my antivirus software.

    It looks something like this:



    and this:



    What is going on here, and can it possibly be solved? All help much appreciated!

  2. #2
    Join Date
    May 2012
    Posts
    44
    same problem here. except I played this morning and now 8 hrs later, I get the above screens.

    from the LotroLauncher.log
    2018.07.11 18:02:45[W] Data Center URL: QUrl( "http://moria.gls.lotro.com/GLS.DataCenterServer/Service.asmx" )

    2018.07.11 18:02:50[W] PatchFlow::OnPatchProductResul t - CheckDatFiles failure! err: "PatchClientDLL::CheckDatF iles Failed. [Unable to decrypt and de-serialize the data downloaded from the server.]"
    2018.07.11 18:02:50[W] ForwardPatch: false
    2018.07.11 18:02:50[W] HighDetail: true
    2018.07.11 18:02:50[C]
    2018.07.11 18:02:50[C] PatchFlow::AdmitFailure
    2018.07.11 18:02:50[C] PatchFlow::AdmitFailure [ "PatchClientDLL::CheckDatF iles Failed. [Unable to decrypt and de-serialize the data downloaded from the server.]" ]

    normallly PatchCLient.log says:
    000000003.280: Loading data patch dll.
    000000006.773: Response received from patchserver.
    000000006.773: Prepared to patch 782779 bytes of data.
    000000006.773: Patching data...
    000000006.773: Queueing download of <http://download.lotro.akamai.turbine...tch/iterations ....... etc

    now it says
    000000003.295: Loading data patch dll.
    000000003.295: Could not init the patchtime manager
    000000003.295: Failed to create a patchtime patching manager in <...\Steam\steamapps\common\lo rd of the rings online>: error 0x81930003
    Last edited by RustyShadow; Jul 11 2018 at 06:15 PM.

  3. #3
    Join Date
    Jul 2016
    Location
    UK
    Posts
    2,197
    Quote Originally Posted by RustyShadow View Post
    same problem here. except I played this morning and now 8 hrs later, I get the above screens.

    from the LotroLauncher.log
    2018.07.11 18:02:45[W] Data Center URL: QUrl( "http://moria.gls.lotro.com/GLS.DataCenterServer/Service.asmx" )

    2018.07.11 18:02:50[W] PatchFlow::OnPatchProductResul t - CheckDatFiles failure! err: "PatchClientDLL::CheckDatF iles Failed. [Unable to decrypt and de-serialize the data downloaded from the server.]"
    2018.07.11 18:02:50[W] ForwardPatch: false
    2018.07.11 18:02:50[W] HighDetail: true
    2018.07.11 18:02:50[C]
    2018.07.11 18:02:50[C] PatchFlow::AdmitFailure
    2018.07.11 18:02:50[C] PatchFlow::AdmitFailure [ "PatchClientDLL::CheckDatF iles Failed. [Unable to decrypt and de-serialize the data downloaded from the server.]" ]

    normallly PatchCLient.log says:
    000000003.280: Loading data patch dll.
    000000006.773: Response received from patchserver.
    000000006.773: Prepared to patch 782779 bytes of data.
    000000006.773: Patching data...
    000000006.773: Queueing download of <http://download.lotro.akamai.turbine...tch/iterations ....... etc

    now it says
    000000003.295: Loading data patch dll.
    000000003.295: Could not init the patchtime manager
    000000003.295: Failed to create a patchtime patching manager in <...\Steam\steamapps\common\lo rd of the rings online>: error 0x81930003
    STEAM has a whole set of known LOTRO issues, but start as I suggested above - checking akamai hasnt been blocked as well; "Unable to decrypt and de-serialize" is a classic av interference issue, try switching off av before the next download attempt, and delete the existing files as they are corrupted.

  4. #4
    Join Date
    May 2012
    Posts
    44
    same error msg with/without av. same settings since I installed win 10 jun 2016.
    machine rebooted. router rebooted.

    so TTEPatchClient.log had these lines
    DiskCon::InitFile: Warning: datfile "client_sound_aux_1.datx" did not contain any GUID version stamp information!
    000000000.000: CompoundDiskController::Initia lizeExtent: Extent stamp mismatch.
    000000000.000: CompoundDiskController::Initia lizeExtents: Failed to open extent file client_sound_aux_1.datx

    I deleted client_sound_aux_1.datx and ran launcher. 9470 files downloaded and 90 minutes later,
    lotro launcher works. guess the moral is deleting 1 file or the game folder is the same - the whole game gets downloaded.
    Last edited by RustyShadow; Jul 11 2018 at 10:41 PM.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

This form's session has expired. You need to reload the page.

Reload