We have detected that cookies are not enabled on your browser. Please enable cookies to ensure the proper experience.
Page 1 of 3 1 2 3 LastLast
Results 1 to 25 of 58
  1. #1
    Join Date
    Feb 2007
    Location
    USA
    Posts
    6,582

    Game Error [105], [128] DirectX 9 Errors While Alt-Tabbing (etc.), SOLUTION/WORKAROUND

    SYMPTOM
    While adjusting video settings, or multi-tasking by alt-tabbing to other applications, LotRO crashes, generating "Game Error [105]" and/or "Game Error [128]" and then the "lotroclient has stopped working" error.








    CAUSE
    From a user perspective, it's always difficult to determine actual root cause. However, it seems that the catalyst for this issue is the latest "Windows Fall Creator's Update" combined with nvidia gpus (note: There are occasional reports from AMD users as well), and using DirectX 9 as the in-game selected "Graphics Hardware Level." Those using DirectX 10/11 in LotRO seem to be unaffected.

    SOLUTION / WORK-AROUND
    On your computer. . .

    • In your Documents folder, find the "The Lord of the Rings Online" directory.
    • In that directory, open the "Userpreferences.ini" file in notepad (or any text editor).
    • Locate "AllowFakeFullscreen" and make sure it is set to "True".
    • Locate "ForceFakeFullscreen" and change it to "True" (it is set to "False" by default).

    . . . with that in place, saved, and the LotRO client launched anew, you should be able to alt-tab, switch between fulscreen and windowed mode, change video settings, and otherwise do everything normally. Note: This is a different setting than "screen mode" that is presented in the Video Options in-game. And "ForceFakeFullscreen=True" in your UserPreferences.ini will fix the errors specified in this thread for all "screen modes" including "Fullscreen (windowed)".

    Best Regards,

    Hurin
    Last edited by Hurin; Mar 10 2018 at 07:39 PM. Reason: typos

  2. #2
    Join Date
    Mar 2014
    Location
    Greece
    Posts
    684
    Thanks Hurin.

    I will test when i get home.

    I had the same problem and 'fix' it by going to DX10, but now i have other problems (e.g. crashes in MT).
    Thorgull lvl 105 Champion - Malendar lvl 115 Warden - Estelldion lvl 101 LoreMaster - Ballduin lvl 36 Runekeeper - Nharduil lvl 17 Minstrel All on Evernight

    Malenborn - Warden & Athanandor - Hunter on Crickhollow (Casual Wanderers)

  3. #3
    Join Date
    Feb 2007
    Location
    USA
    Posts
    6,582
    Initial reports are good. . .

    Quote Originally Posted by Helwryeth View Post
    Hurin, I am happy to report that, on my PC at least, this workaround really does seem to work! A thousand festive blessings upon you for delving into the problem and proffering a viable solution. It's something you'd think the ones who coded the game would advise us of ... but thankfully we have those within the community with the ability and the altruism to do the job :bows:

  4. #4
    This worked for me too, thank you very much! I've been looking for a solution all around the internet, I even tried re-installing my graphic drivers numerous times, it didn't do any good. Honesly, I hate Windows for ruining something with every single update.

  5. #5
    Join Date
    Mar 2014
    Location
    Greece
    Posts
    684
    Thanks alot Hurin. It worked.
    Thorgull lvl 105 Champion - Malendar lvl 115 Warden - Estelldion lvl 101 LoreMaster - Ballduin lvl 36 Runekeeper - Nharduil lvl 17 Minstrel All on Evernight

    Malenborn - Warden & Athanandor - Hunter on Crickhollow (Casual Wanderers)

  6. #6
    Hmm. I just finished installing the stupid new Windows 10 update this morning and now my lotro will no longer load. It gave me the error message [105] referenced above. My graphics are NVIDIA and my in-game graphics settings are set to DirectX9. At this point I'd like to just reset my in-game graphics settings to Directx10 or Directx11... but I can't load the game to change it.

    When I tried the fix suggested by Hurin game error [105] is now replaced by...

    Game Error [131] (Unable to find the desired game display mode. Please try resetting the game graphics options via the launcher. [131])



    EDIT: to show my current configuration

    [Display]
    AllowDesktopCompositing=True
    AllowFakeFullScreen=True
    AllowWindowResizing=True
    Antialiasing=2x
    ConfineFullScreenMouseCursor=T rue
    FixedOutputScaling=Default
    ForceFakeFullScreen=True
    FullScreen=False
    RefreshRate=Auto
    Resolution=1768x992
    ScreenMode=FullScreen
    SyncToRefresh=False
    TripleBuffering=False
    WindowedResolution=1360x768

  7. #7
    Join Date
    Feb 2007
    Location
    USA
    Posts
    6,582
    Quote Originally Posted by madrigal1974 View Post
    Hmm. I just finished installing the stupid new Windows 10 update this morning and now my lotro will no longer load. It gave me the error message [105] referenced above. My graphics are NVIDIA and my in-game graphics settings are set to DirectX9. At this point I'd like to just reset my in-game graphics settings to Directx10 or Directx11... but I can't load the game to change it.

    When I tried the fix suggested by Hurin game error [105] is now replaced by...

    Game Error [131] (Unable to find the desired game display mode. Please try resetting the game graphics options via the launcher. [131])



    EDIT: to show my current configuration

    [Display]
    AllowDesktopCompositing=True
    AllowFakeFullScreen=True
    AllowWindowResizing=True
    Antialiasing=2x
    ConfineFullScreenMouseCursor=T rue
    FixedOutputScaling=Default
    ForceFakeFullScreen=True
    FullScreen=False
    RefreshRate=Auto
    Resolution=1768x992
    ScreenMode=FullScreen
    SyncToRefresh=False
    TripleBuffering=False
    WindowedResolution=1360x768
    I'm going to paste my "bag of tricks" in the order I'd try them in your case.

    1. Delete/rename UserPreferences.ini file in order to reset all LotRO settings in hopes of removing any setting that has somehow become a catalyst for this behavior. LotRO will regenerate a new/default one upon next launch.

    2. Install/reinstall the Visual C++ 2005 and 2010 runtimes from here and here.

    3. Reinstall DirectX runtimes (be careful of checkboxes attempting to foist MS's "Bing Bar" and such on you during download and install).

    (I'd again delete my UserPreferences.ini file again as in step #1 before going any further).

    4. Try "ForceFakeFullscreen=True" in the UserPreferences.ini file as described here.

    5. This is a bit of grasping at straws. . . try installing (newest) nvidia driver if you haven't already. Then. . . go into nvidia control panel and set your screen resolution to on that is non-native for your monitor. Try LotRO. Then reboot. Go into nvidia control panel and set resolution to monitor's native resolution. Reboot. Try LotRO.

    Believe it or not, there is method to this madness and it apparently helped someone prior even though I only posted it on a hunch.

    6. Adjust "DisplayAdapter=0" in UserPreferences.ini (this is very unlikely to help on a single-GPU system. . . but can't hurt since you can always change it back or delete the UserPreferences.ini altogether).


    . . . change that to 1 or 2 (or 3!) and try each.

    7. Whenever you try a few things that don't actually work, re-deleting/renaming the UserPreferences.ini file to get it back to defaults isn't a bad idea.

    --H

  8. #8
    Thanks Hurin.

    I tried #3 first and the manual installation of all the microsoft versions of direct x seems to have done the trick as far as getting the game to launch.

    My first time back in the launcher asked if I wanted to use DirectX11 and I replied "yes." Then I reset to DirectX9 in-game and relaunched with no issues (thankfully). The only problem I have now is that it reset all my graphics settings and I can no longer select 1768x992 resolution in full screen mode (it gives me the Game Error [131] "unable to find the desired game display mode" message when I try to change it in-game).

    Again, many thanks!

  9. #9
    Join Date
    Feb 2007
    Location
    USA
    Posts
    6,582
    Quote Originally Posted by madrigal1974 View Post
    Thanks Hurin.

    I tried #3 first and the manual installation of all the microsoft versions of direct x seems to have done the trick as far as getting the game to launch.

    My first time back in the launcher asked if I wanted to use DirectX11 and I replied "yes." Then I reset to DirectX9 in-game and relaunched with no issues (thankfully). The only problem I have now is that it reset all my graphics settings and I can no longer select 1768x992 resolution in full screen mode (it gives me the Game Error [131] "unable to find the desired game display mode" message when I try to change it in-game).

    Again, many thanks!
    Though this may sound pedantic. . . I think (though I could easily be wrong since I'm not the one at the console and you know more about what has occurred than I do) what has actually happened is that somewhere along the way your system lost the ability to use this resolution in-game before things got reset by what we just did. The resetting that we just accomplished is what's now allowing us to work around that situation.

    But regardless. . . is 1768x992 the native resolution of your monitor/screen/tv? If so, and you really need it to work, I would think that the problem is that either there's a faulty custom resolution for 1768x992 already in the nvidia control panel. . . or. . . you need to set up a 1768x992 custom resolution in the nvidia control panel.

    Check out NVIDIA Control Panel-->Display-->Change Resolution-->"Customize. . ." button.

    . . . and adjust appropriately.

    Please do let me/us know how it turns out!

    --H

    Edit: "ForceFakeFullscreen" might also work around the issue you're now seeing. But I'd try the custom resolution first (and delete it if it doesn't help).

  10. #10
    Join Date
    Jul 2016
    Location
    UK
    Posts
    4,041
    So, something screwed the pooch and hurin suggested trying a dx file reinstall, how poetic.

    But hurin, you keep ridiculing me when I state there is something randomly scrambling the dx files.

  11. #11
    I use the recommended resolution (1366 x 768) and that's what set on both the main Windows display settings and on my NVIDIA settings. I tried a few minutes ago setting the display resolution to 1768 x 992 and it looked awful... and it wouldn't let me in LOTRO so I reverted back to 1366 x 768.

    Back in 1366 x 768 I relaunched LOTRO and switched to 1920 x 1080 fullscreen resolution (which I used on my old PC and I like just fine except that it cuts off the edges of my screen partially obscuring the map, character portrait, chat boxes and quickslot bar 1). Is there a setting offhand that I can change to fix that... since I've decided to not bother trying to get 1768 x 992 to work?

  12. #12
    Join Date
    Feb 2007
    Location
    USA
    Posts
    6,582
    Quote Originally Posted by Yarbro View Post
    So, something screwed the pooch and hurin suggested trying a dx file reinstall, how poetic.

    But hurin, you keep ridiculing me when I state there is something randomly scrambling the dx files.
    No, I question your constant "I suspect. . ." statements followed by needless, nonsensical and completely unsubstantiated theories about why the reinstall is necessary. As where you randomly suggest that nvidia and/or amd are deleting/corrupting them. There's zero to substantiate that.

    In case you haven't noticed, while you hop from thread to thread rambling on about irrelevant, often completely bizarre theories, I'm actually helping people to fix their issues.

    I think that bothers you. Hence this needless outburst from you.

    --H
    Last edited by Hurin; Jan 06 2018 at 07:46 PM.

  13. #13
    Join Date
    Feb 2007
    Location
    USA
    Posts
    6,582
    Quote Originally Posted by madrigal1974 View Post
    I use the recommended resolution (1366 x 768) and that's what set on both the main Windows display settings and on my NVIDIA settings. I tried a few minutes ago setting the display resolution to 1768 x 992 and it looked awful... and it wouldn't let me in LOTRO so I reverted back to 1366 x 768.

    Back in 1366 x 768 I relaunched LOTRO and switched to 1920 x 1080 fullscreen resolution (which I used on my old PC and I like just fine except that it cuts off the edges of my screen partially obscuring the map, character portrait, chat boxes and quickslot bar 1). Is there a setting offhand that I can change to fix that... since I've decided to not bother trying to get 1768 x 992 to work?
    It sounds like your display driver or your monitor is doing "scaling". . .

    To disable it on your gpu, go to the nvidia control panel like so. . .



    . . . or otherwise tweak them until things look right in your preferred resolution.

    You may also need to find and/adjust scaling options on your monitor (they're often labeled something other than "scaling" though).

    Dinner is on the table so I'm a bit rushed. And was a bit distracted by a prior post (as you might have noticed).

    Good Luck!

    --H

  14. #14
    Join Date
    Jul 2016
    Location
    UK
    Posts
    4,041
    Quote Originally Posted by Hurin View Post
    No, I question your constant "I suspect. . ." statements followed by needless, nonsensical and completely unsubstantiated theories about why the reinstall is necessary. As where you randomly suggest that nvidia and/or amd are deleting/corrupting them. There's zero to substantiate that.

    In case you haven't noticed, while you hop from thread to thread rambling on about irrelevant, often completely bizarre theories, I'm actually helping people to fix their issues.

    I think that bothers you. Hence this needless outburst from you.

    --H
    So, I am doing to you what you do it me, correct??

    Poetic justice indeed.

  15. #15
    Join Date
    Feb 2007
    Location
    USA
    Posts
    6,582
    Quote Originally Posted by Yarbro View Post
    So, I am doing to you what you do it me, correct???
    Well, except I correct you when you're wrong and misleading people. You just pop in to distract and harass in retaliation for being embarrassed. But, alas, the embarrassment on your part is only so unbearable because you insist on engaging in page after page of shenanigans rather than ever conceding a point (which you never, ever do even in the face of concrete documentation of your error).

    Yarbro, you once stated you think MMOs (and LotRO in particular) store character state and progression locally. You seem to have no idea where a user's desktop and documents are normally located and refuse to accept the information of where they are by default when presented with it. You once urged people to install platform updates intended for prior Operating systems (ie., Vista/7/8 servicing/feature packs) on Windows 10 as a means of resinstalling DirectX itself. You think deleting files from C:\Windows is helpful and beneficial because Windows "constantly scans it". . . and so on (and all but outright lied to avoid ever admitting that this is not the case). And man could I go on. Anyone who could say such things and continue to stand by them in the face of substantive correction really has no place giving anyone technical advice.

    But hey. . . feel free to try to give me a hard time. I can take it. Because I tend to make sure I know what I'm talking about before I open my pie hole. And I try to avoid needless and bizarre conjecture in what I say. You obviously. . . painfully obviously. . . can't say the same.

    --H
    Last edited by Hurin; Jan 06 2018 at 08:27 PM. Reason: Links!

  16. #16
    Quote Originally Posted by Hurin View Post
    It sounds like your display driver or your monitor is doing "scaling". . .

    To disable it on your gpu, go to the nvidia control panel like so. . .



    . . . or otherwise tweak them until things look right in your preferred resolution.

    You may also need to find and/adjust scaling options on your monitor (they're often labeled something other than "scaling" though).

    Dinner is on the table so I'm a bit rushed. And was a bit distracted by a prior post (as you might have noticed).

    Good Luck!

    --H
    I changed the settings to what you have shown there in my NVIDIA Control Panel and it made no difference inside LOTRO.

    So this is what I did to get LOTRO to display properly sized in 1920x1080 without cutting off the edges of the screen:
    1) I changed the resolution on my NVIDIA Control Panel from the recommended native PC 1366x768 resolution to 1080p 1920x1080.
    2) I went into Adjust Desktop Size and Position and manually resized it to 1842x1036.
    3) Now LOTRO looks great in 1920x1080 mode (although the text is a little small for my taste now).

    The only downside to changing to switching away from my monitor's (a Samsung TV) native resolution is that the text on my screen is just a tad bit blurry and clear type settings can only do so much to remedy that.

  17. #17
    Join Date
    Feb 2007
    Location
    USA
    Posts
    6,582
    Quote Originally Posted by madrigal1974 View Post
    (a Samsung TV)(
    Ah! So it is indeed a TV! In that case, some TVs still do "overscan" where they essentially zoom the image to eliminate the edges (which fits the descriptions you posted a post or two back). Back in the day, this was done to hide the edges of broadcasts that often had garbage and other oddness visible on the edges. The bezel around the edge of the tube hid such things.

    In the digital era where pixels cover edge to edge and there is no bezel, that garbage becomes visible so overscan is sometimes enabled by default.

    Look around on your TV for a way to disable "overscan" or something similar and then try native TV resolution again. If no such setting exists, there should be a way to adjust for overscan without distortion. I would suggest the "size" tab that you already seem to have experimented with. . . but well, you've already tried that. Hopefully your TV has a way to turn off overscan. On my Panasonic plasma, the setting is called: "Aspect Adjustment" --> Size --> "H Size" and "V Size." (they even mention "trimming analog noise"). Yours will likely differ in label/name. But will hopefully be there!

    --H
    Last edited by Hurin; Jan 07 2018 at 03:07 AM.

  18. #18
    Join Date
    Jun 2011
    Location
    Athens/Greece
    Posts
    706
    Thank you very much.
    Arandour Champion Rank 12-Nerien Hunter rank 11-Runendir RK Rank 7
    Kinship PRIME-Evernight Since May 2007
    Borzol R12-Mauhnakh R9-Varcolac R9-Sumnor R8-Orcapo R8 (Creep status retired)
    Discord: Arandour #1742

  19. #19
    Join Date
    Feb 2007
    Location
    USA
    Posts
    6,582
    Quote Originally Posted by Arandour View Post
    Thank you very much.
    Very welcome!

  20. #20
    Hurin, you're a saint, you should be on SSG's payroll mate.

  21. #21
    I suddenly started to get this error, since a day or two. Never had it before, and I have been playing on this machine for 4 years now. Your solution has fixed it for me. Thank you very much Hurin!
    "Out of the Great Sea to Middle-earth I am come. In this place will I abide, and my heirs, unto the ending of the world."

  22. #22
    Quote Originally Posted by Hurin View Post
    SYMPTOM
    While adjusting video settings, or multi-tasking by alt-tabbing to other applications, LotRO crashes, generating "Game Error [105]" and/or "Game Error [128]" and then the "lotroclient has stopped working" error.








    CAUSE
    From a user perspective, it's always difficult to determine actual root cause. However, it seems that the catalyst for this issue is the latest "Windows Fall Creator's Update" combined with nvidia gpus, and using DirectX 9 as the in-game selected "Graphics Hardware Level." Those using DirectX 10/11 in LotRO seem to be unaffected.

    SOLUTION / WORK-AROUND
    On your computer. . .

    • In your Documents folder, find the "The Lord of the Rings Online" directory.
    • In that directory, open the "Userpreferences.ini" file in notepad (or any text editor).
    • Locate "AllowFakeFullscreen" and make sure it is set to "True".
    • Locate "ForceFakeFullscreen" and change it to "True" (it is set to "False" by default).


    . . . with that in place, saved, and the LotRO client launched anew, you should be able to alt-tab, switch between fulscreen and windowed mode, change video settings, and otherwise do everything normally. Note: This is a different setting than "screen mode" that is presented in the Video Options in-game. And "ForceFakeFullscreen=True" in your UserPreferences.ini will fix the errors specified in this thread for all "screen modes" including "Fullscreen (windowed)".

    Best Regards,

    Hurin
    Thanks a million Hurin. This worked great.

  23. #23
    Join Date
    Sep 2010
    Posts
    380
    Quote Originally Posted by Hurin View Post
    CAUSE
    From a user perspective, it's always difficult to determine actual root cause. However, it seems that the catalyst for this issue is the latest "Windows Fall Creator's Update" combined with nvidia gpus, and using DirectX 9 as the in-game selected "Graphics Hardware Level." Those using DirectX 10/11 in LotRO seem to be unaffected.
    This is not nVidia drivers issue because I have Radeon RX Vega 56 and I had same issue. So it's FCU what we should blame.

  24. #24
    Join Date
    Feb 2007
    Location
    USA
    Posts
    6,582
    Quote Originally Posted by JiiPee View Post
    This is not nVidia drivers issue because I have Radeon RX Vega 56 and I had same issue. So it's FCU what we should blame.
    First report of this on AMD where LotRO is concerned. Might be a separate catalyst in your case.

    --H

  25. #25
    Thanks so much for this. When it suddenly happened to me, I was very confused. And 100% sure that DirectX 9.0c or higher was indeed installed, lol. I liked running it with DirectX 11 but MT made that a no-go.

 

 
Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

This form's session has expired. You need to reload the page.

Reload