We have detected that cookies are not enabled on your browser. Please enable cookies to ensure the proper experience.
Results 1 to 5 of 5
  1. #1

    All my Characters Gone

    I logged on. I was taken to character creation! I exited that and all my characters are gone, all slots empty. All these years of play vanished. I don't even have a toon to enter the game and submit a ticket. The support form outside the game has no request topic for such an occurrence. I logged out and logged back in again. The same thing occurred. \what the hell has happened and what am I supposed to do now?

  2. #2
    Is there *any* chance you accidentally went to the wrong server?

    Have you submitted a Support Ticket? SSG Support

    You may have to Register on there since it's SSG now and not Turbine. Once Registered click "How do I contact support?"

    If you've confirmed that you're on the correct Server I'd start the Support process ASAP. It takes them a week plus to contact you. Provide them with *ALL* of the information they may need. If they reply to you, and you need to provide more information, you'll have to wait for the next day to get a reply. Sometimes even longer.

    Sending 'good vibes' your way. I'm sure you'll get sorted...in time. =)

  3. #3
    Join Date
    Feb 2007
    Location
    Iowa
    Posts
    1,278
    Definitely double-check that you logged on to the correct server.
    Make sure "Enter Last Played World" isn't checked and login.
    There should be a "Transfer" button below "Play".
    Click that and you'll see a server list that tells where you have any characters.
    Chances are that you somehow got logged into the wrong server.

  4. #4
    Join Date
    Jul 2016
    Location
    UK
    Posts
    3,732
    Quote Originally Posted by EB64 View Post
    Definitely double-check that you logged on to the correct server.
    Make sure "Enter Last Played World" isn't checked and login.
    There should be a "Transfer" button below "Play".
    Click that and you'll see a server list that tells where you have any characters.
    Chances are that you somehow got logged into the wrong server.
    I have gotten caught out by the above on two different occasions; when the launcher decided to reset to the default, "New Player" server instead of the server I had been gaming on for (at the time) over 6 months. In fact, the launcher only stopped saying I logged into that server "Last Month", a few weeks ago - 2 years after the last time I did it.

  5. #5
    Join Date
    Feb 2009
    Posts
    29

    Thumbs up

    Apologies for necroing here but I just had this problem!

    I reinstall the game after a couple of years having stepped away. I did manage to get my character migrated off of Vilya... but when I came back I couldn’t remember which server I had migrated her to. I installed the game last night and after it finished I loaded it up and I found no characters and no previously played worlds.

    I had to close out and reload the launcher...and my characters on crickhollow popped in...but that first load up they didn’t exist! It was fraught...but after reading this thread I tried again and they reappeared! Thanks all!
    .
    I do not love the bright sword for its sharpness, nor the arrow for its swiftness, nor the warrior for his glory. I love only that which they defend.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

This form's session has expired. You need to reload the page.

Reload