We have detected that cookies are not enabled on your browser. Please enable cookies to ensure the proper experience.
Page 9 of 9 FirstFirst ... 5 6 7 8 9
Results 201 to 206 of 206
  1. #201
    Join Date
    Jun 2011
    Posts
    1,144
    Quote Originally Posted by LightGatherer View Post
    I made a short sequence for testing, which contains only "pet" and "current target's target". I found that the first round I click them, it always keeps the target on my pet, but the second round, it will correctly target the mob, as long as I don't click very fast. Any idea of this?
    Probably because after you select your pet, it takes a while for the game client to discover your pet's target.

    Currently (although I'll probably change this soon), the target is only detected when you move the mouse over the "Select Target" slot. So after you click the "Select target: Pet" slot, the "Select target: Current target's target" slot immediately moves under the mouse, and that may be too soon because the game client hasn't yet discovered your pet's target. A workaround would be to insert a "Delay" slot (e.g. half a second) between the two. (Or, you could simply move the mouse away, and back over the slot half a second later to redetect the target.)

    I am thinking about ways to improve this in the next version.
    Thurallor, Warden of Landroval
    Author of plugins: SequenceBars, Reminders, others

  2. #202
    Quote Originally Posted by Thurallor View Post
    Probably because after you select your pet, it takes a while for the game client to discover your pet's target.

    Currently (although I'll probably change this soon), the target is only detected when you move the mouse over the "Select Target" slot. So after you click the "Select target: Pet" slot, the "Select target: Current target's target" slot immediately moves under the mouse, and that may be too soon because the game client hasn't yet discovered your pet's target. A workaround would be to insert a "Delay" slot (e.g. half a second) between the two. (Or, you could simply move the mouse away, and back over the slot half a second later to redetect the target.)

    I am thinking about ways to improve this in the next version.
    You're right. It works now. Thank you for the advice!

  3. #203
    Join Date
    Jun 2011
    Posts
    1,144
    Version 3.27 of SequenceBars is now available at lotrointerface.

    Version 3.27 release notes

    New features:

    • Added "Require target" option for "Select target" slots. This will prevent the sequence from advancing until you have successfully selected a target. This is to accommodate the fact that detecting another player or NPC's target can take a small amount of time after you select them. With this option enabled, you can just spam clicks until the target is selected.

    Other changes:

    • The appearance of a "Select target" slot will now change when the mouse is over it. It will either have a red or a green background, indicating whether a target has been identified or not.
    • Removed "Pet's target" from the list of selectable targets for "Select target" slots. (It can't be reliably detected if your pet isn't already targeted.) As a substitute, you can use a "Select target: Pet" slot, followed by a "Select target: Current target's target" slot. In the latter slot, be sure to enable the "Require target" option, since detecting the pet's target is not instantaneous.
    Thurallor, Warden of Landroval
    Author of plugins: SequenceBars, Reminders, others

  4. #204
    Targeting "myself" and targeting "pet" are not working correctly. Sometimes they target the right target, sometimes they don't. And there is always an error message "...Rings Online\Plugins\Thurallor\Seque nceBars\Slot.lua:152: attempt to index field 'object' (a nil value)" when I click either of them. Any idea?

  5. #205
    Join Date
    Jun 2011
    Posts
    1,144
    Quote Originally Posted by LightGatherer View Post
    Targeting "myself" and targeting "pet" are not working correctly. Sometimes they target the right target, sometimes they don't. And there is always an error message "...Rings Online\Plugins\Thurallor\Seque nceBars\Slot.lua:152: attempt to index field 'object' (a nil value)" when I click either of them. Any idea?
    Sorry about that. It should be fixed now (in version 3.28). After installing the new version, you may need to delete and recreate your "Select target" slots to make them work correctly.
    Thurallor, Warden of Landroval
    Author of plugins: SequenceBars, Reminders, others

  6. #206
    Quote Originally Posted by Thurallor View Post
    Sorry about that. It should be fixed now (in version 3.28). After installing the new version, you may need to delete and recreate your "Select target" slots to make them work correctly.
    Tried it and it's very nice. Thank you!

 

 
Page 9 of 9 FirstFirst ... 5 6 7 8 9

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

This form's session has expired. You need to reload the page.

Reload