We have detected that cookies are not enabled on your browser. Please enable cookies to ensure the proper experience.
Results 1 to 5 of 5
  1. #1
    Join Date
    Sep 2013
    Location
    Ontario, Canada
    Posts
    680

    Internet Explorer 6-11 Vulnerability

    Hullo all! Posting this here for visibility (much like this thread). Mods, if you think this would be more appropriate elsewhere, I understand.

    Microsoft has announced that they're discovered a significant vulnerability in Internet Explorer versions 6-11. They offer quite a bit of information about the problem here. Scroll down about halfway for the "Suggested Actions" if you're using Internet Explorer and would like to take some steps to mitigate the vulnerability. The US Government has posted about it here and suggests that "Those who cannot follow Microsoft's recommendations, such as Windows XP users, may consider employing an alternate browser."

    In short, if you're running Internet Explorer, there's a chance this vulnerability could affect you while Microsoft works on patching the hole. You can take some preventative measures or switch to another browser until the issue's resolved.

    Not wanting to cause a panic, just hoping folks are informed.

    Happy questing.
    Neddor, Untrustworthy Guardian of Arkenstone
    Massan, Captain Nutter of Laurelin

  2. #2
    Join Date
    Jun 2011
    Posts
    1,656
    Microsoft yesterday released an update for IE that fixes the issue.

    It's important that all users of IE that are affected by this run Windows/Microsoft updates and install the relevant update as soon as possible.
    How to get help on the Tech Forums and how to contact Turbine

    Please reply to the topic or PM me if a solution I posted works for you: The more data I can gather the better I can help.

  3. #3
    Join Date
    Apr 2011
    Location
    Michigan
    Posts
    4,999
    Ah that explains the update Windows keeps begging me to install. I was rather hesitant because Windows XP is no longer receiving support, so I wasn't sure why they suddenly threw an IE 8 update at me. To confirm, for XP users the update is KB2964358, correct?

    I don't use IE anyway, but I suppose I should download the update regardless...
    R5 100 GRD Marevayave - Leader of Riddermarked For Death
    R8 100 MNS Fayah/100 LM Siennah/100 HNT Dinenol/100 RK Dhurik
    100 CHN Alachas/85 CPT Dinfaerien/60 BUR Dhax/35 WDN Godoric
    R9 100 MNS Fayeh (alt Wilya) - Lonely Mountain Band @ Landroval

  4. #4
    Join Date
    Jun 2011
    Posts
    1,656
    Quote Originally Posted by Mar-Evayave View Post
    To confirm, for XP users the update is KB2964358, correct?
    Yes, it is.

    I don't use IE anyway, but I suppose I should download the update regardless...
    You'd be surprised how many other applications do use it though. Just because people don't use IE to browse the web doesn't mean they are unaffected by this issue I'm afraid.
    How to get help on the Tech Forums and how to contact Turbine

    Please reply to the topic or PM me if a solution I posted works for you: The more data I can gather the better I can help.

  5. #5
    Join Date
    Apr 2011
    Location
    Michigan
    Posts
    4,999
    Yeah, I know a lot of system tools use IE and/or IE components.

    At least I am mildly comforted that XP users haven't been totally forgotten. :/
    R5 100 GRD Marevayave - Leader of Riddermarked For Death
    R8 100 MNS Fayah/100 LM Siennah/100 HNT Dinenol/100 RK Dhurik
    100 CHN Alachas/85 CPT Dinfaerien/60 BUR Dhax/35 WDN Godoric
    R9 100 MNS Fayeh (alt Wilya) - Lonely Mountain Band @ Landroval

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

This form's session has expired. You need to reload the page.

Reload