We have detected that cookies are not enabled on your browser. Please enable cookies to ensure the proper experience.
Results 1 to 5 of 5
  1. #1

    Exclamation Extremely low FPS for no reason

    I recently came back to LOTRO after several months. When I decided to come back to PC games I reset my computer to factory standards to get rid of numerous unwanted background processes and malware. I downloaded some MMO's I played before the factory reset with 15-25fps, but I've had the same horrible decline of fps in every game I've tried. I can't even get past the character creation on account of the lag. the fps is below 5fps now so there's no possible way I can play any game that slow. I've already tried updating my drivers and directx with no luck. In no way, shape, or form do I have a gaming computer. But I have played this game and others before on this system with much better fps. I'm currently trying to save up for an actual gaming PC but I just need something to do until then. If anyone has an idea for my problem I'm open to suggestions.

  2. #2
    If you are having this issue with all MMOs, I would say this is a technical issue, but not related to Lotro. Did you also install all DirectX versions 9.c through 11? It might be that they are missing, and this is having an impact on the performance of your system.


    Greetings, Polymachos

  3. #3
    Join Date
    Feb 2011
    Location
    Indiana, USA
    Posts
    406
    The bottom recently dropped out of FPS for me as well. I was having black screen//computer crash issues. Did a LOT of diagnosis. Eventually decided to upgrade my graphics card and install more fans. I upgraded video drivers, audio drivers, DirectX, and Windows. I pulled a TON of stuff out of my system and radically pared the start menu.

    My fps before, during black screen period, was 25-35 fps. Not fun but at least playable. In raid content, the fps dropped to 4 fps in turtle.

    Now with the new graphics card, my fps is 25-40 fps. New card is an Nvidia 610 with 2 GB of memory on it.

    Not sure what's going on but at least I'm playable. I'm thinking that at least a large chunk of responsibility for this is within the LOTRO code.

  4. #4
    Quote Originally Posted by VarrikStormstrider View Post
    I recently came back to LOTRO after several months. When I decided to come back to PC games I reset my computer to factory standards to get rid of numerous unwanted background processes and malware. I downloaded some MMO's I played before the factory reset with 15-25fps, but I've had the same horrible decline of fps in every game I've tried. I can't even get past the character creation on account of the lag. the fps is below 5fps now so there's no possible way I can play any game that slow. I've already tried updating my drivers and directx with no luck. In no way, shape, or form do I have a gaming computer. But I have played this game and others before on this system with much better fps. I'm currently trying to save up for an actual gaming PC but I just need something to do until then. If anyone has an idea for my problem I'm open to suggestions.
    I had this same issue. Turn off all unnecessary programs in startup. Press Ctrl+Alt+Delete then click on task manager. Click the startup tab and disable all non-essential programs. This took my FPS from 20 fps on any setting to 175 fps on ultra high. Startup programs are classically draining on the system. hope this helps there aren't many answers out there for this fix

  5. #5
    In case that you didn't notice: This thread started nearly two years ago. The poster didn't reply, so either he got the issue resolved, or he left the game.


    Greetings, Polymachos
    Treufried, human Level 105 Lore Master, formerly from Maiar (DE), now on Belegaer
    Manfreid, dwarven Level 105 Champion, all the same
    Alexophor, human Level 105 Hunter, formerly a Nimrod, now on Landroval

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

This form's session has expired. You need to reload the page.

Reload