We have detected that cookies are not enabled on your browser. Please enable cookies to ensure the proper experience.
Results 1 to 11 of 11
  1. #1
    Join Date
    Jun 2011
    Location
    Cornwall, UK
    Posts
    1,383

    Is this forum safe?

    I have just finished wiping my harddrive and reinstalling everything from scratch. When I set up my browser and started bookmarking my usual websites, everything was fine and all have been bookmarked without problems until I came to this forum. As soon as I googled this forum it was earmarked by both Google and Firefox as an "unsafe" website and I had to be warned of the risks of visiting this site and click a disclaimer before I could even connect to it!!!

    What the heck? Is this site having problems or lacking in security as Google suggests?

  2. #2
    Join Date
    Dec 2010
    Location
    Sweden
    Posts
    3,499
    I'm not certain how this new version of forums works. Old one would have gathered near real-time info from the game and should potentially have triggered a couple of security warnings (but never saw it do that!). It is possible that some sort of...certificate?...is asking for unusual permissions and this gives the warning.

    I used to have an antivirus running which wrapped itself around my system like a wet blanket, constantly asking if I was certain I wanted to perform this action or warned me that sites were not secure and so on, could this be an effect of something similar?

  3. #3
    Join Date
    Jun 2011
    Location
    Cornwall, UK
    Posts
    1,383
    Quote Originally Posted by Macroscian View Post
    I'm not certain how this new version of forums works. Old one would have gathered near real-time info from the game and should potentially have triggered a couple of security warnings (but never saw it do that!). It is possible that some sort of...certificate?...is asking for unusual permissions and this gives the warning.

    I used to have an antivirus running which wrapped itself around my system like a wet blanket, constantly asking if I was certain I wanted to perform this action or warned me that sites were not secure and so on, could this be an effect of something similar?
    Maybe but I kinda doubt it. I'm using AVG and of all the sites I have visited (scores) in last 2 days this was the only one it deemed unsafe.

  4. #4
    Join Date
    Jun 2011
    Posts
    1,544
    Without seeing the actual and complete error/warning message can't say if this is nonsense of your browsers, Google or something else.
    Used to play: 85 Champ / Captain / Runekeeper / Guardian, Guild Master of everything but cooking.
    Playing now: Hellcat / King Tiger / GW Panther / IS / KV-5 / M4 Sherman and more

  5. #5
    The forum is running with https, which should be fine. I just opened Google Chrome to see what is going wrong, and find that (clarification: when logging in) the browser is having issues with the web page, trying to connect again and again, and then presents an error page that says: This page contains too many redirects.

    This is a specific habit of this forum. It is meant to bring you back to the topic that you were currently reading and probably wanted to reply to. It doesn't always work for me, for instance I get redirected to a topic that I opened before the one I want to reply to. Chrome seems to see redirects as potentially dangerous, and redirects from redirects even more.

    Try to open the page with Firefox, that should work.


    Greetings, Polymachos
    Last edited by Polymachos; Feb 13 2014 at 09:13 AM.

  6. #6
    Join Date
    Apr 2008
    Posts
    3,203
    Android version of chrome always complains about this site's certificates on my tablet. Unclear what the issue is, but I've seen others report it. I don't see the issue with firefox or chrome on windows however.

  7. #7
    Sapience is offline Former Community Manager & Harbinger of Soon
    Join Date
    Aug 2008
    Posts
    9,519
    Yes, it is. We've seen this crop up mostly on Android OS (as noted above) but it does seem to happen from time to time on new machines or clean installs.

  8. #8
    Something similar happened to me a few weeks ago. I built a new computer, imported my old bookmarks, hit my link to the forums and got a security warning, something about a certificate. I googled it. There was a complicated solution. But the simple solution was to just visit the top level domain first (www.lotro.com) before trying to visit subdomains. That would make sure all the certificates were in order. That is what worked for me.

  9. #9
    This issue is caused by their SSL cert is setup for www.lotro.com so for some reason chrome if you put https://lotro.com it does not do the redirect the first time till you tell it its ok to proceed. Technically chrome is handling this correct to prevent redirects to "bad" sites.
    [charsig=http://lotrosigs.level3.turbine.com/0820a00000000548a/01001/signature.png]Nerobus[/charsig]

  10. #10
    Join Date
    Mar 2011
    Posts
    2,780
    Probably means the SSL/A Records of this website are missing something/not written in a way that browser understands.

    And yes, I've only seen that notification pop up when on Android Chrome. The web admin probably needs to research android chrome a bit to see if there's anything specifically needed for https:// websites.
    LvL 100s: Beorning, Burglar, Captain, Champ, Guardian, Hunter, Lore-Master, Minstrel, Rune-Keeper
    LvL 85: Warden, Minstrel
    All my forum posts are my opinions and may not even be that. Also On Twitter: @leixicon

  11. #11
    Join Date
    Jun 2011
    Location
    Cornwall, UK
    Posts
    1,383
    I got the warning on Firefox browser on a new clean install of Windows and Firefox after a full wipe of my harddrive.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

This form's session has expired. You need to reload the page.

Reload