We have detected that cookies are not enabled on your browser. Please enable cookies to ensure the proper experience.
Results 1 to 7 of 7
  1. #1

    Sound & Voice problem

    Hello,
    I'll try to describe the situation. I use Mac client, headset. Headset works fine (while playing I communicate via mumble, skype etc.). I can hear in-game sounds and music as well. The problem with the sound is when I'm in a group. In Options micro is enabled. But I cannot hear other members of the group or speak to them. For example, when someone speaks the icon above their portrait turns red, but there's still no sound.

    Any ideas?

    ____________________


    Problem is solved.
    Last edited by Judmerfei; Dec 20 2013 at 02:50 AM.

  2. #2
    How was this prob solved?
    I just got a logitech usb headset & everything but in game voice chat goes to headset. Ingame goes to the IMac's speakers.
    The in game control for playback source is grayed. Restarting makes no change.
    Anyone know how I can edit out/adjust the code to make the game's ingame chat recognize the headset for playback?

    Reme
    mber, it is a game.

  3. #3
    Join Date
    Feb 2007
    Location
    Philadelphia, PA
    Posts
    2,675
    Quote Originally Posted by Krysstofur View Post
    How was this prob solved?
    I just got a logitech usb headset & everything but in game voice chat goes to headset. Ingame goes to the IMac's speakers.
    The in game control for playback source is grayed. Restarting makes no change.
    Anyone know how I can edit out/adjust the code to make the game's ingame chat recognize the headset for playback?
    I don't know how the original problem was solved...

    One thing I know from my own experience -- USB audio is flakey on the iMac.

    Check in System Preferences, Select Sound - make certain that the input and output values are selected to be your headset.

    Note that your headset will only show up in this panel when it is plugged in... and that it can take a couple of minutes for it to be recognized by the iMac.
    I use a powered hub which "should work" -- sometimes it does, sometimes it doesn't. Plugging directly into the back of the iMac does make a difference.

    Another tool which can be used: Applications/Utilities -- Audio MIDI Setup.app

    The other "trick" I use is to plugin and configure my headset BEFORE I launch LOTRO.

    However, the real winning trick -- Use Mumble

    27 inch iMac Intel (mid 2010)
    Model: iMac11,3
    Processor: 2.93 GHz Intel Core i7
    Memory: 8 GB 1333 MHz DDR3
    Graphics: ATI Radeon HD 5750 1024 MB
    Display: 27-inch (2560 x 1440)
    Software OS X 10.9.2 (13C64)

    Audio FX 5+1 USB headset
    Bill Magill Mac Player
    (OTG)
    Val - Man Minstrel (90)
    Valalin - Dwarf Minsrel (69)
    Valamar - Dwarf Hunter (105)
    Valanne - Beorning (90)
    Valdicta - Dwarf RK (104)
    Valhad - Elf LM (65)
    Valkeeper - Elf RK (86)
    Valwood - Dwarf RK (80)


    Valhunt - Dwarf Hunter (70)
    Valanne - Beorning (91)
    Ninth - Man Warden (65)

    "Laid back, not so serious, no drama.
    All about the fun!"


  4. #4
    Thanks, yes I understand it needs to be plugged in to be seen & how to use sys prefs etc.
    The issue is that once Lotro's gamespy picks a default playback it doesn't want to change, it just is not an option, totally grayed out.
    I was hoping someone could help me get that detail reset so it would look again and select the headset.
    I'd rather not do a full reinstall to fix one sentence of start code.
    If I find what to edit, I'll post.
    I had considered disabling the onboard speakers temporarily, but of course I didn't find an easy way to do that in the sound control panel.

    Reme
    mber, it is a game.

  5. #5
    Join Date
    Feb 2007
    Location
    Philadelphia, PA
    Posts
    2,675
    Quote Originally Posted by Krysstofur View Post
    Thanks, yes I understand it needs to be plugged in to be seen & how to use sys prefs etc.
    The issue is that once Lotro's gamespy picks a default playback it doesn't want to change, it just is not an option, totally grayed out.
    I was hoping someone could help me get that detail reset so it would look again and select the headset.
    I'd rather not do a full reinstall to fix one sentence of start code.
    If I find what to edit, I'll post.
    I had considered disabling the onboard speakers temporarily, but of course I didn't find an easy way to do that in the sound control panel.
    There is no reason or benefit from doing a re-install.

    The Game-spy technology has never "worked well" -- it has simply "worked."

    From what I can tell, the problem is with OSX, not with LOTRO.

    The one thing which I have found is that if you have the Headset plugged in when you Power-cycle (not reboot) your Mac, and then Launch the LOTRO client, it will work.

    I don't know if there are any preferences which might apply, but I doubt it.
    (~/Library/Preferences/com.turbine.lotroclient.plist)

    One other trick you can always try is to quit the client, delete that file and re-launch.
    Bill Magill Mac Player
    (OTG)
    Val - Man Minstrel (90)
    Valalin - Dwarf Minsrel (69)
    Valamar - Dwarf Hunter (105)
    Valanne - Beorning (90)
    Valdicta - Dwarf RK (104)
    Valhad - Elf LM (65)
    Valkeeper - Elf RK (86)
    Valwood - Dwarf RK (80)


    Valhunt - Dwarf Hunter (70)
    Valanne - Beorning (91)
    Ninth - Man Warden (65)

    "Laid back, not so serious, no drama.
    All about the fun!"


  6. #6
    I got the game to recognize the headset for in game chat ( the only thing not going to it) by selecting the headset as output but also muting the IMac speakers, then it was willing to see the headset.

    Reme
    mber, it is a game.

  7. #7
    Join Date
    Feb 2007
    Location
    Philadelphia, PA
    Posts
    2,675
    Quote Originally Posted by Krysstofur View Post
    I got the game to recognize the headset for in game chat ( the only thing not going to it) by selecting the headset as output but also muting the IMac speakers, then it was willing to see the headset.
    Very werid... makes me more convinced that it is an OSX issue.

    Interestingly, if you Google for "osx usb headset not working" (which, for me at least, is "auto suggested") the top listed hits are a number of references to Logitech headsets.
    The basic implication being -- the problem is not new or unique. (Going back to Lion!)

    This particular post is symptomatic of the strange USB behavior I have seen in the past: https://discussions.apple.com/thread/5303868

    I have Apple Care support and in the past when I have called about USB related problems, the first thing the support desk says -- plug it directly into the back of the iMac.... go figure
    Bill Magill Mac Player
    (OTG)
    Val - Man Minstrel (90)
    Valalin - Dwarf Minsrel (69)
    Valamar - Dwarf Hunter (105)
    Valanne - Beorning (90)
    Valdicta - Dwarf RK (104)
    Valhad - Elf LM (65)
    Valkeeper - Elf RK (86)
    Valwood - Dwarf RK (80)


    Valhunt - Dwarf Hunter (70)
    Valanne - Beorning (91)
    Ninth - Man Warden (65)

    "Laid back, not so serious, no drama.
    All about the fun!"


 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

This form's session has expired. You need to reload the page.

Reload