We have detected that cookies are not enabled on your browser. Please enable cookies to ensure the proper experience.
Results 1 to 4 of 4
  1. #1

    Angry HELP! Lotro Store glitch charged me 8 times for one purchase!

    I wanted to add a milestone skill slot. When I tried to do it, I kept getting an error that the request could not be processed and to try again later.

    Shortly after that, the whole store function went offline.

    Later, I log back in and I have SIX milestone skill things in my first inventory bag. On my milestone skills I now have 3 slots instead of 2 (which is what I was trying to do in the first place).

    I checked my account and it shows EIGHT charges for the same thing. As these things don't inherently stack, I can't use them because they are barred by the installed skill (normally, the store won't show you a skill upgrade that you already have active). At 350 points a pop, this is an expensive glitch.

    HELP!
    [charsig=http://lotrosigs.level3.turbine.com/012030000001e7ee0/01000/signature.png]undefined[/charsig]

  2. #2
    You need to contact Turbine Account Management. Either put an email ticket:
    http://support.turbine.com/ics/suppo...?style=classic
    via the support site and wait some days 3 days to a week for a response.

    Or call them on the telephone:
    http://support.turbine.com/ics/support/contactUs.asp
    when the lines are open get problem resolved immediately. Yula approved because I have no patience. I want it fixed NOW not hours or days from now.
    Unless stated otherwise, all content in this post is My Personal Opinion.

  3. #3

    Thumbs down

    I tried to call their number. Every time I try to press 2 to get to the LOTRO rep, it says I made an invalid choice. In fact, I don't think any of the buttons work.

    AAAAGGGGHHH!
    [charsig=http://lotrosigs.level3.turbine.com/012030000001e7ee0/01000/signature.png]undefined[/charsig]

  4. #4
    Join Date
    Mar 2012
    Posts
    570
    When you try to purchase something & you get one of these errors, never ever keep trying. Log out of game & log back in & you should have your item. This has happened to me & when I kept trying a few times, after logging out & logging back in I had multiples of the item.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

This form's session has expired. You need to reload the page.

Reload