We have detected that cookies are not enabled on your browser. Please enable cookies to ensure the proper experience.
Results 1 to 3 of 3
  1. #1
    Join Date
    Jul 2012
    Location
    Dublin, Ireland
    Posts
    7

    What happened to the Lost Alliance kinship?

    ...anybody?

  2. #2

    Lost Alliance, they do seem to be lost.

    Quote Originally Posted by Solarcon View Post
    ...anybody?
    I have just come back after a long break from LOTRO and wanted to get back in touch with Nesty and the gang, only to find out my universe has disappeared like a badly ending sci fi series. I typically used my Hunter named Jeofrey, around 45th, and a couple of others as alts. Currently looking high and low and no sign can be found, I am not happy. ### were they thinking of eradicating all those servers? A had characters on a few of them.

  3. #3

    Captain Eodenwen Reporting IN!

    I know this is a necro-post. Just in case any other LA'er or friend of LA'ers are or will be looking. This is the Captain Eodenwen, of the Lost Alliance. I am just starting back after a long break. I like you, ended up coming back to find Vilya no more. I decided to pop on to Landroval since I have always been bit of a RP-er at heart. I am still in contact with several other old LA'ers if you'd like to get in touch (Most not playing the game but still happy to help make contact for you). Since I need to re-learn the ropes I will be on some low level characters for a while. Feel free to hit me up on here or in game (I'll pop in on Captain E to check her mail from time to time.) Again sorry for res'ing this old post, still thought it best to answer.

    Captain Eodenwen of Rohan
    formarliy of Vilya now of Landroval
    aka
    Q
    [charsig=http://lotrosigs.level3.turbine.com/0b20c000000169196/01002/signature.png]undefined[/charsig]

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

This form's session has expired. You need to reload the page.

Reload