We have detected that cookies are not enabled on your browser. Please enable cookies to ensure the proper experience.
Results 1 to 6 of 6

Thread: Mouse Issue

  1. #1

    Mouse Issue

    Recently decided to get a "gaming" mouse. Plugged it in and had no problems until I got into LotRO, within a couple minutes, both my keyboard and mouse would lockup and I'd have to hard reboot. Figured it was just the mouse so returned it and got another completely different mouse and had the exact same thing happen. Used the second mouse literally all day long and then within 2 minutes of loggin into LotRO my keyboard and mouse lockup.
    Using Windows 8.1 now but had 8 when I tried the first mouse.
    Any ideas?

  2. #2
    Join Date
    Oct 2013
    Posts
    3
    Same with me, and I use windows 7. After a few mins the mouse pointer just drags to the bottom of the screen and the buttons don't work and I have to re-boot. I'm returning my new optical gamer mouse, but even using my old optical mouse, I get some crazy, unexplainable and erratic flipping up of the camera for no reason.

    Cheers.

  3. #3
    Join Date
    Jun 2011
    Location
    Frankfurt Main Germany
    Posts
    672
    google for windows 8.1 mouse lag and you find the answer. It seems a number of games have a problem with the new directinput Windows gave us with the update. There is a list with fixes but didn't work for me.
    Officer of Radix Lecti @ Laurelin (the only real taters)
    You want to know more?
    http://radixlecti.eu/
    The wise & sociable 2012
    Hero of the small folk 2013
    Original Tundra Cub owner 2014
    The kinship that brought the hobbit to Isengard :)

  4. #4

    Solution

    Looks like I have found a solution. I updated my drivers and LotRO would let me log in but once I selected a world, a window would pop up and immediately close. I found the fix for that in https://www.lotro.com/forums/showthr...ows-8-1-issues.
    "To solve the problem just delete your "UserPreferences" file in "C:\Users\####\Documents\T he Lord of the Rings Online", you might have to set a few options again but you will be able to play. "
    Once I got LotRO working again I decided to try one of the mouses again and was able to play several house Sunday with no issues.
    So, there was something wonky in the UserPreferences file that was causing the mouse issue.

  5. #5
    Quote Originally Posted by Erebthoron View Post
    google for windows 8.1 mouse lag and you find the answer. It seems a number of games have a problem with the new directinput Windows gave us with the update. There is a list with fixes but didn't work for me.
    Thanks for the tip- I rolled back to windows 8.0 from 8.1 and the weird mouse problems are gone. Makes me happy, and sad (that windows 8.1 is so terrible) at the same time.

  6. #6
    Join Date
    Jun 2011
    Location
    Sweden
    Posts
    63
    Best thing to do if you want 8.1 is to make a very clean 8.0 install (dont apply anything to it except win updates, no drivers at all and absolutly no programs/apps) and then throw 8.1 ontop, after that it works well with most things, the upgrade installation that is 8.1 is very poorly implemented, it breaks .net and Visual redists and lets not mention drivers...
    [CENTER][FONT=Book Antiqua][B][I]Bardori Warsong of The Lonely Mountain[/I][/B][/FONT][/CENTER]

    [CENTER][FONT=Book Antiqua][B][I]Proud Officer in [URL="http://www.radixlecti.eu"]Radix Lecti[/URL][/I][/B][/FONT][/CENTER]

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

This form's session has expired. You need to reload the page.

Reload