Firstly, I'm a casual player and have recently got the lotro bug again so much so that I purchased a quest pack and bought RoR edition for extra/new content. I have been VIP before and would like to do so again for more content but ever since I installed RoR and some recent patches the client crashes, with alarming regularity. It is better in non mounted combat regions it seems but can still crash. Prior to installing RoR I had no problems at all and the client would rarely crash. Luckily most times it crashes now is in passive situations like entering or exiting buildings but it has got me killed on numerous occasions as well.

My system is intel i5 cpu @ 2.8ghz, 4 gig ram installed (2.96 gig shown available by windows) and a 1 gig Radeon HD 57xx gfx card. OS is xp 32 bit home edition.

I have searched for possible causes and solutions and read so much that my eyes hurt. End result is that I am non the wiser for a solution and have an endless list of possible causes. Generally it seems to be a popular opinion that it is a memory problem and the magic number seems to be less than 3 gig available causing the problems. There are various tricks and ways suggested to enable more than 3 gig memory in a 32 bit OS but having tried them all with no success I am resigned to not fixing it with my current setup. Having also read that 32 bit OS's cannot ever really access more than 3 gig of memory, if this is the cause of the problems, then the only way I can fix it is to upgrade my OS. Hence the question in the title, if this is so are the min requirement for lotro now that you require a 64 bit OS because a 32 bit OS just can't give you enough memory.

I am interested to know if anyone else has had this problem on a 32 bit OS with RoR installed and have fixed it. Conversely, those that have no problems with RoR, are you running a similar setup to me?

My dilemmas are, do I buy a 64 bit OS in the hope that it will fix the problem? Do I go VIP or purchase future content? I know the problem is not limited to just me but I have yet to read of someone having the same problem and fixing it. Has anyone actually solved this problem and if so how did you do it? Do I just give up on the game and find something else? (I'd hate for that to be the solution).

Please post a reply if you have some constructive info etc. Meanwhile, I'll log back in again and carry on with Hytbold rebuild....