We have detected that cookies are not enabled on your browser. Please enable cookies to ensure the proper experience.
Results 1 to 4 of 4
  1. #1

    Payment not yet accepted by Wb

    I have purchased HD using the ultimate pay option on he website, but im getting an e-mail from ultimate pay saying that warner bros have not yet accepted the payment....is there anything that can be done to rectify this?..or have i lost my £45.....

    I can provide full transaction numbers that i was given saying i purchased the item:-

    WB - Production 1 Transaction ID: a4755977-103b-4673-9b66-3e56979f7f93

    i can email the full transaction reciept,account numbers etc to verify the transaction...

    Turbine Customer Support: #24001-519048? is my ticket number
    Last edited by valkrye; Oct 04 2013 at 09:19 AM.

  2. #2
    Join Date
    Aug 2013
    Sorry for the inconvenience and delay. We are looking into issues with UltimatePay orders. Once the issue has been resolved, the products will be granted to your account automatically.
    Contact us on Twitter @LOTRO

  3. #3
    Join Date
    Jun 2011
    Remscheid, Germany
    Are there any Information when this problem with UlitmatePay will probably be solved?

    I have the same problem with my pre-purchase of HD and using UltimatePay. Now it is more than 10 days since I pre-ordered. And for my submitted tickets I did not receive any corfirmation and no ticket-numbers. (For both, the german and the english ticket)
    Arennor of Belegaer

  4. #4

    Thumbs down

    WHY? do you give us the ability to pay via Ultimatepay when it is not possible in the end? any reasons for this?!

    I paid and got some standard blabla mails, but not the HD expansion...

    No answer from Turbine support on my ticket.
    No answer from Ultimatepay support on my mail.

    I "purchased" , or at least tried to, on 13 Sep....

    Any news regarding this issue?



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

This form's session has expired. You need to reload the page.