We have detected that cookies are not enabled on your browser. Please enable cookies to ensure the proper experience.
Results 1 to 2 of 2
  1. #1

    Can't Purchase Helm's Deep

    Every time I try I get:

    "Error
    There was a problem with this request. "

    Tried multiple payment methods, same result each time.

    What gives?
    [charsig=http://lotrosigs.level3.turbine.com/0420800000010da9a/01008/signature.png]Murili[/charsig]

  2. #2
    Sometimes Turbine's system is not able get the funds from whatever you are using to pay with. In these cases, you have to call Turbine Account Management get to try and force the transaction manually.

    You can also try waiting a day or two to see if the problem clears up on its own. It is a Sunday. Part of the system may have locked up. Since Sunday is not a normal business (M-F) there may not be anybody to replace a dead gerbil. Or wake up a guinea pig that refuses to get up and go to work.
    Unless stated otherwise, all content in this post is My Personal Opinion.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

This form's session has expired. You need to reload the page.

Reload