We have detected that cookies are not enabled on your browser. Please enable cookies to ensure the proper experience.
Results 1 to 9 of 9

Hybrid View

  1. #1
    Join Date
    May 2011
    Location
    Netherlands
    Posts
    345

    Loggin into the site leads straight to the last forum page I visited?!

    Hey all,

    After posting in the thread "Cannot enter lottery" it doesn't matter where I log out or in on the entire site, I'm immediately returned to the forum page I last visited. I didn't have any problems before posting in that particular thread.

    I'm using Firefox. I've already closed Firefox and everything, but this weird bug keeps popping up. It's almost like with the previous site where you were being led to the page you were originally on......

    Also, somehow all forums were marked "read" while I hadn't clicked that option. I've even made a new password, closed Firefox and tested it again.
    Accessing the site and not the forums gives a normal reaction. From the moment I enter the forums it's wrong again. I can visit the main site and log out there all I want, I'm being led straight back here to the last forum page I visited, instead of the page of the main site I was visiting.

    What's going on? Does the forum already have problems not even week after it's completely revamped?

    How do I solve this?
    Last edited by Shriya; Aug 10 2013 at 08:52 AM.
    Country: Netherlands, Current Server: Nimrodel. Future server: Landroval
    Sheherezi's an Eastemnet Cook & Farmer

  2. #2
    Join Date
    Feb 2007
    Posts
    12,677
    Quote Originally Posted by Shriya View Post
    I've already closed Firefox and everything, but this weird bug keeps popping up. It's almost like with the previous site where you were being led to the page you were originally on......
    That's weird - haven't seen it. However, I'd try clearing out your cookies (since that would be the most likely mechanism for it to be remembering that sort of information across sessions).

    Also, somehow all forums were marked "read" while I hadn't clicked that option.
    This might be a setting Turbine has on their end - there are several possibilities for "Thread/Forum Read Marking Type". One of them is inactivity-based... if you get logged out for inactivity, it will mark all forums read. The other types require it to store lots of information in the forum database about every thread changed since the last time you marked all threads read.

    Does the forum already have problems not even week after it's completely revamped?
    It's not exactly a surprise if new software has bugs in it. However, these forums don't seem to be even remotely as buggy as the ones Turbine switched to when they rolled out F2P. Those were just horrendous.

    Khafar

  3. #3
    Join Date
    May 2011
    Location
    Netherlands
    Posts
    345
    Quote Originally Posted by Khafar View Post
    That's weird - haven't seen it. However, I'd try clearing out your cookies (since that would be the most likely mechanism for it to be remembering that sort of information across sessions).
    I already cleared my cookies and my Cache before posting the OP

    Quote Originally Posted by Khafar View Post
    This might be a setting Turbine has on their end - there are several possibilities for "Thread/Forum Read Marking Type". One of them is inactivity-based... if you get logged out for inactivity, it will mark all forums read. The other types require it to store lots of information in the forum database about every thread changed since the last time you marked all threads read.
    Hmm.. Could be. Hadn't noticed it before. Although... I wasn't logged out because of inactivity. I logged out myself for testing purposes.

    Quote Originally Posted by Khafar View Post
    It's not exactly a surprise if new software has bugs in it. However, these forums don't seem to be even remotely as buggy as the ones Turbine switched to when they rolled out F2P. Those were just horrendous.

    Khafar
    True, you've got a point there. But it in a weird way it seemed so much like the problem the old forum had (kept going back to the previous page instead of the forum, while now I was led back to the last forum page I visited each time) which I thought was solved so that I was suprised.
    Right, did this still make any sense?

    hmmm.. still testing, I've had restarted my PC (RL bugging in with grocery shopping and such ) and at first glance it seems to have corrected itself. I've logged in from the mainsite and was led to my account page instead of the forum. I've visited the forum mainpage and went back to the lotteries page. Logged out from there and got the login screen instead of the main forumpage, which of course was a good thing. Now lets see what happens when I've submitted this post and then log out on the main site page.

    ETA: Too bad. After I submitted this post I went back to the mainpage of the site and logged out there. I was immediately led back to this thread which was the last forumpage I visited.
    Country: Netherlands, Current Server: Nimrodel. Future server: Landroval
    Sheherezi's an Eastemnet Cook & Farmer

  4. #4
    Join Date
    Feb 2007
    Posts
    12,677
    Too bad. After I submitted this post I went back to the mainpage of the site and logged out there. I was immediately led back to this thread which was the last forumpage I visited.
    Have you tried this with a different browser, like Chrome? If it's specific to Firefox, it's always possible it's a setting (or bug) with that browser. Do you have FF set up to restore your last session on startup?

    Also, if you login from a specific page, LOTRO's forum will redirect you to where you were - that's a common feature on lots of websites. The best assumption they can make is that you wanted to get back to where you were when you're done logging in.

    Khafar

  5. #5
    Join Date
    May 2011
    Location
    Netherlands
    Posts
    345
    Quote Originally Posted by Khafar View Post
    Have you tried this with a different browser, like Chrome? If it's specific to Firefox, it's always possible it's a setting (or bug) with that browser. Do you have FF set up to restore your last session on startup?
    This I'll need to try out. I haven't had this problem before my post in the other thread though. I didn't have this problem yesterday, though. I only ran into this problem today when I posted in the "Cannot enter lotteries" thread.

    Quote Originally Posted by Khafar View Post
    Also, if you login from a specific page, LOTRO's forum will redirect you to where you were - that's a common feature on lots of websites. The best assumption they can make is that you wanted to get back to where you were when you're done logging in.

    Khafar
    Like I said above, I wasn't on the forum when I logged out. I was on the Lotro Main page . When I logged out there before I made a new post in this thread, I was just redirected back to the Login screen of the account page of the site (NOT the forum). Getting there seems perfectly logical to me. Heck, getting back to the Lotro Main page would have even been more logical since I logged out there.
    Returning to the last forumpage I visited before returning back to site's mainpage while I'm NOT ON THE FORUM when I click log out is ABSOLUTELY NOT logical.

    ETA: Okay, just tried it in IE. Repeated the exact same steps and got exactly the same problem. Here are the steps:
    1. go to the Lotro Main Page
    2. Click login and enter your login data
    3. You're landing in your main account page of the site (NOT the forum)
    4. Visit the mainpage of the forum
    5. Go back to the main site (click community-> lotteries or simply the logo)
    6. Click log out
    7. You'll get the login screen from the main site or the message "You need to be logged in" on the Lotteries Page
    So far so good. Everything's absolutely logical
    8. Enter your login data in the login screen.
    9. You're presented with your main account page of the site (NOT the forum)
    10. Visit the forum's mainpage
    So far so good
    11. Click the subforum we're in right now (Forums, Lottery & Community site discussion)
    12. Click the logo again (or community-> lottery) and click log out once you're on the mainpage or the lottery page (Mind you: this is NOT the forum!)
    13. Be presented with the forum page you last visited (Forums, Lottery & Community site discussion)
    THAT'S NOT GOOD
    When I click "log out" on the main page I should be presented either with the mainpage or the with the login screen. When I click log out on the lotteries page I should be presented with the message "You need to be logged in" on the lotteries page. That's what I've seen before I got these problems.
    Last edited by Shriya; Aug 10 2013 at 12:19 PM.
    Country: Netherlands, Current Server: Nimrodel. Future server: Landroval
    Sheherezi's an Eastemnet Cook & Farmer

  6. #6
    Join Date
    Feb 2007
    Posts
    12,677
    Well, I was able to reproduce it in Chrome by following your steps. I don't think I've ever once logged in from the site's main page before, during the 9 or so years I've been posting on this forum (or its predecessors). In fact, I almost never visit there - I bookmark the forum list and come straight here.

    Thing is... for me your issue would be a feature, not a bug. I like that it remembers where I last was on the forums, because that's what I care about. However, I can see how it could be annoying for those who expect to wind up back on the main page when they log in there.

    Khafar

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

This form's session has expired. You need to reload the page.

Reload