We have detected that cookies are not enabled on your browser. Please enable cookies to ensure the proper experience.
Results 1 to 5 of 5
  1. #1

    Light Caparison of the Norcrofts won't show

    Hey guys,
    for the last three or four days, my normal 'outfit' for my horse, the Light set of the Norcrofts, will show every other piece but the Caparison. While it's not a huge deal, it's still pretty annoying.
    Does anyone else have this problem, or a possible solution? I've tried mounting/dismounting, changing the appearance of the horse while mounted and dismounted, taking all the 'armor' off of the horse, putting it back on, etc. Every other caparison works but the Light Caparison of the Norcrofts. my Entwash, Sutcrofts, Rohan set, and my Spring Festival sets all work.
    Is there any kind of solution or fix? Like i said, it's not a huge problem, but it's just annoying.
    Thanks everyone!

  2. #2
    Join Date
    Jan 2007
    4 Wending Way, Haremead, The Shire
    I don't have a solution, but just so you know that you're not alone -- mine isn't showing up either.

  3. #3
    Join Date
    Jan 2012
    That happened to me as well, but I haven't figured out a solution yet :/

  4. #4
    happened to me too - bugged it. You should as well.
    <Landroval: Gawaine (Lvl 85 Hunter) ~ Muddvayne (Lvl 85 Burglar) ~ Fealasse (Lvl 85 Loremaster) of Hobbitual>

  5. #5
    Join Date
    Sep 2010
    I've had that problem with my Warden (Caparison isn't showing up) and I've tried everything...removing it and putting it back, switching to a second cosmetic tab, and so on, and nothing works.

    I've also had an even more annoying problem with my Hunter's Warsteed; she won a cosmetic set during the spring festival and at first it was lovely, the entire set was red. Now when she mounts up the head piece is still red but the caparison is blue and I can't change the color. In addition, the flag decoration seems to be permanently stuck on there, as it won't let me remove it. Let's just say she looks rather weird riding around on a half-blue, half-red horse, lol.

    I'm wondering if this isn't a bug that surfaced after the last update, as I can't recall ever having seen it before.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

This form's session has expired. You need to reload the page.