We have detected that cookies are not enabled on your browser. Please enable cookies to ensure the proper experience.
Results 1 to 5 of 5
  1. #1
    Join Date
    Dec 2007

    Unhappy Vol 1 Ch 8-Mordirith's Bane won't advance

    I noticed I had not finished Vol 1 epic, so I went to GF to talk to Golodir. No Golodir. Went to Aragorn, no quest. My completed quests said I had finished the instance Mordirith's Bane, but not the quest, so I went to a reflecting pool and did the instance. When I talked to Golodir after the instance, he ported me back to GF but he didn't have a ring. I tried again with the same result. I am not Vip so it wouldn't let me submit a ticket. Can a GM please advance the quest so I can finish that chapter of the epic, or am I missing something?

  2. #2
    Join Date
    Jun 2011
    Manchester, UK
    Don't remember this well enough to offer you a pointer, but a couple of general tips you might try:

    1/ read the full text of the completed quest, see if it offers you a clue as to where to cash it in?

    2/ Invest a mithril coin to go directly to that questmaster?

  3. #3
    You must be on Book 8 at the point where Golodir sticks Dunachar into Mordirith resulting in a broken sword and Sara Oakheart shows up to steal the palantir. At least it seems that way to me. That is about halfway through Vol 1.

    I would assume that you collected Golodir's gear as suggested by Laerdan, got it repaired as needed, and presented the repaired items to him to motivate Golodir to fight Mordirith? That would lead to the instance Mordirith's Fall.

    It has been a while since I did Vol 1 and whatever you were doing might have been instanced so therefore wiped off your pending quest log which means you'd have to go get it again. Doing the instance does not (to my mind) advance the epic story if you have not done a pre-requisite quest that would lead to it.

    Since you mentioned Golodir and Aragorn, I wonder if you collected all of Golodir's gear and got it repaired as needed then presented it to him? That should lead to the instance you apparently did assuming it was with Golodir.

    If you were towards the end of the Volume, you'd have been on Book 15.

    Excuse me if this is all silly or you have done all of it. Aside from a glitch (always possible) it sounds like a pre-rec has not been fulfilled.

    My best guess based on what you posted. Good luck.

  4. #4
    Your first step needs to be positively identifying the last quest you did in Vol 1 epic. Compare your completed quests in your quest log to lotro-wiki's Epic Quests overview; you may want to start at the Vol1.Book8 list.

    Ignore the instance quests in your completed quest log; focus on the chapter quests. What was the last completed book chapter? Are you currently on a book quest, and if so, which one? If you can answer those questions, we'll be able to help you much more directly.

    Note that lotro-wiki's pages do not mention a "Mordirith's Bane", but "Mordirith's Fall" is Vol1.Bk8.Ch5. If you've completed this and also completed Vol1.Bk8.Ch6, you're done with Book 8 already. Have you completed any of Book 9?

    Quote Originally Posted by Brodrick View Post
    I am not Vip so it wouldn't let me submit a ticket. Can a GM please advance the quest so I can finish that chapter of the epic, or am I missing something?
    Unfortunately you can only get in-game assistance from a GM by submitting a ticket in-game. You could try submitting an account ticket at https://myaccount.turbine.com/, or you could purchase something to make your account Premium or VIP and thus eligible for in-game help.
    Join the LotRO Volunteer QA Team!
    Use the bug reporting tool or type /bug in-game!*
    *no rants please

  5. #5
    Join Date
    Dec 2007

    Thumbs up

    Alright, went back to Chapter 7 and found that I had to talk to the Dorf next to Dwalin. So now I am back on track.
    Thanks for the help!!!!!!



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

This form's session has expired. You need to reload the page.