We have detected that cookies are not enabled on your browser. Please enable cookies to ensure the proper experience.
Results 1 to 7 of 7
  1. #1
    Join Date
    Oct 2010
    Posts
    2

    DirectX error coming up instead of the world

    I've been playing Lotro for almost 3 years on this computer. On I think May 14th or 15th everything ran fine as always. But on I think May 16th it would not let me in. As kin leader I think somebody might be missing me I login fine. I go into Riddermark but instead of coming up it gives this DirectX error. I get the same error with my other Turbine game DDO.

    The error is:
    Game error 105:
    Could not initialize Direct3D. Please ensure you have DirectX 9.0c [Dec 2005] installed. [105].

    I did dxdiag and it looks like this.
    Operating System: Windows Vista Home Premium (6.0, Build 6001)
    System Manufacturer: Hewlett-Packard
    System Model: HP G70 Notebook PC
    BIOS: Default System BIOS
    Processor: Intel(R) Core(TM)2 Duo CPU T6500 @ 2.10GHz
    Memory: 2974MB RAM
    Page file: 1199MB used, 4991MB available
    DirectX Version: DirectX 10

    Does this mean Turbine does not work with DirectX 10 for my type of system?
    I'm quite baffled. Any ideas?

  2. #2
    Join Date
    Jun 2011
    Location
    Germany
    Posts
    2,040
    DirectX 10 does not include DX9. So make sure, you have installed the latest DX9 from Microsoft.

    More information about this error and sownload links are in this article
    http://support.turbine.com/link/port...gher-installed
    Wer Hilfe will, muss Informationen liefern.
    >> Lotro World transfer status <<

  3. #3
    Join Date
    Oct 2010
    Posts
    2

    Thumbs up Sweet. That fixed it. Thanks so much :)

    Apparently all I had to do was rename that ini file and try again. It popped up asked if I wanted to enable directx 10 and I said no and it worked great.

  4. #4
    Quote Originally Posted by Amrundir View Post
    DirectX 10 does not include DX9. So make sure, you have installed the latest DX9 from Microsoft.

    More information about this error and sownload links are in this article
    http://support.turbine.com/link/port...gher-installed
    The link broke since the post. For future use:
    http://web.archive.org/web/201404051...gher-installed

    And thanks for the link!

  5. #5
    Join Date
    Jul 2016
    Location
    UK
    Posts
    1,388
    I had the exact same issue and about the same date, I reinstalled the full dx9 package and fixed it.

    As per another dx9 thread, I wonder if an AV update deleted the missing .dll file as a false positive.

  6. #6
    That's easy to verify, isn't it?

  7. #7
    Join Date
    Jul 2016
    Location
    UK
    Posts
    1,388
    Quote Originally Posted by OghranNasty View Post
    That's easy to verify, isn't it?
    If thats a reply to me, I dont know, AV update virus deffs so often that by the time you realise there is an issue, a new set of deffs may have been downloaded to replace the duff ones. It is only when an AV update bjorks something in the OS that anyone really notices. My Virus Vault is empty, which it shouldnt be, as it picked up another false positive a couple of weeks ago, so it should have had THAT file in there. Ditto the alerts log.

    On the day in question, I had been playing LOTRO earlier in the day and not rebooted my PC, however my AV checks for updates every 10 minutes, so it is possible it got the update that caused the issue, then got a later update that fixed it again before I even fired up LOTRO for my late evening session.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

This form's session has expired. You need to reload the page.

Reload