We have detected that cookies are not enabled on your browser. Please enable cookies to ensure the proper experience.
Results 1 to 9 of 9
  1. #1
    Join Date
    May 2008

    Thumbs down Day#2 stil can not log in :(

    well day#2 to me still problem with launcher working, gets stuck at world login.

  2. #2
    same for me tryd to repair/update it won't work same problem like yesterday but therefor before the update i never had trouble with the same thing

  3. #3
    Join Date
    Jun 2011

    same here

    this is getting tiresome

  4. #4
    Join Date
    Nov 2010
    don't know if this will work for you or not - but one of my kinnies got stuck at the same place - finally "chose" his language, and got in.

    You still may have to choose a different language after that, and then switch back as soon as it lets you (you don't have to patch both languages).

    Hope that works for you.
    . Montras (Main - Hunter 95); Goswen (Minstrel - 95): Monntras (Captain - 21) ; Amtu (Black Arrow R8) Aa' menle nauva calen ar' ta hwesta e' ale'quenle

  5. #5
    Quote Originally Posted by MaestroJack View Post
    (you don't have to patch both languages)
    Not sure if this is actually true. When I tried switching languages and then switching again before the patch in German completed, nothing changed for me. Tried again, got the blank installer. Tried a third time, letting the German version patch and then switching back to English, got right in.

  6. #6
    Join Date
    Nov 2012
    Yea I been waiting as well with no chance of getting in, even though I got further then I did yesterday.

  7. #7
    Join Date
    May 2008
    Seems that switching launguges is working thanks everyone good advise

  8. #8
    Go to the Launcher Menu, Settings, Proxy (third tab) and check your settings.
    It may be that you need to select "No Proxy".
    This works especially well if you're able to select a server on the list but the Play button does nothing.
    --= Windy Acres Ranch -- http://SteelAndMagic.com =--

  9. #9
    I went through this yesterday. In order for the language trick to work, when you get stuck at the world choice, make sure you actually log out. Then restart client, switch languages, and as soon as it lets you switch languages again, switch back to your original language selection. It should shut the client down and when you restart log in. Once you get to the "pick your world" part, and click on start, you should get an agreement pop up. You will have to agree to both agreements before it will fully launch.

    If you get the initializing and doesn't go away, "x" out of the client and give it a couple of minutes and try again.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

This form's session has expired. You need to reload the page.