How I can hide war-steed EXP bar when using F12 Hide HUD hotkey? It hides everything else, but not that mount EXP bar. Is there checkbox in options that I need to enable?

It looks ugly on screenshots.