We have detected that cookies are not enabled on your browser. Please enable cookies to ensure the proper experience.
Results 1 to 5 of 5
  1. #1
    Join Date
    Mar 2013
    Posts
    2

    Unhappy Cannot buy turbine points anymore (ERR-17)

    I've played LORTO for a while now, I've added extra points and bought items before, but now everytime I try to add points it gives me an error message.

    I try to buy points through the in-game store, go to 'add points', then 'purchase points through Steam'.
    Sometimes it already gives me the 'ERR-17' message there, but most of the times I can pick how many points I want. But no matter which one I pick, the moment I click 'Buy now' it gives me this error:

    "There was an error processing your order.
    Please click here to return to the point purchase page and try again.
    (ERR-17)"

    I've tried returning and trying again, it fails every time.
    I've restarted the game-app multiple times.
    I've added my credit-card to my account (not that I've ever had to do that before) but that also fails.

    Does anyone have any idea what I can do?

    Thanks in advance

  2. #2
    A number of people have this problem. You will need to contact the nice humans in Turibne Account Support to manually update your payment information. You have two chocies:

    1) Put in an email ticket via the support portal. Wait the 1-2 weeks for the ticket to get to the head of the queue so that a human can work on it.

    2) Call Turbine on the telephone when the lines are open get the problem solved immediately.
    Unless stated otherwise, all content in this post is My Personal Opinion.

  3. #3
    I've been having this exact problem with mine too, I can't seem to fix it either.

  4. #4
    Im also having the exact same issue. You really need to drill into the contact information to find the number, but heres the info. Calling now.

    Contact Account Support toll-free at 1-855-WBGAMES Account Support Hours: 10am – 7pm Eastern Time 7 days a week (GMT -5) If calling isn't an option, we can provide you with fax details via email.

    Please note that this telephone number is for Account Support only. The Account Support Team is unable to assist with technical, in-game, or forum concerns.


    Update: At least in my case, Im running through steam. I wasn't aware there was a separate ingame client. The only solution is to uninstall...the entire game. And reinstall..the entire game with their client, since it would appear (and makes sense) that this is a problem with Steam.

    The kid was rushed and on script and also offered to take a payment manually I was in queue for a min or so. Im guessing there may be a few others with the same problem. I was too annoyed by the bother to have to dig out the info. im going to grab a few screenshots and try and try to grb someone at steams attention.

    Update 2 did it through paypal instead...try and keep me from throwing my money at you will you!

    On that note.... TO ISENGARD!
    Last edited by Ginko; Apr 20 2013 at 04:40 PM.
    [FONT=system][B]Stundot!™[/B][/FONT]

  5. #5
    Join Date
    Mar 2013
    Posts
    2

    Cool

    I just went through the entire un-installing/re-installing thing with Steam, unfortunately it didn't help a single bit.

    I did notice, just before I uninstalled everything, my error message started switching between the known ERR-17 and a new ERR-25. Not sure if I'm happy with that..

    I'm going to bother the Steam support then, see if that gets me anywhere. If not, I'll give Turbine a call.

    Thanks for your replies!

    EDIT: SUCCES! I've just de-installed it again, but this time re-installed the game by downloading it from www.lotro.com and that did the trick!
    Since I no longer have to use Steam it doesn't show me the error anymore and I can freely spend my money

    Thanks again for all your help!
    Last edited by Luthewyn; Apr 21 2013 at 05:49 AM.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

This form's session has expired. You need to reload the page.

Reload