We have detected that cookies are not enabled on your browser. Please enable cookies to ensure the proper experience.
Results 1 to 2 of 2
  1. #1
    Join Date
    Feb 2013

    Defender of Ered Luin deed not progressing.

    Hello,I have been trying to complete the deed "Defender of Ered Luin" but it just stopped at 16/20. I have completed several quests after 16/20 but no progression and still shows 16/20. Furthermore, I have started a new dwarf character to test this deed if it is working for a new character or not, but after completing several quests there is no "Ally of Ered Luin" in my deed log.(Yes, I have finished intro with new dwarf character.) I have tried relogging, restarting the game and even a complete reboot but it is still the same. Please help me I can not seem to get this deed work.
    Last edited by Klendea; Apr 12 2013 at 01:22 PM.

  2. #2
    Join Date
    Jan 2007
    Depends on which game I'm in :)
    The only quests that count for this deed are the quests that show up under the Ered Luin heading of the Quest Log. Not every quest you get in Ered Luin counts (e.g. epic quests, festival quests, crafting quests). Open your Quest Log and look for quests under the Ered Luin heading to complete. Check the deed progress when the quest is completed. You can add the deed to the Quest Tracker to see the progress easier (it will also flash when it gets updated).
    "Everyone's got one. Better to be a smart one than a dumb one." - me
    "It's people like you that [I]think[/I] you know everything that give those of us that [I]do[/I] a bad name." - me
    "Eat, drink, and be Merry, 'cause Pippin was a fool of a Took."



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

This form's session has expired. You need to reload the page.