We have detected that cookies are not enabled on your browser. Please enable cookies to ensure the proper experience.
Results 1 to 6 of 6
  1. #1
    Join Date
    Oct 2011

    Mouse Wheel Zoom Problem Summary Thread

    Hi all,

    I understand that this is a long post but please consider reading (or at least skimming) it in case you have problems with your your mouse wheel zooming function - or, and I am equally exited about this one, if you are interested in testing whether a strong and coordinated community effort in the forum can actually lead to getting a bug fixed! Every player can contribute!

    Okay, let's get started:

    Motivated by being frequently affected by the 'mouse wheel scroll bug' (see below), I decided to spend some time researching ALL the relevant postings in the different forums here. As of now (March 25, 2013), I am done collecting information and would like to start this summary/review thread in the good hope that with the community's help, we can tackle this long existing and rather annoying bug well enough to allow Turbine to come up with a fix.

    To ease reading, this post is organized into sections. This first post will be edited regularly.

    0. Sources
    I'd like to start with sources first, allowing interested readers to update their knowledge and learn what other users have reported and tried so far. This is not a complete list of threads I studied, but the main observations and the most relevant discussion of the bug are provided here:


    1. Bug description / Symptoms
    In normal game play the mouse wheel is controlling the camera's zoom, i.e. the distance from which the camera is looking down at your character is changed within a certain range. The same functionality is provided by the +/- keys on the numeric pad. Under certain conditions, the mouse wheel stops to affect the camera zoom factor while the +/- keys still work. Also the mouse wheel still works when scrolling within User Interface (UI) windows. The bug persists until the LOTRO client gets completely restarted, just logging the same character out and back in won't help it. Even logging on with another character in between won't help the first character's stuck zoom until you really completely exit the game.

    2. How to reproduce it
    While this still needs further confirmation (see section 5, How can the community help?) these steps represent the best way known to trigger the bug:

    2.1 Arrange or wait for a situation in which you've got enough messages in your in-game mailbox that listing them will force the corresponding UI window to draw a scroll bar. Important: The sender of the message has to be the action house (AH), messages from other characters are reported not to trigger the bug.

    2.2 Use the mailbox to display the list of available messages. Now process them as fast as your clicking abilities allow. I usually start at the bottom of the list. Use a double click to open the mail, grab the item or money and delete the mail. At this point, the current UI window will auto-close and the remaining messages in your box are presented. Process them exactly the same way and continue to work through all your mail, always maintaining the utmost speed you can manage. Speed really is the factor here, do it slow and the bug will not appear.

    3. Failed work arounds and fixing attempts
    List of "fixes" that have been reported not to work, including replies from customer support:

    - Walking to mailbox instead of riding.
    - Within "My Documents" or "Documents" > "The Lord of the Rings Online": deleting file "lotro.keymap" to force the client to
    regenerate it during next launch (and thus losing your custom key mappings until you redo them).
    - Using other "unbugged" mailboxes.
    - Reinstalling the game.
    - Reinstalling the mouse driver(s).

    4. Successful work arounds
    List of work arounds that successfully prevent the bug:

    - Never have more than 4 messages in your mailbox, i.e. prevent the scroll bar from appearing. This is might be near impossible to achieve if you use the AH frequently.
    - Work through your messages slowly, allowing the UI and auto-close mechanism to 'stay on top of things' thus preventing the mouse wheel getting stuck in 'UI mode'.

    4. Confirmed platforms and LOTRO versions affected
    ============================== ===
    This bug has been reported on Windows LOTRO clients all the way from Alpha (July 2007) to date (March 2013) suggesting that it is a bug in the LOTRO code and independent of the used Windows platforms and different mice models. There is confirmation for:

    - Windows XP; 32bit & 64bit; DX9
    - Windows Vista; 32bit & 64bit; DX9 & DX10
    - Windows 7; 32bit & 64bit; DX9 & DX10

    5. How can the community help?

    If you think this bug is worth fixing, then please consider taking 15 minutes to help the case! This is best done by following the instructions below and NOT just by replying to this thread stating how much you hate this bug! The goals are to keep this thread well organized with the ultimate aim to have it reported many times (i) and being able to indicate how it is reproduced (ii).

    5.1 Bookmark this thread if you plan to help at a later time or wish to keep up with it. If you can't find it, you can't help us.

    5.2 Try to recreate the bug. If successful, please use the in-game /bug command to file a bug report. You can copy the text above for the instructions how to reproduce it, if you did it that way. Also, please reply to this thread stating your OS version, mouse model and whether you were able to reproduce the bug or not!

    5.3 If you know other ways to reliably recreate this bug, report it here stating your platform and mouse model. Please report it in-game too (see 5.2). Seeing the bug one time is by far not enough. Report only if it worked for more than 5 times the same way, with no exceptions.

    5.4 If you seem not affected by the bug after trying the instructions in section 3, please also report it here stating your platform mouse model, how many mails you processed, and how many seconds it took you.

    Thank you very much for your help!

    I will tally up your replies by editing this posting and hope that with joined efforts we can get rid of the bug! Please send me a private message here in the forum if you have ideas how to improve this post with respect to structure, orthography, or other.
    Last edited by Singbard; Mar 25 2013 at 04:28 PM.

  2. #2
    A kinmate mentioned this to me, and I know I've suffered from the same problem before. Here's an excellent post almost one year back that documents alot of information about the annoying issue that's been a bug for as long as I can remember.

    Shame nobody has done anything about it.

  3. #3


    Hi (= Just like to add my 2 cents:

    In my experience, the number of mails doesn't matter in getting this bug. I've had one mail once and as soon as I detached the item, the scroll wheel stopped working for zooming. Also, while the mail list is open, holding down the right mouse button to look around can cause the bug.

    To minimize in getting the bug, I try not to move my toon around while processing my mails. After I'm done, I walk as far as when the UI is suppose to disappear on its own before using the scroll wheel again.

    Hoping that Turbine can finally solve this problem.

  4. #4
    Join Date
    Jun 2011
    I have begun to suffer from this bug in the last 10 days, for the first time ever since I started. Three times, nothing to do with any mail use. Only fixed with a restart of the client.
    'A cage,' she said. 'To stay behind bars, until use and old age accept them, and all chance of doing great deeds is gone beyond recall or desire.'

    [evernight] lilka : warden | gwenaëlle : champion | elorie : minstrel | cedar : hunter

  5. #5
    Join Date
    Oct 2011
    I have been playing since 2007 and don't recall experiencing this bug in the past but since returning to play again in the last 6 months I have been experiencing this bug fairly often. I would say it is mail related for me as my kinship sends a lot of mail and I've been noticing it more often recently while taking care of the kin mail (by removing it more often) but still receiving mail from Auction House. Complete reboot of the game works to fix it but so far nothing else. I have Windows 7 64bit DX11.

    As far as section 3 goes. My install is already fresh, all of my drivers are up to date including mouse drivers which I updated recently because I have a stupid high mouse speed and it was playing up. Since you don't have to use a mailbox now, this issue has occurred when I just use the VIP popup mailbox as well in which case I do think I was mounted. Will pay more attention to specifics now that I know it's an actual bug (*cough* should we start calling 10 year old bugs features?) but so far definitely feels mail related.

    Thanks for your post!

  6. #6

    was this ever resolved?

    first time ever happened today at the festival, zoom has locked on in default, just behind the character.
    relog hasnt fixed it?
    “If more of us valued food and cheer and song above hoarded gold, it would be a merrier world.”
    ? J.R.R. Tolkien



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

This form's session has expired. You need to reload the page.