We have detected that cookies are not enabled on your browser. Please enable cookies to ensure the proper experience.
Results 1 to 3 of 3
  1. #1
    Join Date
    Jan 2011

    carnt enter the middle earth world

    any help plz i can make a char then when i click on enter middle eart world it goes to the loading screen then freezes doesnt load so carnt get into the game and susgestions plz

  2. #2
    Join Date
    Jul 2011
    A few suggestions:
    • Set your graphics settings to very low, and DirectX to the lowest version listed
    • If you haven't tried already: reboot your computer
    • Re-install the game
    • Check your port-forwarding (more info here) and other firewall settings
    • I've had the same problem too about a year ago, but my problem was that something with the router (we still don't know exactly what), it didn't occur anymore since we have a new one. This might not work for you and may cost a lot of money, so I don't advise trying this out... I don't want to make you waste money and time.
    Good luck!
    Fordil of Landroval, Minstrel officer of The Alliance

    Check out my Guide for New Players: https://www.lotro.com/forums/showthread.php?507561-GUIDE-New-to-LOTRO-hints-and-tips

  3. #3
    Join Date
    Sep 2011
    vicky11970, I'm having the same problem, on Crickhollow. Which server did this happen to you on? Any chance it's the same one?

    Edit: I again hit my router reset button just for kicks. I just managed to get in by trying reducing the graphics setting to 'Very Low' on the character selection screen. That seemed the easiest, most immediate thing I could try and it worked. So now I don't know if it was the router or the graphics setting lol. I broke the cardinal rule of only changing one variable at a time. I'm in for now anyway.

    Last edited by Matthren; Feb 18 2013 at 06:09 PM.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

This form's session has expired. You need to reload the page.