We have detected that cookies are not enabled on your browser. Please enable cookies to ensure the proper experience.
Results 1 to 4 of 4
  1. #1
    Join Date
    Nov 2012

    badimageformatexception: ? error PLEASE HELP

    I've recently installed LOTRO because I really want to play it again,and I'm installing it on a different computer,an older computer. Everytime I start it i get the same error message:

    System.BadImageFormatException : ?
    at System.Reflection.Assembly.nLo adImage(Byte[] rawAssembly, Byte[] rawSymbolStore, Evidence evidence, StackCrawlMark& stackMark)
    at System.Reflection.Assembly.Loa d(Byte[] rawAssembly, Byte[] rawSymbolStore, Evidence securityEvidence)
    at System.CodeDom.Compiler.CodeCo mpiler.FromFileBatch(CompilerP arameters options, String[] fileNames)
    at System.CodeDom.Compiler.CodeCo mpiler.FromSourceBatch(Compile rParameters options, String[] sources)
    at System.CodeDom.Compiler.CodeCo mpiler.FromSource(CompilerPara meters options, String source)
    at System.CodeDom.Compiler.CodeCo mpiler.System.CodeDom.Compiler .ICodeCompiler.CompileAssembly FromSource(CompilerParameters options, String source)
    at System.Xml.Serialization.Compi ler.Compile()
    at System.Xml.Serialization.TempA ssembly..ctor(XmlMapping[] xmlMappings)
    at System.Xml.Serialization.XmlSe rializer.FromMappings(XmlMappi ng[] mappings)
    at System.Web.Services.Protocols. SoapClientType..ctor(Type type)
    at System.Web.Services.Protocols. SoapHttpClientProtocol..ctor()
    at com.turbine.launcher.DataCente rService.GLSDatacenterInfoServ er..ctor()
    at com.turbine.launcher.Services. DataCenterBrowser..ctor()

    I've researched online and installed .net framework 1.1 and the sp1 hotfix(which wont show up anywhere),still didnt work. I tried this a couple times and i got nothing. I used the .net framework tool thing to clean it all out and reinstall the framework,rebooted computer multiple times,just reinstalled the entire game which has taken hours,and i still get the same error message. I've been trying to fix this for almost 2 days now,and its really irritating. I have windows XP on an older computer,and I can run WoW decently,so I should be able to play LOTRO. Please respond and guide me through this because im dying to play and I'd rather not wait until i can get a new PC(if that will even help.) 1 Internet goes to whoever can solve this problem without having to wipe my entire computer. <3
    Last edited by kittynips; Dec 03 2012 at 05:23 PM.

  2. #2
    Join Date
    Nov 2012
    Can someone please help,if i download it through steam will it work?

  3. #3
    Join Date
    Jun 2011
    London, England
    You might be better off asking about this in the Technical Support forum.

    It's a .NET error for certain. But since you've already got 1.1 installed and patched, I'm at a loss to suggest anything else.
    Leader of The Rangers of Eriador

  4. #4
    Join Date
    Nov 2012
    Yeah,I was looking through the threads and it finally dawned on me,so I posted it there,hopefully I wont get penalized for double posting,I dont know what I was thinking. Thanks for your response,I am also at a loss :/ I'm close to just wiping my computer or giving up til i get a new one,but it would be nice to hear from tech support to see if they can help,I've been trying like crazy to get it to work and I dont know if its worth it anymore haha. I am dying to play again



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

This form's session has expired. You need to reload the page.