We have detected that cookies are not enabled on your browser. Please enable cookies to ensure the proper experience.
Results 1 to 11 of 11
  1. #1
    Join Date
    Dec 2007
    Posts
    2

    Mac Update Error

    I am using a MacBook, I have never played LotRO before, but I downloaded the 17.74 GB file from the website and opened it, and was able to log in, but it says "An update error occurred" and under task it says "Retry", and it continually tries to reconnect. How do I get past this? I have tried rebooting, restarting the launcher, and changing the language of the launcher, and nothing has worked.

  2. #2
    Join Date
    Nov 2012
    Posts
    1
    Exactly the same problem for me mate, Does anyone have an answer? Really looking forward to the game having played wow for 6 years this seems a legit game and i was looking forward to playing it now the mac client was out.

  3. #3
    Join Date
    Sep 2012
    Location
    France
    Posts
    684
    Quote Originally Posted by jdbellis View Post
    I am using a MacBook, I have never played LotRO before, but I downloaded the 17.74 GB file from the website and opened it, and was able to log in, but it says "An update error occurred" and under task it says "Retry", and it continually tries to reconnect. How do I get past this? I have tried rebooting, restarting the launcher, and changing the language of the launcher, and nothing has worked.
    Hi and welcome to Mac LOTRO!

    Not sure if you can see the Mac Technical Support section as F2P. If you can then check this thread and that section for any Mac related issues;

    [SOLUTION] Stuck at 'An update error occured' 50...retry loop, on Launcher

    If not, here is a solution I posted yesterday for this. The workaround is simple to do.

    Issue: During the launch process of the Mac client LotroLauncher.app (in the Finder named The Lord of the Rings Online™), after connecting to the patch server and Check product stage; instead of progressing to the Login/Password stage the launcher shows the error message;

    An update error occured
    [sic]

    And just repeats a Retry every 60 seconds will no progress. Relaunching will only repeat the loop.

    Workaround: Rename the application from The Lord of the Rings Online™ to The Lord of the Rings Online by removing the '™'. Relaunch the application and it should now progress to Login/Password and allow you to enter the game.

    Image: This is the error message on the launcher window;



    Note: This workaround has been confirm to work on this and similar issues during patching and checking before the login/pass stage. There are other options to resolve this issue which are;

    Optional Workarounds

    Launch the LotroLauncher.app directly

    1. Navigate to /Applications > The Lord of the Rings Online™ then right click the app and select Show Package Contents.

    2. Navigate to Contents >MacOS >LotroLauncher (LotroLauncher.app if extensions are shown) and double click to launch directly. This will automatically open Terminal and run the launch sequence. This should result in you reaching the Login/Password stage ready to enter the game.

    You do not have to alter the app name to do this (although that is the neater solution). It is also possible to drag this to the Dock (right or lower part) to make a shortcut.

    Reinstall the Application

    Initially I resolved this after a lot of checks by removing the following (I moved them to a new folder on the desktop);

    /Applications/The Lord of the Rings Online™.app
    (normally this is /Applications/LotroLauncher.app but shows as this with a problem install)

    and all the supporting/related files;

    ~/Library/Application Support/com.turbine.lotroclient
    ~/Library/Caches/com.turbine.lotroclient
    ~/Library/Preferences/com.turbine.lotroclient.plist
    ~/Library/Preferences/com.turbine.LotroLauncher.plis t
    ~/Library/Saved Application State/com.turbine.lotroclient.savedS tate
    ~/Library/Saved Application State/com.turbine.LotroLauncher.save dState
    Then mounting the LotroLauncher.dmg disk image again; Letting the Verify complete (takes a while but important) and copy to Applications by dragging it to the folder on the disk image window (takes a while as a large file).

    Launch the fresh install and let it patch. This time it worked without the error. Just make sure that all the files noted are removed.

    Hope this works for you. If you need any more help post to the Mac forum or here if not able to.
    [I]Gaspard Strongpole[/I] - Hunter on [B]Eldar[/B] : [COLOR="#FF0000"]Mac Player[/COLOR] - iMac/27-inch, Late 2013/ 3.4 GHz Intel Core i5/ 8 GB 1600 MHz DDR3/ NVIDIA GeForce GTX 780M 4096 MB/OS X 10.10.5

  4. #4
    Join Date
    Dec 2007
    Posts
    2

    Talking

    Quote Originally Posted by Toddlepip View Post
    Hi and welcome to Mac LOTRO!

    Hope this works for you. If you need any more help post to the Mac forum or here if not able to.
    Thank you SOO much!!! The renaming solution solved my problem perfectly!!! Thank you so much!
    - Josh

  5. #5
    Join Date
    Sep 2012
    Location
    France
    Posts
    684
    Quote Originally Posted by jdbellis View Post
    Thank you SOO much!!! The renaming solution solved my problem perfectly!!! Thank you so much!
    - Josh
    Glad it worked for you. Happy Mac LOTRO
    [I]Gaspard Strongpole[/I] - Hunter on [B]Eldar[/B] : [COLOR="#FF0000"]Mac Player[/COLOR] - iMac/27-inch, Late 2013/ 3.4 GHz Intel Core i5/ 8 GB 1600 MHz DDR3/ NVIDIA GeForce GTX 780M 4096 MB/OS X 10.10.5

  6. #6
    Join Date
    Jan 2014
    Posts
    1

    Angry Still not working

    Hey. I tried EVERYTHING but it still don't worked
    Help me please D:

  7. #7
    Hey, maybe someone can help me here, too.

    I downloaded the low res client completely and as I wanted to start playing, the updater opened downloading 26 Files.
    So far so good, but every time it gets to about the middle of the process, the App fails and closes again. I downloaded the complete
    file again and tried the process several times - it keeps crashing.

    Another weird detail is, that when I open the launcher, it will sometimes download the mentioned 26 Files, another time it showed 74 Files,
    I've even seen the number 54 and 58. Anyone might have an idea?

    I'm playing (or trying to) on a MacBook Air 13" mid 2013, 1,3 GHz Intel Core i5, 4 GB 1600MHz DDR3, Intel HD Graphics 5000, OSX 10.9.4!

    Any suggestion is greatly appreciated. Thank you

  8. #8
    Join Date
    Dec 2014
    Location
    Coeur d'Alene, ID
    Posts
    2

    Thumbs up Thank you, that was most informative

    Initially this workaround did not work and my lotrolauncher kept crashing from the update loop, but renaming the app in the package contents did the trick. This will be my first time playing. Thanks very much for the straightforward and helpful instructions.

  9. #9
    If you are getting Mac update error then make sure you have enough disk space or not. At least 3 GB space required for update Mac operating system. If the required space is available and you are then you are getting Mac update error then it may be due to missing Mac system files, so use Mac data recovery tool to recover Mac data and complete the update process.

  10. #10
    Join Date
    Jul 2015
    Posts
    15
    I'm having the same issue. I don't have a "LOTRO Launcher" in my applications folder but
    I do have "LOTRO Installer."

    But no file name (in the package or elsewhere) with "TM"

    What am I missing?

  11. #11
    Join Date
    Jul 2015
    Posts
    15
    Here is a snapshot of my system:

    EtreCheck version: 2.2 (132)
    Report generated 7/7/15 1:13 PM
    Download EtreCheck from http://etresoft.com/etrecheck

    Click the [Click for support] links for help with non-Apple products.
    Click the [Click for details] links for more information about that line.

    Hardware Information: ??
    MacBook (13-inch, Mid 2010) (Technical Specifications)
    MacBook - model: MacBook7,1
    1 2.4 GHz Intel Core 2 Duo CPU: 2-core
    4 GB RAM
    BANK 0/DIMM0
    2 GB DDR3 1067 MHz ok
    BANK 1/DIMM0
    2 GB DDR3 1067 MHz ok
    Bluetooth: Old - Handoff/Airdrop2 not supported
    Wireless: en1: 802.11 a/b/g/n
    Battery: Health = Normal - Cycle count = 183 - SN = 9G1240QLEE1MA

    Video Information: ??
    NVIDIA GeForce 320M - VRAM: 256 MB
    Color LCD 1280 x 800

    System Software: ??
    OS X 10.8.5 (12F45) - Time since boot: 22:25:23

    Disk Information: ??
    Hitachi HTS545050B9SA02 disk0 : (500.11 GB)
    disk0s1 (disk0s1) <not mounted> : 210 MB
    Macintosh HD (disk0s2) / : 485.00 GB (75.68 GB free)
    Recovery HD (disk0s3) <not mounted> [Recovery]: 650 MB
    eDrive (disk0s4) /Volumes/eDrive : 14.11 GB (8.13 GB free)

    HL-DT-ST DVDRW GS23N

    USB Information: ??
    Apple Inc. Built-in iSight
    Apple Inc. BRCM2070 Hub
    Apple Inc. Bluetooth USB Host Controller
    Apple Inc. Apple Internal Keyboard / Trackpad

    Gatekeeper: ??
    Anywhere

    Kernel Extensions: ??
    /Library/Application Support/Roxio
    [not loaded] com.roxio.TDIXController (2.0) [Click for support]

    /Library/Application Support/Symantec/Protector
    [not loaded] com.symantec.kext.protector.pa nther (1.0f5) [Click for support]
    [not loaded] com.symantec.kext.protector.ti gerplus (1.0f5) [Click for support]

    /Library/StartupItems/SymAutoProtect
    [not loaded] com.Symantec.kext.SAVAPComm (11.0.6) [Click for support]

    /System/Library/Extensions
    [loaded] com.epson.driver.EPSONProjecto rUDAudio (1.30 - SDK 10.4) [Click for support]
    [not loaded] com.roxio.BluRaySupport (1.1.6) [Click for support]
    [not loaded] com.seagate.driver.PowSecDrive rCore (5.2.6 - SDK 10.4) [Click for support]
    [not loaded] com.smarttech.iokit.SMARTBoard (11) [Click for support]
    [not loaded] com.tectona.driver.PL2303 (1.3.0) [Click for support]

    /System/Library/Extensions/Seagate Storage Driver.kext/Contents/PlugIns
    [not loaded] com.seagate.driver.PowSecLeafD river_10_4 (5.2.6 - SDK 10.4) [Click for support]
    [not loaded] com.seagate.driver.PowSecLeafD river_10_5 (5.2.6 - SDK 10.5) [Click for support]
    [not loaded] com.seagate.driver.SeagateDriv eIcons (5.2.6 - SDK 10.4) [Click for support]

    Startup Items: ??
    NortonMissedTasks: Path: /Library/StartupItems/NortonMissedTasks
    SMC: Path: /Library/StartupItems/SMC
    SymAutoProtect: Path: /Library/StartupItems/SymAutoProtect
    SymProtector: Path: /Library/StartupItems/SymProtector
    Startup items are obsolete in OS X Yosemite

    Problem System Launch Agents: ??
    [failed] com.apple.accountsd.plist [Click for details]

    Problem System Launch Daemons: ??
    [failed] com.apple.wdhelper.plist [Click for details]
    [running] com.seagate.TBDecorator.plist [Click for support]

    Launch Agents: ??
    [not loaded] com.adobe.AAM.Updater-1.0.plist [Click for support]
    [loaded] com.google.keystone.agent.plis t [Click for support]
    [loaded] com.oracle.java.Java-Updater.plist [Click for support]
    [running] com.smarttech.boardservice.pli st [Click for support]
    [running] com.smarttech.SBWDKService.pli st [Click for support]
    [running] com.symantec.quickmenu.applica tion.plist [Click for support]
    [not loaded] com.teamviewer.teamviewer.plis t [Click for support]
    [not loaded] com.teamviewer.teamviewer_desk top.plist [Click for support]

    Launch Daemons: ??
    [loaded] com.adobe.fpsaud.plist [Click for support]
    [loaded] com.adobe.SwitchBoard.plist [Click for support]
    [running] com.crashplan.engine.plist [Click for support]
    [loaded] com.google.keystone.daemon.pli st [Click for support]
    [loaded] com.microsoft.office.licensing .helper.plist [Click for support]
    [loaded] com.oracle.java.Helper-Tool.plist [Click for support]
    [loaded] com.teamviewer.Helper.plist [Click for support]
    [not loaded] com.teamviewer.teamviewer_serv ice.plist [Click for support]
    [loaded] com.tunnelbear.mac.tbeard.plis t [Click for support]

    User Launch Agents: ??
    [loaded] com.adobe.ARM.[...].plist [Click for support]
    [loaded] com.adobe.ARM.[...].plist [Click for support]
    [running] com.akamai.single-user-client.plist [Click for support]
    [failed] com.facebook.videochat.[redacted].plist [Click for support] [Click for details]

    User Login Items: ??
    iTunesHelper UNKNOWN Hidden (missing value)
    KeyRemap4MacBook_launchd UNKNOWN Hidden (missing value)
    USB Display Agent Application (/Applications/USB Display/USB Display.app/Contents/Resources/USB Display Agent.app)
    CrashPlan menu bar UNKNOWN (missing value)
    Thyme Application (/Applications/Thyme.app)
    CrashPlan menu bar Application (/Applications/CrashPlan.app/Contents/Helpers/CrashPlan menu bar.app)
    Android File Transfer Agent Application (/Users/[redacted]/Library/Application Support/Google/Android File Transfer/Android File Transfer Agent.app)
    Dropbox Application (/Applications/Dropbox.app)
    USB Display Agent Application (/Applications/USB Display/USB Display.app/Contents/Resources/USB Display Agent.app)

    Internet Plug-ins: ??
    DirectorShockwave: Version: 12.0.2r122 - SDK 10.6 [Click for support]
    Unity Web Player: Version: UnityPlayer version 4.1.5f1 [Click for support]
    AdobeExManDetect: Version: AdobeExManDetect 1.0.0.0 - SDK 10.7 [Click for support]
    Flip4Mac WMV Plugin: Version: 3.3.1.3 - SDK 10.8 [Click for support]
    AdobePDFViewerNPAPI: Version: 11.0.11 - SDK 10.6 [Click for support]
    FlashPlayer-10.6: Version: 18.0.0.194 - SDK 10.6 [Click for support]
    Silverlight: Version: 5.1.20125.0 - SDK 10.6 [Click for support]
    Flash Player: Version: 18.0.0.194 - SDK 10.6 [Click for support]
    QuickTime Plugin: Version: 7.7.1
    iPhotoPhotocast: Version: 7.0 - SDK 10.8
    SharePointBrowserPlugin: Version: 14.3.5 - SDK 10.6 [Click for support]
    AdobePDFViewer: Version: 11.0.11 - SDK 10.6 [Click for support]
    JavaAppletPlugin: Version: Java 7 Update 25 Check version

    User internet Plug-ins: ??
    Aspera Web 3.5.2.95060: Version: Unknown - SDK 10.9 [Click for support]

    3rd Party Preference Panes: ??
    Akamai NetSession Preferences [Click for support]
    Flash Player [Click for support]
    Flip4Mac WMV [Click for support]
    Java [Click for support]
    Paragon NTFS for Mac ® OS X [Click for support]
    Perian [Click for support]
    Seagate Dashboard for Mac OSX [Click for support]
    SMART Board [Click for support]
    SymAutoProtect
    Symantec\nQuickMenu [Click for support]
    YAMAHA-USBMIDIPatch [Click for support]

    Time Machine: ??
    Skip System Files: NO
    Mobile backups: OFF
    Auto backup: NO - Auto backup turned off
    Volumes being backed up:
    Macintosh HD: Disk size: 485.00 GB Disk used: 409.32 GB
    Destinations:
    My Passport for Mac [Local]
    Total size: 600.00 GB
    Total number of backups: 3
    Oldest backup: 2014-07-17 23:03:02 +0000
    Last backup: 2014-07-28 21:26:34 +0000
    Size of backup disk: Too small
    Backup size 600.00 GB < (Disk used 409.32 GB X 3)

    Top Processes by CPU: ??
    22% mds
    2% WindowServer
    0% The Happy Cloud
    0% apsd
    0% hidd

    Top Processes by Memory: ??
    119 MB The Happy Cloud
    106 MB CrashPlanService
    74 MB Dropbox
    70 MB Finder
    45 MB Dock

    Virtual Memory Information: ??
    1.40 GB Free RAM
    2.60 GB Used RAM
    72 MB Swap Used

    Diagnostics Information: ??
    Jul 6, 2015, 02:47:17 PM Self test - passed

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

This form's session has expired. You need to reload the page.

Reload