We have detected that cookies are not enabled on your browser. Please enable cookies to ensure the proper experience.
Page 3 of 3 FirstFirst 1 2 3
Results 51 to 74 of 74
  1. #51
    Quote Originally Posted by FabiHobs View Post
    It even got worse after downloading and installing the game aka fresh start. The bug happens and then it even got that stupid bugged it even can't launch the launcher anymore. Great just great!
    /Applications/The\ Lord\ of\ the\ Rings\ Online.app/Contents/MacOS/LotroLauncher ; exit;
    Cannot mix incompatible Qt library (version 0x40802) with this library (version 0x40804)
    Abort trap: 6

    [Proces voltooid]

  2. #52

    Thumbs up Thanks!

    I'm a newbie to the game but have used Macs since 1984. Your thorough explanations will come in handy as I progress in the game. I'm not a programmer but have system level experience and will use your approach when I try to debug issues. I will contribute to this thread as I'm able. Still in Bree-Land intro so have not encountered any issues.
    Running on MacBook Pro 17", OSX 10.8.3, 2.66 GHz i7, 8 GB RAM, NVIDIA GeForce GT 330M

  3. #53
    Join Date
    Mar 2013
    I don't know why this worked for me but it did.

    I installed the game to my desktop instead of the applications folder and it ran like a charm. It takes a long time to download all the updates the first time but now when I log on, I'm playing in a matter of minutes.

    Hope this helps at least one person.

  4. #54
    Join Date
    Mar 2013

    Possible quick solution?

    I don't know why this worked but it did.

    I installed the game on my desktop instead of the applications folder. Worked like a charm.

    Hope this helps at least one person.

  5. #55
    Join Date
    Mar 2013

    possible solution

    I tried posting this once already, for some reason Turbine didn't allow it to post.

    This could be a freak incident but for whatever reason this worked for me. Instead of installing the game client into my applications folder, I installed it on the desktop. I've been playing for less than a week. I haven't had any problems getting the game to launch.

    I'm loving the game and currently have an Elf hunter at level 11.

    I'm going to try to download the DDO mac client now as well.

  6. #56
    I had been playing the Steam download of LOTRO for over a week with no issues, and then had the patch server cycle of doom today. I was aware of this Avast AV issue before - it prevented me from patching initially after I first installed. Adding patch.lotro.com to the exclusions seemed to help with that.

    As none of the .app filename changes above seemed to fix the problem, I disabled Avast's WebShield, and now the launcher is working fine, and downloading tons of files. That's kinda annoying, probably due to the file name changes. Hope this works.

    So if you use Avast anti-virus, try just disabling the WebShield. Adding the exclusion may not be enough!

    Quote Originally Posted by Valamar View Post
    This is a duplicate of the posting in the thread:
    "avast! virus protection prevents Mac Client startup - An Update Error Occurred"

    This may be a more common fix (post Update 10) than the previous solutions.

  7. #57
    Join Date
    May 2011

    steam exact same problem

    Downloaded it from steam and the same thing is happening. Deleted the (tm)s of both the lotro thingys and its still not working

  8. #58
    Join Date
    Jun 2011
    Still saying " An update error occured "...

    Sometimes it works to update sometimes not.
    I update at my Macbook no problem, then i tryed to iMac and it says allways update error occured... blaaah...

    Any help? Same problem when the new update came.

  9. #59
    Join Date
    Jun 2013

    I'm so confused!!!

    I have read these over and over again, and from what i read all i have to do is change one or two file names, so i did what i read and changed the file name to The Lord Of The Rings Online but that didnt help. I then selected show package contents and removed the "tm" from that file... It's still not working! could somebody possibly make a youtube video or some video to work off of? I am completely lost! haha, if so, thank you very much.

  10. #60
    Join Date
    Sep 2011

    anti-virus blocking

    just a little bit i found with the 'update error occurred' issue. try temporarily turning off your anti virus software and the running the lotro launcher.
    it worked for me.

  11. #61
    Quote Originally Posted by Toddlepip View Post
    Workaround: Rename the application from The Lord of the Rings Online™ to The Lord of the Rings Online by removing the '™'. Relaunch the application and it should now progress to Login/Password and allow you to enter the game.
    Have the same error here:

    Lotrolauncher.dmg is on desktop and when i run it i get ''The Lord of the Rings Online TM'' application.

    I m not able to rename application to ''The Lord of the Rings Online'' because it's locked.. any help with this?

    I ve tried the other way with LotroLauncher file but unfortunatelly didn't work..

  12. #62
    It is hard not to agree that this should have been solved by the development team long ago if it was known in the run.

    Downloading on 22 December and it is still an issue!

    As a new Mac user, it was painful to figure it out. But the guidance on accessing the *system* applications folder and the clicking to see the components of the LOTRO *package* seemed to work. The game is now past the initial hang in the launcher and is downloading update files.

    What game developer puts superscripts in its file names? Come on guys, you are better than that! Get on the stick here and address this problem.

  13. #63
    Hi All,

    I'm running mavericks with osx journaled case sensitive disk partition... and
    I'm still discovering the patchclient update issue.

    However the log is straightforward:

    PatchFlow::OnDataCenterUpdated - LoadDLL error - strError: "Failed to load patchclient [Cannot load library /Applications/LotroLauncher.app/Contents/MacOS/patchclient: (dlopen(/Applications/LotroLauncher.app/Contents/MacOS/libpatchclient.dylib, 5): image not found)]"
    It cannot find the file "libpatchlient.dylib" and "ttepatchclient.dylib". Looking inside that folder we have them but with a different case: PatchClient.dylib, TTEPatchClient.dylib.
    I just copied them renaming with lowercase names and it works.

  14. #64

    Wrong File Permission

    Hi there,
    I would like to share my own solution.
    I was stuck at the updater launch with "an unknown error" with an unreadable HEX code !
    I realized that I backup / format / restore / my HD a few days ago. And I messed up my LOTRO file permission.

    NOTE : I am not a Unix Pro. What I did work fine for me because it was THE problem.
    You should consider to search other groups about this to be sure about what you are going to do.

    1 - Open Terminal
    2 - type "chmod -R a+rwx " without the double quote and with a space at the end.
    3 - pick up the Lotro App icon and drag&drop it on the terminal window. You should read "chmod -R a+rwx /Application/lord\ of\ the\ ring\ online.app
    4 - hit Return

    If you read a lot of error message try "sudo chmod -R a+rwx ".
    sudo require your admin password.
    Last edited by Arkanasterith; Mar 11 2014 at 06:25 AM.

  15. #65


    This is happening also under windows all of a sudden. I don't get to play often, but the last 6 times I have tried to play, LOTRO has either broken or I have had to spend my one day of play time updating. This is very disappointing.

    Do we have a solution to the update error bug yet or not?

  16. #66

    possible solution

    My solution was to rename "TTEPatchClient.dylib" to "ttepatchclient.dylib" and "PatchClient.dylib" to "patchclient.dylib"
    --> both filenames in lower case!

  17. #67
    *Sigh* I've tried everything my tech skills allow me: Changed the folder name (- tm), copied the file and changed the name, tried to open the Laucher straight from the MacOS folder and now changed the file names to lower case. Still the same thing happens "An update error occurred".

    I usually play with PC but I'm now stuck for about two weeks with my old MacBook Pro (mid 2010) and wanted to start playing Lotro again.

    Any new tips I could try?

  18. #68
    Quote Originally Posted by Naksu_ View Post
    with my old MacBook Pro (mid 2010)
    Did you make any Time Machine Restoration ? Try my solution...

    Quote Originally Posted by Naksu_ View Post
    Any new tips I could try?
    Maybe you can try to copy the UPDATED game data from your PC clent to Mac.
    1 - make a COPY of your Mac client
    2 - right clic Lotro icon> Open package content > Content > Ressource
    3 - Copy the matching folder

  19. #69
    Join Date
    Feb 2007
    Philadelphia, PA
    Quote Originally Posted by Naksu_ View Post
    *Sigh* I've tried everything my tech skills allow me: Changed the folder name (- tm), copied the file and changed the name, tried to open the Laucher straight from the MacOS folder and now changed the file names to lower case. Still the same thing happens "An update error occurred".

    I usually play with PC but I'm now stuck for about two weeks with my old MacBook Pro (mid 2010) and wanted to start playing Lotro again.

    Any new tips I could try?
    Please don't resurrect ancient threads.

    I would recommend that your run "Applications/Utilities/Disk Utility" and "Repair Disk Permissions."
    Check the log file to see if you can tell which file is failing -- delete (move out of the folder) that file and try again.
    The Launcher will re-download any missing files.

    1- ~/Library/logs/LotroLauncher.log -- probably won't show anything useful, but it might.

    2- ~/library/logs/com.turbine.lotroclient/PatchClient.log - might show which file the update is failing on.

    3- Power cycle your system (shutdown, no reboot).
    While it is shutdown -- as appropriate for your setup -- powercycle your Router/Modem/WiFi... power them all off wait 2 minutes.
    Power up the Modem -- wait until it reboots
    Power up the Router -- wait until it reboots
    Power up your WiFI access point -- wait until it reboots
    Power up your laptop
    Re-launch and try again.
    Bill Magill - Mac Player - Old Timers Guild- Gladden:

    Partial cast
    Valamar: Dwarf Hunter - Level 100
    Valdicta: Dwarf Rune-keeper - Level 100
    Valanne: Beorning - Level 80

  20. #70

    Lightbulb UPDATED SOLUTION (for Steam people) (hopefully works)

    Yo everyone,

    Just an update for those who are struggling with the fix to this (and maybe Toodletip can update the solution list) – since Steam seems to have changed its file structure, the app you need to rename is now located in /Users/(username)/Library/Application Support/Steam/steamapps/common/Lord of the Rings Online/ – you have to unhide hidden files/folders to see the /Library folder.

    Again, you also have to Show Package Contents, go Contents > Resources and remove the ™ from the launcher app name, too.

    Good luck!

    EDIT: It seems that the above method messes up the patching process because the updater is looking for an .app with ™ in it – stupidly, it won't tell you that, instead it's going to write all the patch data to another internal .app file with the ™. But that's a problem, because then you end up with two .app files, one with the base game (about 25GB) and one with just the patch data (about 3GB, that's gonna vary) – which obviously doesn't work, as the patch data seem to be simply appended to the .dat files, so you end up with incomplete ones, and won't be able to launch the game. As far as I can tell you then need to add the ™s back to everything, delete the incomplete .app, start the launcher (this time it should connect properly even with the ™s), let it patch up AGAIN, and that should work.

    Check if it's working by looking at the place where you had the duplicate .app files and making sure it didn't make another one while updating.

    I came back to LOTRO for pure nostalgia after 3 years (played since the ol' beta in 2007) and I'm happy they've now got a Mac version, but I'm terrified at how they just don't really care about its users. COME ON TURBINE!!!
    Last edited by venethios; May 02 2015 at 05:38 AM.

  21. #71
    Join Date
    Jul 2015
    Hi --#

    I'm installing LOTRO on my MacBook. #Using the Happy Cloud installer.

    All 20 GB have downloaded. #When I double click the LOTRO Installer,
    it brings up the 1st screen (with the Game Ready button), and then automatically
    the 2nd screen (with the Community Acct Support buttons along the top).

    A bunch of really quick downloads go fine (Screenshots #1-9 and others), and then
    it says,

    "update error occurred: request could not be sent."

    Then a 60 second retry countdown.

    Then the same error again in an endless loop.

    One of the many help documents I've looked at suggested running EtreCheck -- results below.

    Any ideas? #Please help. #(Some think its a connectivity error but I don't see how it could be --
    I've downloaded 20GB successfully and so much has gone thru -- I don't know why its
    hanging 90% of the way in....)


    EtreCheck version: 2.2 (132)
    Report generated 7/7/15 1:13 PM
    Download EtreCheck from http://etresoft.com/etrecheck

    Click the [Click for support] links for help with non-Apple products.
    Click the [Click for details] links for more information about that line.

    Hardware Information: ??
    MacBook (13-inch, Mid 2010) (Technical Specifications)
    MacBook - model: MacBook7,1
    1 2.4 GHz Intel Core 2 Duo CPU: 2-core
    4 GB RAM
    BANK 0/DIMM0
    2 GB DDR3 1067 MHz ok
    BANK 1/DIMM0
    2 GB DDR3 1067 MHz ok
    Bluetooth: Old - Handoff/Airdrop2 not supported
    Wireless: en1: 802.11 a/b/g/n
    Battery: Health = Normal - Cycle count = 183 - SN = 9G1240QLEE1MA

    Video Information: ??
    NVIDIA GeForce 320M - VRAM: 256 MB
    Color LCD 1280 x 800

    System Software: ??
    OS X 10.8.5 (12F45) - Time since boot: 22:25:23

    Disk Information: ??
    Hitachi HTS545050B9SA02 disk0 : (500.11 GB)
    disk0s1 (disk0s1) <not mounted> : 210 MB
    Macintosh HD (disk0s2) / : 485.00 GB (75.68 GB free)
    Recovery HD (disk0s3) <not mounted> [Recovery]: 650 MB
    eDrive (disk0s4) /Volumes/eDrive : 14.11 GB (8.13 GB free)


    USB Information: ??
    Apple Inc. Built-in iSight
    Apple Inc. BRCM2070 Hub
    Apple Inc. Bluetooth USB Host Controller
    Apple Inc. Apple Internal Keyboard / Trackpad

    Gatekeeper: ??

    Kernel Extensions: ??
    /Library/Application Support/Roxio
    [not loaded] com.roxio.TDIXController (2.0) [Click for support]

    /Library/Application Support/Symantec/Protector
    [not loaded] com.symantec.kext.protector.pa nther (1.0f5) [Click for support]
    [not loaded] com.symantec.kext.protector.ti gerplus (1.0f5) [Click for support]

    [not loaded] com.Symantec.kext.SAVAPComm (11.0.6) [Click for support]

    [loaded] com.epson.driver.EPSONProjecto rUDAudio (1.30 - SDK 10.4) [Click for support]
    [not loaded] com.roxio.BluRaySupport (1.1.6) [Click for support]
    [not loaded] com.seagate.driver.PowSecDrive rCore (5.2.6 - SDK 10.4) [Click for support]
    [not loaded] com.smarttech.iokit.SMARTBoard (11) [Click for support]
    [not loaded] com.tectona.driver.PL2303 (1.3.0) [Click for support]

    /System/Library/Extensions/Seagate Storage Driver.kext/Contents/PlugIns
    [not loaded] com.seagate.driver.PowSecLeafD river_10_4 (5.2.6 - SDK 10.4) [Click for support]
    [not loaded] com.seagate.driver.PowSecLeafD river_10_5 (5.2.6 - SDK 10.5) [Click for support]
    [not loaded] com.seagate.driver.SeagateDriv eIcons (5.2.6 - SDK 10.4) [Click for support]

    Startup Items: ??
    NortonMissedTasks: Path: /Library/StartupItems/NortonMissedTasks
    SMC: Path: /Library/StartupItems/SMC
    SymAutoProtect: Path: /Library/StartupItems/SymAutoProtect
    SymProtector: Path: /Library/StartupItems/SymProtector
    Startup items are obsolete in OS X Yosemite

    Problem System Launch Agents: ??
    [failed] com.apple.accountsd.plist [Click for details]

    Problem System Launch Daemons: ??
    [failed] com.apple.wdhelper.plist [Click for details]
    [running] com.seagate.TBDecorator.plist [Click for support]

    Launch Agents: ??
    [not loaded] com.adobe.AAM.Updater-1.0.plist [Click for support]
    [loaded] com.google.keystone.agent.plis t [Click for support]
    [loaded] com.oracle.java.Java-Updater.plist [Click for support]
    [running] com.smarttech.boardservice.pli st [Click for support]
    [running] com.smarttech.SBWDKService.pli st [Click for support]
    [running] com.symantec.quickmenu.applica tion.plist [Click for support]
    [not loaded] com.teamviewer.teamviewer.plis t [Click for support]
    [not loaded] com.teamviewer.teamviewer_desk top.plist [Click for support]

    Launch Daemons: ??
    [loaded] com.adobe.fpsaud.plist [Click for support]
    [loaded] com.adobe.SwitchBoard.plist [Click for support]
    [running] com.crashplan.engine.plist [Click for support]
    [loaded] com.google.keystone.daemon.pli st [Click for support]
    [loaded] com.microsoft.office.licensing .helper.plist [Click for support]
    [loaded] com.oracle.java.Helper-Tool.plist [Click for support]
    [loaded] com.teamviewer.Helper.plist [Click for support]
    [not loaded] com.teamviewer.teamviewer_serv ice.plist [Click for support]
    [loaded] com.tunnelbear.mac.tbeard.plis t [Click for support]

    User Launch Agents: ??
    [loaded] com.adobe.ARM.[...].plist [Click for support]
    [loaded] com.adobe.ARM.[...].plist [Click for support]
    [running] com.akamai.single-user-client.plist [Click for support]
    [failed] com.facebook.videochat.[redacted].plist [Click for support] [Click for details]

    User Login Items: ??
    iTunesHelper UNKNOWN Hidden (missing value)
    KeyRemap4MacBook_launchd UNKNOWN Hidden (missing value)
    USB Display Agent Application (/Applications/USB Display/USB Display.app/Contents/Resources/USB Display Agent.app)
    CrashPlan menu bar UNKNOWN (missing value)
    Thyme Application (/Applications/Thyme.app)
    CrashPlan menu bar Application (/Applications/CrashPlan.app/Contents/Helpers/CrashPlan menu bar.app)
    Android File Transfer Agent Application (/Users/[redacted]/Library/Application Support/Google/Android File Transfer/Android File Transfer Agent.app)
    Dropbox Application (/Applications/Dropbox.app)
    USB Display Agent Application (/Applications/USB Display/USB Display.app/Contents/Resources/USB Display Agent.app)

    Internet Plug-ins: ??
    DirectorShockwave: Version: 12.0.2r122 - SDK 10.6 [Click for support]
    Unity Web Player: Version: UnityPlayer version 4.1.5f1 [Click for support]
    AdobeExManDetect: Version: AdobeExManDetect - SDK 10.7 [Click for support]
    Flip4Mac WMV Plugin: Version: - SDK 10.8 [Click for support]
    AdobePDFViewerNPAPI: Version: 11.0.11 - SDK 10.6 [Click for support]
    FlashPlayer-10.6: Version: - SDK 10.6 [Click for support]
    Silverlight: Version: 5.1.20125.0 - SDK 10.6 [Click for support]
    Flash Player: Version: - SDK 10.6 [Click for support]
    QuickTime Plugin: Version: 7.7.1
    iPhotoPhotocast: Version: 7.0 - SDK 10.8
    SharePointBrowserPlugin: Version: 14.3.5 - SDK 10.6 [Click for support]
    AdobePDFViewer: Version: 11.0.11 - SDK 10.6 [Click for support]
    JavaAppletPlugin: Version: Java 7 Update 25 Check version

    User internet Plug-ins: ??
    Aspera Web Version: Unknown - SDK 10.9 [Click for support]

    3rd Party Preference Panes: ??
    Akamai NetSession Preferences [Click for support]
    Flash Player [Click for support]
    Flip4Mac WMV [Click for support]
    Java [Click for support]
    Paragon NTFS for Mac ® OS X [Click for support]
    Perian [Click for support]
    Seagate Dashboard for Mac OSX [Click for support]
    SMART Board [Click for support]
    Symantec\nQuickMenu [Click for support]
    YAMAHA-USBMIDIPatch [Click for support]

    Time Machine: ??
    Skip System Files: NO
    Mobile backups: OFF
    Auto backup: NO - Auto backup turned off
    Volumes being backed up:
    Macintosh HD: Disk size: 485.00 GB Disk used: 409.32 GB
    My Passport for Mac [Local]
    Total size: 600.00 GB
    Total number of backups: 3
    Oldest backup: 2014-07-17 23:03:02 +0000
    Last backup: 2014-07-28 21:26:34 +0000
    Size of backup disk: Too small
    Backup size 600.00 GB < (Disk used 409.32 GB X 3)

    Top Processes by CPU: ??
    22% mds
    2% WindowServer
    0% The Happy Cloud
    0% apsd
    0% hidd

    Top Processes by Memory: ??
    119 MB The Happy Cloud
    106 MB CrashPlanService
    74 MB Dropbox
    70 MB Finder
    45 MB Dock

    Virtual Memory Information: ??
    1.40 GB Free RAM
    2.60 GB Used RAM
    72 MB Swap Used

    Diagnostics Information: ??
    Jul 6, 2015, 02:47:17 PM Self test - passed

  22. #72
    Thanks for the effort! Worked like a champ for me. I had to rename the file name and the name of embedded app as well but it's rocking now!

    Thanks again! I was beginning to think I'd never be able to play this game! :P

  23. #73

    Simple way to make libpatchclient.dylib be found

    I search for solution, but I not found a simple way to make a workaround to "Can't locate libpatchclient.dylib loop" issue.

    For people that have same problem, that's my solution

    - Open terminal;
    - Considering the libpatchclient.dylib path is: "/Applications/lotroLauncher.app/Contents/MacOS/". Make sure PatchClient.dylib exists in this folder;
    - Execute:
    cp PatchClient.dylib libpatchclient.dylib
    that's it, I hope it help someone!


  24. #74
    Quote Originally Posted by Toddlepip View Post
    Having developed this issue myself last Friday after no problems playing since release, I have spent the weekend trying to troubleshoot the problem and now believe I have finally identified at least a workaround, if not a definitive cause (probably only Turbine can do this). This has been confirmed now as working for others with similar issues (including being stuck at an earlier stage)

    Issue: During the launch process of the Mac client LotroLauncher.app (in the Finder named The Lord of the Rings Online™), after connecting to the patch server and Check product stage; instead of progressing to the Login/Password stage the launcher shows the error message;


    And just repeats a Retry every 60 seconds will no progress. Relaunching will only repeat the loop.



    I would recommend that if you get this issue, you follow the third option above and do a fresh install of the app. In this way the correct path will show. Just ensure to remove all support files which are identified there. Keep the ~/Library/Application Support/com.turbine.lotroclient folder so you can add this back after to retain your lotro.keymap, Plugins and any screenshots etc., as there doesn't appear to be anything in there which will cause this.
    I haven't logged into the game since early December 2015, though I've been playing for years. During the time between when I last played and now (Feb 2016), I upgraded from OS 10.8.5 to 10.10.5 and replaced my old drive with an SSD. Today I tried logging in to Lotro and I'm getting the "update error occurred" loop talked about in this thread.

    1. First thing I did was remove "tm" from the two places indicated. This resulted in connection to the patch server and the patch files downloaded. However, upon launching the game, the error occurred again.

    2. I was concerned that my OS upgrade had caused a problem, so I booted up the old disk with the old OS and the old game client. Same problem, "an update error occurred".

    3. I tried a "clean install" based on the information in the first post. The game downloaded and updated through Akmai, but when the game tried to launch, the same error occurred again. I tried removing the "tm" on this "clean install", but now the launcher wants to download the whole freeking game again. I stopped the download and restored the "tm", but it still wants to download the whole game again.

    4. I fired up Lotro on my Win7 machine that was also running Lotro fine several months ago and I'm now getting the same issue there too.

    5. I tried launching Lotro on an old XP machine that I used to play on, and it .. patches, loads, and plays with no problems.

    All of these systems are connected to the same local network and the same internet access.

    To summarize, my XP install works, my Win7 doesn't, and my Mac doesn't work on two different operating systems. Two months ago I could play on all of them.

    I admit that I am thoroughly confused. Can anyone offer an advice about what to do? The Knowledge Base has exactly zero information about Mac, and I'm far more concerned about that install than Win7.


Page 3 of 3 FirstFirst 1 2 3

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

This form's session has expired. You need to reload the page.