We have detected that cookies are not enabled on your browser. Please enable cookies to ensure the proper experience.
Results 1 to 2 of 2
  1. #1
    Join Date
    Jun 2011
    Posts
    3

    Thumbs up Client Freezes / Error - FIXED

    Hey all,

    I've downloaded and installed LOTRO on my Mac it's the correct 17.74gb size and I ran the installation after opening the /dmg file.

    Firstly, the client kept saying that there was an error and then it would do a 60 second timer to try and update/correct the problem. The timer just reset after the countdown continuously.

    Now upon reading some posts her I changed the language to 'English' using the arrow menu on the client. Now whenever I open the client it just freezes after a few seconds and has to be fore quit. :/

    Any suggestions on how to fix this? Alternatively how would I go about uninstalling the game and running the installation again? Would I need to download the 17gb file or can I remove it and then open the file again? Sorry if this last part is dumb, I've only had my Mac a few weeks and I'm still learning.

    Thanks for any advice!
    Last edited by Gyomaekr; Nov 03 2012 at 11:45 AM.

  2. #2
    Join Date
    Jun 2011
    Posts
    3
    Hi all,

    I've fixed the issue and the game is running great for me now.

    I deleted the applications folder file for LOTRO and moved the download back into it. Seems to have worked. I have no idea why something so simple fixed it but if anyone else has this same problem just try deleting it and moving it back in again?


 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

This form's session has expired. You need to reload the page.

Reload