Just to confirm and save any players with 10.6.x or lower from the large download, although we have yet to have official minimum specifications posted yet it appears that;

OS X 10.7.x/Lion or 10.8.x/Mountain Lion are required as a minimum in order to run the LOTRO Mac Client.

Trying to using OS X 10.6.x/Snow Leopard or below will result in an error message (confirmed now in forum posts)

This was the case on the closed beta during Bullroarer testing, also noted as such in this forum post from back then. The closed beta Bullroarer forum section is no longer available.

http://forums.lotro.com/showthread.php?412407-Lotro-mac-client&p=6378180#post6378180