We have detected that cookies are not enabled on your browser. Please enable cookies to ensure the proper experience.
Results 1 to 9 of 9
  1. #1

    Mac client minimum system requirements?

    I haven't seen an info page, only some direct download links, so I wanted to ask: Can anyone say what the minimum system requirements are for the LOTRO Mac client?

    My wife is looking forward to this, but her system is a bit old. LOTRO runs fine on her Boot Camp partition, but I don't know if the Mac client imposes additional requirements that may cause problems.

    In particular, I saw reference, in some discussion, to OS 10.7 (Lion) or 10.8 (Mountain Lion) being required. Does anyone know if these are hard-and-fast must-have requirements, as in the LOTRO client will check and say "nope, it's impossible to run on an older OS version"? Or are they more soft requirements, of the "well, it may have issues but you're welcome to try it and see how it goes"? (I don't know what OS version she's running, but I am sure it's older than 10.7).

    I mean, I'd just tell her to start downloading and try it. But with the extremely large file, I'd like to get some idea whether it will work at all first.

    I know there was a lot of discussion about this back when the NDA dropped, but the responses were all unfirm, since the Mac client was still in flux.
    [charsig=http://lotrosigs.level3.turbine.com/0a20b00000007ede1/01005/signature.png]Cleogrin[/charsig]

  2. #2
    I attempted to launch the application under 10.6.8 and it failed, stating that I should "Check with a developer to make sure LotroLauncher works with this version of Mac OS X."

    I was expecting this and fortunately have a version of 10.7 to install. Doing that now.
    [charsig=http://lotrosigs.level3.turbine.com/0820700000017b961/01008/signature.png]undefined[/charsig]

  3. #3
    Join Date
    Jun 2010
    Posts
    4
    Quote Originally Posted by Eliel View Post
    ...her system is a bit old. LOTRO runs fine on her Boot Camp partition, but I don't know if the Mac client imposes additional requirements that may cause problems.

    In particular, I saw reference, in some discussion, to OS 10.7 (Lion) or 10.8 (Mountain Lion) being required. ...
    If it runs well in BootCamp, then the system age isn't a concern, as you've got the horsepower you need.

    But I can't comment on the "Lion or better" requirement, as all my Macs have been on Lion for a while now.

  4. #4
    Join Date
    Feb 2008
    Posts
    6
    if they are using OpenGL 3.2 over the legacy 2.1, that would probably be why 10.7 or 10.8 is needed... 3.2 support wasn't added until 10.7.

  5. #5
    Join Date
    Sep 2012
    Location
    France
    Posts
    684
    OS X 10.7.x/Lion or 10.8.x/Mountain Lion are required as a minimum in order to run the LOTRO Mac Client.

    Trying to using OS X 10.6.x/Snow Leopard or below will result in an error message.

    This was the case on the closed beta during Bullroarer testing.

  6. #6
    If you have Snowleopard it would be best to directly upgrade to Mountain lion if your system can take it, its quite cheap in the app store.

  7. #7
    Quote Originally Posted by Toddlepip View Post
    OS X 10.7.x/Lion or 10.8.x/Mountain Lion are required as a minimum in order to run the LOTRO Mac Client.

    Trying to using OS X 10.6.x/Snow Leopard or below will result in an error message.

    This was the case on the closed beta during Bullroarer testing.
    Thanks for the definitive responses, gang. Saves us the download, anyway.

    Quote Originally Posted by PhillyDave View Post
    If it runs well in BootCamp, then the system age isn't a concern, as you've got the horsepower you need.
    Well, that's not necessarily true. Any five-years-late port might have problems to solve that the devs choose to solve by throwing more horsepower at it. Plus there's this thread where someone is complaining about a problem that could be one of configuration, or could be one of horsepower (I know her system is even older than that person's).

    Quote Originally Posted by DrBrackman View Post
    If you have Snowleopard it would be best to directly upgrade to Mountain lion if your system can take it, its quite cheap in the app store.
    We checked once and she can't use their app store because her OS is too old. However, your suggestion of buying an OS upgrade is certainly one we could take under consideration.

    Thanks again for the responses, everyone.
    [charsig=http://lotrosigs.level3.turbine.com/0a20b00000007ede1/01005/signature.png]Cleogrin[/charsig]

  8. #8
    Quote Originally Posted by Eliel View Post
    We checked once and she can't use their app store because her OS is too old. However, your suggestion of buying an OS upgrade is certainly one we could take under consideration.
    That means your running at best Leopard, which frankly makes an OS update unfeasible.

    1. That hardware is pretty ancient by now.
    2. You would have to first upgrade to Snow Leopard and then again from it towards Mountain Lion(since it only gets sold through the store).
    3. Wether or not the game would run on that system would be questionable at best, the port is currently not exactly optimized and still on beta ... and well you know how long betas can last with Turbine *points at forum software*.

  9. #9
    Join Date
    Feb 2007
    Location
    Philadelphia, PA
    Posts
    2,714
    Quote Originally Posted by Eliel View Post
    In particular, I saw reference, in some discussion, to OS 10.7 (Lion) or 10.8 (Mountain Lion) being required. Does anyone know if these are hard-and-fast must-have requirements, as in the LOTRO client will check and say "nope, it's impossible to run on an older OS version"? Or are they more soft requirements, of the "well, it may have issues but you're welcome to try it and see how it goes"? (I don't know what OS version she's running, but I am sure it's older than 10.7).
    Turbine has not made any official statements as to hardware system requirements however, from the Beta:
    * The only KNOWN restriction is: the client will only run under Lion (OSX 10.7) or Mountain Lion (OSX 10.8). It will not run under Snow Leopard (10.6)

    Note that this restriction in itself will limit the hardware on which the Client can Run, as Lion and Mountain Lion are restricted to certain Intel based Macs.
    See [http://www.apple.com/osx/how-to-upgrade Apple: OSX Mountain Lion - how to updgrade] for hardware information (Nominally a mid-2007 or later iMac).
    (Personally, I would recommend a minimum of 4GB of system memory.)
    Bill Magill Mac Player Founder/Lifetimer
    Old Timers Guild - Gladden

    Val - Man Minstrel (90)
    Valalin - Dwarf Minsrel (69)
    Valamar - Dwarf Hunter (105)
    Valdicta - Dwarf RK (105)
    Valhad - Elf LM (65)
    Valkeeper - Elf RK (86)
    Valwood - Dwarf RK (80)

    Valhunt - Dwarf Hunter (70)
    Valanne - Beorning (92)
    Ninth - Man Warden (65)

    "Laid back, not so serious, no drama.
    All about the fun!"


 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

This form's session has expired. You need to reload the page.

Reload