We have detected that cookies are not enabled on your browser. Please enable cookies to ensure the proper experience.
Results 1 to 6 of 6
  1. #1
    Join Date
    Aug 2011
    Staten Island, NY, USA

    Rogue Herald at the Prancing Pony

    Just showed up some time ago.
    It is not mine.
    Did the bartender get extra protection or is it a Bree protester?
    Glicyn, Man CPT; Drigrin, Hobbit BUR; Heli, Dwarf MIN; Eliyvan, Elf LM- Imladris
    Soldiers of Gondor - Kin

  2. #2
    Join Date
    Oct 2011
    There was a bear named JohnLocke in the middle of Galtrev on Gladden a few weeks ago. It was unattackable, unhealable, and just stayed there sitting and standing in its normal idle animations. We found the offending LM and she had a twin bear following her . I think it's just an amusing bug. It disappeared after a dayish.
    A spaceship from another star / They ask me where all the people are
    I tell them I'm the only one / There was a war, but I must have won

  3. #3
    Join Date
    Dec 2010
    Brisbane, Australia
    Haha! yes I saw this a while ago...
    It seemed to be some weird glitch, but I assumed it would disappear after a while...

  4. #4
    The Herald/Bree Protester is on the Gladden server, too! Today I tried some emotes on him, to try to give him the idea that he should be moving along, when all of a sudden I was stuck in combat mode! I even tried /stuck and /unstuck but it didn't work, I was still locked in combat mode. I did find out that you can use the "toast" emote while in combat--but you get stabbed in the face by your weapon! It was all back to normal after I logged out and logged back on.

  5. #5
    Join Date
    Sep 2010
    Marikina City, Philippines
    There's one at the Bree West Gate in Landroval for several days now. I was wondering if she was part of the Bree Welcoming Committee. XD

  6. #6
    Oh, bummer! After the update on Monday, "Manny" the Man-at-Arms Herald is gone!



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

This form's session has expired. You need to reload the page.