We have detected that cookies are not enabled on your browser. Please enable cookies to ensure the proper experience.
Results 1 to 4 of 4
  1. #1
    Join Date
    Jun 2011

    Problem with saving chat-Shortcuts in quickslots containing umlauts

    Mae gowannen,

    First of all, I am not a developer! My English is not the best, sorry for that. I tried to search the forum here and on lotrointerface.com

    I also tried to contact the author at lotrointerface.com

    The problem:

    I am using TonicBars for emote-shortcuts with a german lotro-client. So I must use the german emotes. I can't use the original English ones instead. Now there is a problem with shortcuts containing german umlauts as ä, ö, ü or ß. I can create those shortcuts to the original clients quickslots an move them to a new tonicbars-quickslot.

    When I now click on that tb-qickslot the emote performs. But after a restart of the lotro-client all umlauts in the emotes are scrambled and of course they don't perform anymore. Umlaut-emotes in the original client-quickslot do not have this problem. They still perform after restart.

    The author NuclearTonic wrote me, that this problem might be on Turbine and I should try some other quickbar-plugins. But I can't see how this should help. If the problem is the same on other plugins, that would be no proof that the issue is on Turbine. It could be, that all developers did the same bug, because English is their native.

    So the questions are:

    Is there any plugin which has not this problem, so Tonic could look in that?


    Is there ane function in LUA to check if a quickslot contains a chat-shortcut and then translate it to utf8, unicode or any of that kind before saving the configuration to file... and re-translate that after loading the configuration?


    Is it on Turbine to fix that issue in the API?

    Thanks for your patience and, hopefully, for your help

    Hagridli of Morthond
    Gwaihir: Hagridarius, Hagrideorn, Hagrideus, Hagridli, Hagridolas, Xarah
    Landroval: Curvith

  2. #2
    Join Date
    Mar 2007

    Re: Problem with saving chat-Shortcuts in quickslots containing umlauts

    I don't use Tonic bars, but there are two places where Turbine issues need workarounds. The first is in saving and loading UTF-8 characters with the default PluginData:Save() and PluginData:Load() methods - there is a patch originally presented by Vindar which can help resolve this. The patch can be found on LoTROInterface.com.

    The second issue has to do with creating the quickslots. There is a bug in the constructor that fails to properly process international characters, but if you creat the shortcut as a blank object then use the :SetData() method to set the string it will properly handle the international characters (I first found this used in Compendium by Lunarwater).

    Your issue may or may not be related to one of these issues but if you pass this on to the author it may help.

  3. #3

    Re: Problem with saving chat-Shortcuts in quickslots containing umlauts

    Well, you could do something like this after loading the settings file to set the shortcut:

    function FixUmlauts(text)
    	text = string.gsub(text, 'ü', string.char(252))
    	text = string.gsub(text, 'ö', string.char(246))
    	text = string.gsub(text, 'ä', string.char(228))
    	text = string.gsub(text, 'ß', string.char(223))
    	return text
    snr = Turbine.UI.Lotro.ShortcutType.Alias
    This is not very elegant, but works. I was not aware that SetData() might work properly though, this would be the better solution then.


  4. #4
    Join Date
    Jun 2011

    Re: Problem with saving chat-Shortcuts in quickslots containing umlauts

    Had the same problem with Baruk but got it working using aliases. Create an alias of the "bad" emotes like

    /alias ;ruelpsen /rülpsen

    then use this to quickslot it

    /alias kurztext ;ruelpsen <quickslot>



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

This form's session has expired. You need to reload the page.