Mae gowannen,

First of all, I am not a developer! My English is not the best, sorry for that. I tried to search the forum here and on lotrointerface.com

I also tried to contact the author at lotrointerface.com

The problem:

I am using TonicBars for emote-shortcuts with a german lotro-client. So I must use the german emotes. I can't use the original English ones instead. Now there is a problem with shortcuts containing german umlauts as ä, ö, ü or ß. I can create those shortcuts to the original clients quickslots an move them to a new tonicbars-quickslot.

When I now click on that tb-qickslot the emote performs. But after a restart of the lotro-client all umlauts in the emotes are scrambled and of course they don't perform anymore. Umlaut-emotes in the original client-quickslot do not have this problem. They still perform after restart.

The author NuclearTonic wrote me, that this problem might be on Turbine and I should try some other quickbar-plugins. But I can't see how this should help. If the problem is the same on other plugins, that would be no proof that the issue is on Turbine. It could be, that all developers did the same bug, because English is their native.

So the questions are:

Is there any plugin which has not this problem, so Tonic could look in that?

or

Is there ane function in LUA to check if a quickslot contains a chat-shortcut and then translate it to utf8, unicode or any of that kind before saving the configuration to file... and re-translate that after loading the configuration?

or

Is it on Turbine to fix that issue in the API?

Thanks for your patience and, hopefully, for your help

Hagridli of Morthond