We have detected that cookies are not enabled on your browser. Please enable cookies to ensure the proper experience.
Results 1 to 5 of 5
  1. #1

    Turbine account not linked to forum account

    Greetings,

    My Turbine account is not linked to my forums account. When logging into the forums, I'm using the same login name shown in Turbine as "Forum Account". I log in successfully, but my subscription, character info, ...etc don't show up in the Forums under "My LOTR". How can I get these linked?

    Thanks

  2. #2

    Re: Turbine account not linked to forum account

    I've also opened an in-game ticket and they closed it and directed me to open a ticket at support.turbine.com - which I did. All I got back from them was a link to reset my password. Is there anywhere else I can direct my issue? I'm hoping this forum is monitored by folks who can help?

    Thanks

  3. #3
    Duwis's Avatar
    Duwis is offline The Lord of the Rings Online Team
    Turbine, Inc.
    Join Date
    Apr 2008
    Posts
    816

    Re: Turbine account not linked to forum account

    Quote Originally Posted by BeakstarRocks View Post
    Greetings,

    My Turbine account is not linked to my forums account. When logging into the forums, I'm using the same login name shown in Turbine as "Forum Account". I log in successfully, but my subscription, character info, ...etc don't show up in the Forums under "My LOTR". How can I get these linked?

    Thanks
    Can you PM me more details -- character names, servers they are on, etc.

  4. #4
    Join Date
    Jan 2007
    Location
    Lake Charles, LA
    Posts
    6,845

    Re: Turbine account not linked to forum account

    Quote Originally Posted by BeakstarRocks View Post
    Greetings,

    My Turbine account is not linked to my forums account. When logging into the forums, I'm using the same login name shown in Turbine as "Forum Account". I log in successfully, but my subscription, character info, ...etc don't show up in the Forums under "My LOTR". How can I get these linked?

    Thanks
    Do you have more than one subscription on your account, by any chance? Up at the top where it says "Logged in as..." can you click on that and change the name you're logged in as?
    [COLOR=Silver][FONT=Arial][SIZE=1][COLOR=Red]Ayrolen[/COLOR]-[COLOR=DarkOrange]Anikosi[/COLOR]-[COLOR=Yellow]Anfribur[/COLOR]-[COLOR=Lime]Ametrine[/COLOR]-[COLOR=DeepSkyBlue]Amari[/COLOR]-[COLOR=DarkOrchid]Ayaneth[/COLOR]-[COLOR=Red]Asparagus[/COLOR]-[COLOR=SandyBrown]Anayalos[/COLOR]-[COLOR=Yellow]Alyradal[/COLOR]-[COLOR=Lime]Aloe[/COLOR]-[COLOR=DeepSkyBlue]Asiago[/COLOR][/SIZE][/FONT][/COLOR][COLOR=Silver][FONT=Arial][SIZE=1]-[COLOR=DarkOrchid]Altanoin[/COLOR][/SIZE][/FONT][/COLOR][COLOR=Silver][FONT=Arial][SIZE=1]
    7 Haven Way, Tund Loriel, Falathlorn Homesteads
    [COLOR=White]Elendilmir[/COLOR] Arda Shrugged -[COLOR=White]Crickhollow[/COLOR] The Colonists[/SIZE][/FONT][/COLOR][SIZE=1]
    [/SIZE]

  5. #5

    Re: Turbine account not linked to forum account

    Just a follow-up, the accounts are now linked properly. I solicited help from both the forum admins as well as the Turbine ticketing system, so I'm not sure which was the correct path to resolution - but all is now well. Thanks for the help!

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

This form's session has expired. You need to reload the page.

Reload