Have you figured this out yet? If not, go to your UI settings in options, and uncheck Player Titles. Hope that helps, it worked for me!