We have detected that cookies are not enabled on your browser. Please enable cookies to ensure the proper experience.
Page 1 of 9 1 2 3 4 5 ... LastLast
Results 1 to 25 of 201
  1. #1
    Join Date
    Jun 2010
    Posts
    2,313

    Workaround for Client Crash to Desktop in 32-bit Windows

    Hi everyone.

    I've decided to make this new post so more people can see it and maybe benefit from the tweak. I've seen lots of people going into the big non plugin crash thread and overlook my original post there so wanted to make this new one.

    First of all, this patch should really only be used on systems with 3 or 4 gigabytes of memory and only on Windows versions that are 32-bit. The reason why 32-bit only is because 64-bit versions of Windows do not have the problem processes being limited to a maximum size of 2 gigabytes by default.

    For Vista 32-bit and Windows 7 32-bit:

    ***WARNING***: For the below, you MUST have Windows Vista or Windows 7 32-bit (any flavor) and at LEAST 3 gigabytes of RAM. If you have less than 3 gigs of RAM please attempt this tweak with a slight risk of video driver issues. Side effects of this tweak with 3 Gigs or less could be problems with your video display on your desktop (reduced colors, resolution). If that happens just set things back to default with the line I provide.

    How to do it:

    1) In Windows Vista/Windows 7 32-bit go to Start -> All Programs -> Accessories -> Right Click on Command Prompt and select "Run as administrator"
    2) In the command prompt window you want to type the following:
    Code:
    bcdedit /set increaseuserva 2560
    then hit enter. You should see: "The operation completed successfully."
    3) Reboot and play LOTRO.
    4) If you still experience crashes to desktop, try setting the increaseuserva number to 2688.
    5) If Turbine fixes this problem and you want to go back to the default process size, do the following:
    Code:
    bcdedit /set increaseuserva 2048




    For Windows XP 32-bit:

    ***WARNING***: For the below, you MUST have Windows XP Home 32-bit or Windows XP Professional 32-bit and at LEAST 3 gigabytes of RAM. If you have less than 3 gigs of RAM please be aware that if you do this tweak there can be problems with certain video drivers. Side effects of this tweak could be problems with your video display on your desktop (reduced colors, resolution). If that happens just set things back to default with the line I provide.

    1) Right click on the My Computer icon on your desktop, select Properties.
    2) Click on the Advanced Tab.

    You should see something like this:



    3) Click on the Settings Button in the Startup and Recovery section (where the mouse pointer is in the picture above)
    4) In the Startup and Recovery window click on the Edit button. This should open up your boot.ini in Notepad.



    5) You should now see a bunch of text similar to this:

    Code:
    [boot loader]
    timeout=30
    default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect /NoExecute=OptIn
    You should have something similar to that last line. Don't worry if there's a few things different, You will just want to edit that LAST line and add the following to the END of it: /3GB /userva=2560. So from the example above, the edited line would look like this:

    Code:
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect /NoExecute=OptIn /3GB /userva=2560
    Once that's done, save the file and reboot the system.

    6) If you still get the crashes to desktop, you can up that /userva=2560 number to /userva=2688
    7) If Turbine fixes the problem or you get any strange problems like having your system boot up with a 16 bit color desktop and low resolution, then just remove the /3GB /userva=2176 that you added and save the file and reboot.


    If you want to geek out, you may read the following article that helps to explain some of what you are editing and why: http://msdn.microsoft.com/en-us/libr...=vs.85%29.aspx
    Last edited by ChromiteSwiftpaw; Dec 18 2012 at 05:51 PM.

  2. #2

    Smile Re: Workaround for Client Crash to Desktop in 32-bit Windows

    Thank you very much! That worked like a charm, it has not crashed since =)

  3. #3
    Join Date
    Apr 2007
    Location
    Memphis, TN
    Posts
    42

    Re: Workaround for Client Crash to Desktop in 32-bit Windows

    I will give this a try tonight. I haven't crashed on LOTRO this much since it first released years ago. I have played since original beta and usually have a crash-free experience until this last expansion.
    Juliea, lvl 100, Minstrel; Ardiel, lvl 95, Guardian; Arrolyn, lvl 97, Hunter; Ardiwen, lvl 95; Rune-keeper; Caril, lvl 95, Lore-master; Juliwen, lvl 95, Warden; Jolete, lvl 95, Champion; Paula, lvl 95, Captain; Mahira, lvl 93, Burglar; Sonjae, lvl 8, Beoring

  4. #4
    Join Date
    Oct 2010
    Location
    Hillsboro, OR
    Posts
    7

    Re: Workaround for Client Crash to Desktop in 32-bit Windows

    I am wondering if this will fix my issue also.

    I had to drop to Directx9 in LOTRO from directx11 since I have done this not one crash.

    Wonder if I do this then go back to Directx11 if it will work with no crashes?

  5. #5
    Join Date
    Jan 2007
    Location
    Wisconsin
    Posts
    311

    Re: Workaround for Client Crash to Desktop in 32-bit Windows

    Sad to say, this has not fixed my propensity to crash going through doorways and zones.
    Linden Starfall, Leader of Mithril Crowns of Elendilmir and Arkenstone

  6. #6

    Re: Workaround for Client Crash to Desktop in 32-bit Windows

    Solved! Thank You ChromiteSwiftpaw! +REP

    I lived with this BUG until Update 6. Every time I tried to head south from Lothlorien, or teleport into the new area, 100% guaranteed CTD.

    I had been afflicted with occasional CTD, always when transitioning game areas in Dunland (never in earlier parts of the game), and often when entering the notorious Lagtrev AH/CH huts (if I had already traveled many places). It was ever annoying, but never a show stopper, I could always just restart and log right back in. Update 6 tipped the balance, it got unbearably bad.

    My system is WinXP Pro 32, 4GB ram, well patched and tended. No plugins, the problem started for me with ROI.

    I used "/3GB /userva=2304", and everything seems OK so far. Will update if anything else breaks.

    My conclusion is that this BUG has clearly affected many many people in the same way, all for the same reason. It should be called the "Middle Earth is Too Big for Two Gigs" bug. The hallmark is crashing during area/zone transitions. Of course these forums suffer noise from people with other different issues, but this one particular issue is an obvious and clear standout.

    I am guessing at the cause: even if physical RAM usage is at acceptable levels, LOTRO is reserving big pools of virtual memory to deal with the new different areas. In total, those allocations can exceed the 2GB default limit of 32 bit operating systems. Or perhaps it's a leak, and some Vmem allocations were not released. In any case, Turbine needs to address this issue. It is clearly a BUG that could be solved by checking ahead of time for a 2GB Vmem limit, and either NOT exceeding that limit, or intervening with the user to make the appropriate system settings.

    The simple fact that this issue remains silently broken, all the way from Update 5 through Update 6, is not adequate diligence. I share in the blame for never having bothered to submit a bug report, but frankly, robust programs don't wait until they they crash and a user complains, they check in advance to make sure they have the required resources.

  7. #7

    Re: Workaround for Client Crash to Desktop in 32-bit Windows

    My guess is that Turbine has only 64 bit Windows 7 machines at this point. They are not doing any testing with this configuration.

    This suggestion didn't work for me. I ended up with my PC freezing. I had to power cycle it. I ended up buying a new PC with Windows 7 to resolve the issue.
    Unless stated otherwise, all content in this post is My Personal Opinion.

  8. #8
    Join Date
    Jun 2011
    Location
    Rzeszow, Poland
    Posts
    251

    Re: Workaround for Client Crash to Desktop in 32-bit Windows

    A trick that worked for me so far is to mute all game sounds in Audio option (there is a checkbox there that does that).

  9. #9
    Join Date
    Sep 2010
    Posts
    177

    Re: Workaround for Client Crash to Desktop in 32-bit Windows

    I tried this as a last resort to get my Warden loaded into the game. Much to my surprise it worked!! I want to thank you very much for this fix, sure beats Turbines suggestion of turning my graphics down to Atari 2600. They should give you a job!!

    Any chance you can fix Driaglitch too????

    Edit: I want to add that this hasnt been 100% successful for me, and my post above was me counting my chickens before they really hatched :/
    Last edited by Followthelight; Mar 20 2012 at 11:27 AM.
    Dhirk Diggler of Salvation
    http://forums.lotro.com/showthread.p...tteries-ingame <---shut down the store maybe? We could all live with that

  10. #10
    Join Date
    Nov 2011
    Location
    Milan, Italy
    Posts
    34

    Re: Workaround for Client Crash to Desktop in 32-bit Windows

    Thank you, will tr this when at home.
    [CENTER][charsig=http://lotrosigs.level3.turbine.com/2521c000000214201/01007/signature.png]undefined[/charsig]
    I'm NOT english native, so forgive my grammar errors and spellin mistakes :D
    [/CENTER]

  11. #11
    Join Date
    Jul 2011
    Posts
    752

    Thumbs up Re: Workaround for Client Crash to Desktop in 32-bit Windows

    Thank you very much! Could do Forges of Isengard without crashing on entering.
    I'm using win7 32b with 4gb.

  12. #12
    Join Date
    Jun 2010
    Posts
    2,313

    Re: Workaround for Client Crash to Desktop in 32-bit Windows

    Just a note: Please post your results when using this workaround. I'd like to hear from people who have had this be successful for them as well as people who haven't (so I can hopefully suggest things to help fix their problem).

    Oh, another note. Did you know that if you have a license for Windows 7 32-bit you can download Windows 7 64 bit and use that same license in it?

    The DVD-ROM .iso images are available for download legitimately. Here's a blog post with links to the .iso image downloads:

    Links for Windows 7 SP1 ISO from Microsoft’s Official Distributer

    So if you're tired of mucking around in Windows 7 32-bit you can just switch to 64-bit and not have to worry about it and also have the full use of your 4 GB+ of RAM if you have that much.
    Last edited by ChromiteSwiftpaw; May 07 2012 at 05:11 PM.

  13. #13

    Re: Workaround for Client Crash to Desktop in 32-bit Windows

    Thanks for this Chromite! It has worked wonders for my crashing issues. I havent tested it yet with ToO (my biggest crashing issues place) but it has worked wonders for fangorns edge and forges of isengard galtrev daily! +rep
    [charsig=http://lotrosigs.level3.turbine.com/032020000003bfae5/01008/signature.png]undefined[/charsig]

  14. #14

    Re: Workaround for Client Crash to Desktop in 32-bit Windows

    Quote Originally Posted by difens View Post
    A trick that worked for me so far is to mute all game sounds in Audio option (there is a checkbox there that does that).
    Yes this is the only thing that seems to work reliably. I believe what it does is reduce the footprint when loading a new area such as the Pit of Iron, which tends to crash for those of us on 32-bit Windows. You can unmute after you've entered successfully. Remember to mute game sounds when leaving the glitchy area, otherwise it simply postpones the crash to exiting rather than entry. For areas such as Gravenwood, you will most likely have to play the whole level with sound muted as there will be many sub-level transitions as you move around.

    The workaround posted to allow apps to use more than 2 gb virtual memory doesn't work for me. When I try to launch LOTRO, it says it can't find a suitable graphics card. Obviously because the graphics card driver is somehow hardcoded to use an area of virtual memory now allocated for apps.

    Turbine is irresponsible for not fixing this issue once and for all for those using 32-bit Windows. 32-bit Windows is still advertised by Turbine as a supported configuration.

    I guess their logic is the problem will fade away as more and more people upgrade to 64-bit Windows.
    Last edited by Zagad; May 08 2012 at 08:36 PM.

  15. #15
    Join Date
    Jun 2011
    Posts
    1,871

    AW: Workaround for Client Crash to Desktop in 32-bit Windows

    Another Workaround: Avoid the ring of Isengard. This works quite well for me ;-)

    The problem is still there. Having a workaround is not a bugfix. Eventually I would like to play the Isengard Instances with sound.

  16. #16

    Re: Workaround for Client Crash to Desktop in 32-bit Windows

    glad I found this thread, the /3GB /userva=2304 worked for me (im on xp 32 bit with 4gb ram). No more crashing and other games and programs are running better. Thanks!

  17. #17

    Re: Workaround for Client Crash to Desktop in 32-bit Windows

    I've decided to make this new post so more people can see it and maybe benefit from the tweak. I've seen lots of people going into the big non plugin crash thread and overlook my original post there so wanted to make this new one.

    First of all, this patch should really only be used on systems with 3 or 4 gigabytes of memory and only on Windows versions that are 32-bit. The reason why 32-bit only is because 64-bit versions of Windows do not have the problem processes being limited to a maximum size of 2 gigabytes by default..
    (SNIP)
    I'm going to have to give this solution a try. I am currently in an ongoing dialogue with Turbine, but they don't seem that close to nailing down my problems. I saw your workaround earlier, but was hoping if it was so straight-forward, I'd be able to get confirmations (on OS versions) among kin members & that Turbine would have figured this out.

    There's little doubt that on my system, the client could be achieving 2G of resources used at points, as I see it ramping up via Task Manager to ungodly levels just loading.. (I've not seen it over 2G by itself, but I've seen it eclipse 1.8 or so, and with the few other system tasks running, it totals over 2G), and the crashes alway seem to happen at a point when there's likely a good bit of communication going back & forth at zone boundaries or after swift traveling/porting. If this is the issue, I find it really weird that Turbine isn't onto it yet.. WTH? Anyway, thanks for refreshing the post.. Gonna give it a shot.
    Last edited by MRNot; Nov 09 2012 at 12:46 PM. Reason: grammar.. D'OH! (old post, too)
    [I][COLOR=#daa520][FONT=comic sans ms]~ Occasional Taunter of Masked Badgers[/FONT][FONT=comic sans ms] ~[/FONT][/COLOR][/I]

  18. #18

    Re: Workaround for Client Crash to Desktop in 32-bit Windows

    Quote Originally Posted by difens View Post
    A trick that worked for me so far is to mute all game sounds in Audio option (there is a checkbox there that does that).
    Doing this did improve things for me (perhaps not completely, and it didn't affect the rubber-banding) but even as a workaround this is just unacceptable. I play to be immersed in Middle-earth, and that doesn't happen in silence..
    [I][COLOR=#daa520][FONT=comic sans ms]~ Occasional Taunter of Masked Badgers[/FONT][FONT=comic sans ms] ~[/FONT][/COLOR][/I]

  19. #19

    Re: Workaround for Client Crash to Desktop in 32-bit Windows

    Quote Originally Posted by ChromiteSwiftpaw View Post
    ..Oh, another note. Did you know that if you have a license for Windows 7 32-bit you can download Windows 7 64 bit and use that same license in it?.
    Did NOT know that, and that may be an avenue I'd explore, because at the price of RAM now (my current 4G in 2x2 sticks cost a whopping $39US), I would be cool with upping system RAM to 8G and/or more and using Win7/64 because I know a lot of people who've been using it with great success all along.
    [I][COLOR=#daa520][FONT=comic sans ms]~ Occasional Taunter of Masked Badgers[/FONT][FONT=comic sans ms] ~[/FONT][/COLOR][/I]

  20. #20

    Re: AW: Workaround for Client Crash to Desktop in 32-bit Windows

    Quote Originally Posted by thinx View Post
    Another Workaround: Avoid the ring of Isengard. This works quite well for me ;-)..
    W!NN!NG! (wait! No it's not!) lmao
    [I][COLOR=#daa520][FONT=comic sans ms]~ Occasional Taunter of Masked Badgers[/FONT][FONT=comic sans ms] ~[/FONT][/COLOR][/I]

  21. #21
    Join Date
    Jun 2010
    Posts
    2,313

    Re: AW: Workaround for Client Crash to Desktop in 32-bit Windows

    Quote Originally Posted by MRNot View Post
    W!NN!NG! (wait! No it's not!) lmao
    Yeah, a lot of people post dumb things like that (and turning off sounds). Those aren't acceptable. Wish they would go make their own threads or something.

  22. #22

    Re: AW: Workaround for Client Crash to Desktop in 32-bit Windows

    Quote Originally Posted by ChromiteSwiftpaw View Post
    Yeah, a lot of people post dumb things like that (and turning off sounds). Those aren't acceptable. Wish they would go make their own threads or something.
    Oh, I don't know.. I thought that was pretty much in fun..
    [I][COLOR=#daa520][FONT=comic sans ms]~ Occasional Taunter of Masked Badgers[/FONT][FONT=comic sans ms] ~[/FONT][/COLOR][/I]

  23. #23

    Re: Workaround for Client Crash to Desktop in 32-bit Windows

    Update: the initial value set in this workaround turned out to not be enough to get me into Ring of Isengard from Nan Curunir, but considering I was able to enter the Pit of Iron with seeming impunity, I think it has helped. I will now raise the value again to the next higher number and see what happens.
    [I][COLOR=#daa520][FONT=comic sans ms]~ Occasional Taunter of Masked Badgers[/FONT][FONT=comic sans ms] ~[/FONT][/COLOR][/I]

  24. #24

    Re: Workaround for Client Crash to Desktop in 32-bit Windows

    Updated update: I have to think I am more stable overall, however I did just crash again when taking the swift horse from Loth Vineyards to Thinglad.. During loading screen. May try increasing the value a bit further.
    [I][COLOR=#daa520][FONT=comic sans ms]~ Occasional Taunter of Masked Badgers[/FONT][FONT=comic sans ms] ~[/FONT][/COLOR][/I]

  25. #25
    Join Date
    Jun 2010
    Posts
    2,313
    Just wanted to update this thread (Unfortunately I can't update the first post since it gives an error... and I don't want to mess it up)

    I've personally seen the process size for the LOTRO client reach up to 2.5 gigabytes of memory. So some of the default numbers I gave won't give you a completely crash free experience.

    Here's some addition numbers to try:

    2304 (256 megabytes above default)
    2432 (384 megabytes above default)
    2560 (512 megabytes above default)

    At the moment, you shouldn't have to set it any higher than 2560.

 

 
Page 1 of 9 1 2 3 4 5 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

This form's session has expired. You need to reload the page.

Reload