Wir haben festgestellt, dass Euer Browser keine Cookies akzeptiert. Bitte erlaubt die Verwendung von Cookies in den Optionen Eures Browsers, um eine optimale Funktion dieser Webseite zu gewährleisten.
Seite 2 von 3 ErsteErste 1 2 3 LetzteLetzte
Ergebnis 26 bis 50 von 56
  1. #26
    Registriert seit
    07.01.2011
    Beiträge
    431
    Zitat Zitat von killykil Beitrag anzeigen
    Originally Posted by mmdoogie

    This worked pre update 11 but now I get a File directory not found error in the terminal when I try to run it. Any new suggestions (besides the obvious Turbine should fix this)
    For Steam people this probably should be changed (as it is in the lotro-wiki) to:
    Code:
    1. cd ~/Library/Application\ Support/Steam/SteamApps/common/Lord\ of\ the\ Rings\ Online/LotroLauncher.app/Contents/Resources/lotroclient.app/Contents/Resources
    
    2. cp DownloadFilesList.xml backup.xml
    
    3. sed -i .bak -e's/\\/\//g' DownloadFilesList.xml

  2. #27
    Registriert seit
    01.06.2011
    Ort
    Greece
    Beiträge
    1.141
    Im a windows 7 non steam intastalation..what should i do?

    Cause today it took me almost 2 hours to download all the splash screens and loading screen.Dunno why tho...nothing qwas changed on my pc
    Came back from work launched and it started

  3. #28
    Registriert seit
    13.08.2013
    Beiträge
    2
    Tangaar

    I've followed all the instructions but with Win7 and it all seems to fit in as well. Just run searches in Windows Explorer in order to find the files to edit or lock. For locking I checked "write protect".

    I will have some time to test it this evening and I'll let you know.

    Cheers!


    EDIT -----

    Confirmed! This works for Win7.

    Since I am outside home for work on a 14-14 days base, I purchased a mobile internet dingle and it cost me many MB of data just to download these pesky loading screens. Not only that, where I am cell phone internet are kinda slow so loading screens would take ages.

    Thanks alot Toddlepip, you rock !!!
    Geändert von Kublahkan (10.09.2013 um 17:40 Uhr)

  4. #29
    Registriert seit
    01.06.2011
    Ort
    Greece
    Beiträge
    1.141
    Zitat Zitat von Kublahkan Beitrag anzeigen
    Tangaar

    I've followed all the instructions but with Win7 and it all seems to fit in as well. Just run searches in Windows Explorer in order to find the files to edit or lock. For locking I checked "write protect".

    I will have some time to test it this evening and I'll let you know.

    Cheers!


    EDIT -----

    Confirmed! This works for Win7.

    Since I am outside home for work on a 14-14 days base, I purchased a mobile internet dingle and it cost me many MB of data just to download these pesky loading screens. Not only that, where I am cell phone internet are kinda slow so loading screens would take ages.

    Thanks alot Toddlepip, you rock !!!
    mind telling me the exact files to lock? The Downloadsfileslist?

  5. #30
    Registriert seit
    13.08.2013
    Beiträge
    2
    Zitat Zitat von Tangaar Beitrag anzeigen
    mind telling me the exact files to lock? The Downloadsfileslist?
    Actually I do not think you need to lock the image files. We'll see today after maintenance if there's a patch.

    Just search the file "DownloadFilesList.xml"
    Make a copy just in case
    Edit the file with Wordpad or any (just make sure to save it as a .xml file and not a .txt) :
    - Erase all but these lines:
    <?xml version="1.0" encoding="utf-8"?>
    <FileList>
    <File>

    </File>
    </FileList>

    Save and put "read only" checkmark in the File's Properties (just in case).

    That should do it.
    Loads at blinding speed and 45 mins of playtime (that's the only time I had yesterday) needed less than 5 Mb of download... Magnificent!
    I also play Star Trek Online and this game is a huge Mb sucker... LotRO gives me some breathing space.

    Cheers

  6. #31
    Registriert seit
    05.05.2012
    Beiträge
    219
    I tried this today, made a duplicate, deleted everything in the original except what was listed above, locked the file and made read only. The launcher stuck at "retrieving downloadable content" and did not continue. Is there a new way to bypass this as of update 11.4? This is dumb we have to do this ourselves rather than Turbine fixing a simple problem with this "new launcher" but oh well. I appreciate all the work the Mac Community does and I hope we can get this to work on update 11.4 also.

  7. #32
    Registriert seit
    17.02.2007
    Ort
    Philadelphia, PA
    Beiträge
    2.649
    Zitat Zitat von AaronIU Beitrag anzeigen
    I tried this today, made a duplicate, deleted everything in the original except what was listed above, locked the file and made read only. The launcher stuck at "retrieving downloadable content" and did not continue. Is there a new way to bypass this as of update 11.4? This is dumb we have to do this ourselves rather than Turbine fixing a simple problem with this "new launcher" but oh well. I appreciate all the work the Mac Community does and I hope we can get this to work on update 11.4 also.
    Nothing has changed with 11.4

    I assume you are getting the message "retrieving downloadable content" in the upper left corner of the first screen. It is a single line which usually flashes on and off very quickly.

    I don't know for certain, but I assume that you are suffering from try all of the solutions at the same time.

    I suspect that "making the file read only" is the problem... as far as I know, the FIRST thing which happens is that the Launcher downloads (or reads, I don't know which) the file: "DownloadFilesList.xml" --

    I do know that this file is overwritten for any MAJOR Patch.... possibly even all patches.

    Personally, I prefer simply fixing the "\" problem.

    .... you can do it quickly. Open Terminal and run this command.
    sed -i .bak -e's/\\/\//g' /Applications/LotroLauncher.app/Contents/Resources/lotroclient.app/Contents/Resources/DownloadFilesList.xml
    Bill Magill - Mac Player - Old Timers Guild- Gladden:

    Partial cast
    Valamar: Dwarf Hunter - Level 105
    Valdicta: Dwarf Rune-keeper - Level 105
    Valanne: Beorning - Level 91

  8. #33
    Registriert seit
    05.05.2012
    Beiträge
    219
    Zitat Zitat von Valamar Beitrag anzeigen
    Nothing has changed with 11.4

    Personally, I prefer simply fixing the "\" problem.

    .... you can do it quickly. Open Terminal and run this command.
    sed -i .bak -e's/\\/\//g' /Applications/LotroLauncher.app/Contents/Resources/lotroclient.app/Contents/Resources/DownloadFilesList.xml
    You are marvelous! Thank you! Works wonderfully.

  9. #34
    Registriert seit
    30.08.2007
    Beiträge
    4
    It seems like they've changed the location for the Mac Steam client again:

    [user]/Library/Application\ Support/SteamApps/common/Lord\ of\ the\ Rings\ Online/The\ Lord\ of\ the\ Rings\ Online™.app/Contents/Resources/The\ Lord\ of\ the\ Rings\ Online™.app/Contents/Resources/raw/en/logo
    [user]/Library/Application\ Support/SteamApps/common/Lord\ of\ the\ Rings\ Online/The\ Lord\ of\ the\ Rings\ Online™.app/Contents/Resources/The\ Lord\ of\ the\ Rings\ Online™.app/Contents/Resources/raw/de/logo
    [user]/Library/Application\ Support/SteamApps/common/Lord\ of\ the\ Rings\ Online/The\ Lord\ of\ the\ Rings\ Online™.app/Contents/Resources/The\ Lord\ of\ the\ Rings\ Online™.app/Contents/Resources/raw/fr/logo

  10. #35
    Registriert seit
    21.07.2011
    Ort
    The Netherlands
    Beiträge
    135

    Exclamation I have this on my Windows 7 laptop :/

    I have this on my Windows 7 laptop, dunno how to fix... :/

  11. #36
    Registriert seit
    07.11.2013
    Beiträge
    5
    have the same problem on my macbook pro too. But i can't do anything; i can't even change the name of the lotto ordner in finder!
    What should I do? Installation took a long long time and the only problem is the launcher/patcher...

  12. #37
    Registriert seit
    03.06.2011
    Beiträge
    14
    Thanks a lot guys.

    I'm brand new to Mac and I just fixed this on my MacBook Pro by replacing all the back-slashes with / and it absolutely flies now.

    For reference, I have change the name of my Application Launcher, dropping the TM from the end, as it was causing the infinite check error.

    So for anyone else looking for the file to change (who has the Turbine installation - Not the Steam one) - This was where I found it:

    Open Finder -> Applications -> Right-Click on "The Lord of the Rings Online" -> "Show Package Contents" -> "Contents" -> "Resources"
    -> Right click on "The Lord of the Rings Online TM" -> "Show Package Contents" -> "Contents" -> "Resources"
    -> Right Click on "DownloadFilesList.xml" -> "Open With" -> TextEdit
    -> In TextEdit, Click "Edit" -> 'Find" -> "Find and Replace" (or just press Alt-CMD-F)
    -> In the top box, enter "\" (without quotes)
    -> In the bottom box, enter "/" (without quotes)
    -> Click the "All" button (to the right of the "Replace With" box)
    -> Click "Done"

    Relaunch the game.

    Enjoy.

    (Sorry for the really long-winded post, but it has taken me a while to figure out the exact order, based on earlier posts, and I just wanted something that's a little clearer for anybody who - like me - has only just started with Macs).

  13. #38
    Registriert seit
    20.12.2007
    Beiträge
    7
    Zitat Zitat von Xxalon Beitrag anzeigen
    Thanks a lot guys.

    I'm brand new to Mac and I just fixed this on my MacBook Pro by replacing all the back-slashes with / and it absolutely flies now.

    For reference, I have change the name of my Application Launcher, dropping the TM from the end, as it was causing the infinite check error.

    So for anyone else looking for the file to change (who has the Turbine installation - Not the Steam one) - This was where I found it:

    Open Finder -> Applications -> Right-Click on "The Lord of the Rings Online" -> "Show Package Contents" -> "Contents" -> "Resources"
    -> Right click on "The Lord of the Rings Online TM" -> "Show Package Contents" -> "Contents" -> "Resources"
    -> Right Click on "DownloadFilesList.xml" -> "Open With" -> TextEdit
    -> In TextEdit, Click "Edit" -> 'Find" -> "Find and Replace" (or just press Alt-CMD-F)
    -> In the top box, enter "\" (without quotes)
    -> In the bottom box, enter "/" (without quotes)
    -> Click the "All" button (to the right of the "Replace With" box)
    -> Click "Done"

    Relaunch the game.

    Enjoy.
    I confirm it works like a charm.

    Could somebody please add this to the first post?

  14. #39
    Registriert seit
    14.09.2013
    Beiträge
    1
    Hi,

    sorry for pasting the wrong version, now in English :-)

    I had the same problem on my Mac, screens loading at every start and DownloadFiles.xml getting recreated as well. I found an easy solution for this without locking or changing files:

    Just create for each file in DownloadFiles.xml a symlink. ls -l shows something like this for every file:

    raw\de\logo\lotro_ad_pregame_d e.jpg -> raw/de/logo/lotro_ad_pregame_de.jpg

    I just wrote a little script to parse the xml file and create a symlink. So I can rerun this after every update if necessary. Just did it 2 or 3 weeks ago so I have to wait for a bigger update but it is working fine so far.

    Bye,
    Mira
    Geändert von Miranox (04.03.2014 um 18:31 Uhr)

  15. #40
    Registriert seit
    25.07.2011
    Beiträge
    1

    Quick post for windows 8.1 users

    hi, just a reminder for windows 8.1 users how to remove the annoying loading at every client start

    navigate to C:\ProgramData\Turbine\The Lord of the Rings Online
    if you can't find ProgramData it's hidden, go Show hidden files and folder on View->Options.....or just right click on your game icon and Open file location

    there is the file DownloadFilesList.xml, edit it with notepad and delete all but this:

    <?xml version="1.0" encoding="utf-8"?>
    <FileList>
    <File>

    </File>
    </FileList>


    then save it, and make it Read-only in Properties, done, ty

  16. #41
    Registriert seit
    07.05.2013
    Beiträge
    28

    Locked lotro_ad_pregame.jpg

    I have always used and found to be successful the locked jpg option. In the scheme of things, I guess all these fully downloaded splash screens don't mean alot other than time, but to me it was much more than that, I found that if I had to continually download this data, it used up my allocated monthly internet usage (satellite being a expensive option but the only one open to me) and the result was I was unable to play the game for one or two weeks a month. When I use the locked jpg (unlocking before patch), it worked a treat and I am able to play quite happily without restriction. With the last patch, the locked jpg is not working for me, so I have spent the last hour trying out the various listed methods above, and find everything to be unsuccessful. I am thinking it has something to do with the offered 6gb high resolution game data offer, although i could be wrong as I am not proficient with Mac. I am hoping that someone with the knowledge is able to rectify this.

    I live in hope
    Cheers :0)

  17. #42
    Registriert seit
    27.05.2013
    Ort
    Chicago, IL
    Beiträge
    84

    Since 14.1 Slight Change in Workaround

    I have always used the workaround (mentioned above in this thread) that involves opening the file DownloadFilesList.xml file buried in

    /Applications/LotroLauncher.app/Contents/Resources/lotroclient.app/Contents/Resources/DownloadFilesList.xml

    and changing all the backward slashes in that file to forward slashes. This has worked for me for over a year after every update I've experienced; opening that same file (by name anyway) and re-changing all the slashes.

    In update 14.1 this seemed to stop working. I was getting the slow listing of the EN, DE and FR splash screens but when I went to the above DownloadFilesList.xml file, there were no backward slashes to change; they were all forward slashes, presumably from when I had last changed them. So I thought I would be stuck with the slow splash screen updates.

    Well, it turns out there is also a DownloadFilesList.xml at an upper level at

    /Applications/LotroLauncher.app/Contents/Resources/DownloadFilesList.xml.

    This is the same level as the second lotro app. This file contains backward slashes too and changing all of them to forward slashes will stop the slow splash screen updates when you start the Lotro client in u14.1. I have no idea how this will continue in future updates but it works on my machine as of 14.1.

    Hope this helps!

  18. #43
    Registriert seit
    31.08.2012
    Beiträge
    6
    Thank you very much !!

  19. #44
    Registriert seit
    13.07.2010
    Beiträge
    358
    Zitat Zitat von VimVeebo Beitrag anzeigen
    I have always used the workaround (mentioned above in this thread) that involves opening the file DownloadFilesList.xml file buried in

    /Applications/LotroLauncher.app/Contents/Resources/lotroclient.app/Contents/Resources/DownloadFilesList.xml

    and changing all the backward slashes in that file to forward slashes. This has worked for me for over a year after every update I've experienced; opening that same file (by name anyway) and re-changing all the slashes.

    In update 14.1 this seemed to stop working. I was getting the slow listing of the EN, DE and FR splash screens but when I went to the above DownloadFilesList.xml file, there were no backward slashes to change; they were all forward slashes, presumably from when I had last changed them. So I thought I would be stuck with the slow splash screen updates.

    Well, it turns out there is also a DownloadFilesList.xml at an upper level at

    /Applications/LotroLauncher.app/Contents/Resources/DownloadFilesList.xml.

    This is the same level as the second lotro app. This file contains backward slashes too and changing all of them to forward slashes will stop the slow splash screen updates when you start the Lotro client in u14.1. I have no idea how this will continue in future updates but it works on my machine as of 14.1.

    Hope this helps!
    Thanks for this!

    I did the same thing - found my old file that had all the backslashes already converted and was really scratching my head. You've saved me hours of time trying to figure it out!

    Makes you wonder why Turbine can't seem to ever get this right ...

  20. #45
    Registriert seit
    19.07.2012
    Beiträge
    1
    Zitat Zitat von VimVeebo Beitrag anzeigen
    I have always used the workaround (mentioned above in this thread) that involves opening the file DownloadFilesList.xml file buried in

    /Applications/LotroLauncher.app/Contents/Resources/lotroclient.app/Contents/Resources/DownloadFilesList.xml

    and changing all the backward slashes in that file to forward slashes. This has worked for me for over a year after every update I've experienced; opening that same file (by name anyway) and re-changing all the slashes.

    In update 14.1 this seemed to stop working. I was getting the slow listing of the EN, DE and FR splash screens but when I went to the above DownloadFilesList.xml file, there were no backward slashes to change; they were all forward slashes, presumably from when I had last changed them. So I thought I would be stuck with the slow splash screen updates.

    Well, it turns out there is also a DownloadFilesList.xml at an upper level at

    /Applications/LotroLauncher.app/Contents/Resources/DownloadFilesList.xml.

    This is the same level as the second lotro app. This file contains backward slashes too and changing all of them to forward slashes will stop the slow splash screen updates when you start the Lotro client in u14.1. I have no idea how this will continue in future updates but it works on my machine as of 14.1.

    Hope this helps!
    Also confirming this works. To fix using Terminal the command is now:
    sed -i .bak -e's/\\/\//g' /Applications/LotroLauncher.app/Contents/Resources/DownloadFilesList.xml

  21. #46
    None of these workarounds seem to work for me and I am wondering if Turbine has changed the way it controls downloading these screens. I seem to have an intermittent problem, with an incredibly long wait (up to an hour) for all these screen to load. At other times it skips through them quickly and the game is up in minutes.

    I have tried: Changing backslashes to forward slashes, deleting everything apart from the <File List> and <File> tags, locking the first jpg file to load. None of these make any difference. I have tried restating the Mac, rebooting my router, I have checked that the firewall is properly configured.

    If it means anything, the problem seems to happen at peak times (evenings in the UK/Europe and at weekends) but that's not based on much data. I tried re-downloading the game with no success and in the process noticed that the connection to 'Happy Cloud' kept being interrupted, which makes me wonder if there is a server-side problem in the distribution of these resources?

    At my wits end. Any ideas?
    Geändert von Hanfur (30.11.2014 um 17:37 Uhr)
    [COLOR=#FF0000][FONT=Arial color=&quot]Mac Player[/FONT][/COLOR] since 2010

  22. #47
    Registriert seit
    17.02.2007
    Ort
    Philadelphia, PA
    Beiträge
    2.649
    Zitat Zitat von Hanfur Beitrag anzeigen
    None of these workarounds seem to work for me and I am wondering if Turbine has changed the way it controls downloading these screens. I seem to have an intermittent problem, with an incredibly long wait (up to an hour) for all these screen to load. At other times it skips through them quickly and the game is up in minutes.

    I have tried: Changing backslashes to forward slashes, deleting everything apart from the <File List> and <File> tags, locking the first jpg file to load. None of these make any difference. I have tried restating the Mac, rebooting my router, I have checked that the firewall is properly configured.

    If it means anything, the problem seems to happen at peak times (evenings in the UK/Europe and at weekends) but that's not based on much data. I tried re-downloading the game with no success and in the process noticed that the connection to 'Happy Cloud' kept being interrupted, which makes me wonder if there is a server-side problem in the distribution of these resources?

    At my wits end. Any ideas?
    For a period of time the download process was "fixed." i.e. Turbine broke it completely.
    That has now been fixed agin in 15.1 -- so we'll have to wait to see what changes will work once the 30 downloads are taking place again.
    Bill Magill - Mac Player - Old Timers Guild- Gladden:

    Partial cast
    Valamar: Dwarf Hunter - Level 105
    Valdicta: Dwarf Rune-keeper - Level 105
    Valanne: Beorning - Level 91

  23. #48
    Registriert seit
    13.09.2013
    Ort
    Withywindle
    Beiträge
    56
    Zitat Zitat von Valamar Beitrag anzeigen
    For a period of time the download process was "fixed." i.e. Turbine broke it completely.
    That has now been fixed agin in 15.1 -- so we'll have to wait to see what changes will work once the 30 downloads are taking place again.
    I'm no techie, but I am currently doing this:

    In the folder:

    /Applications/LotroLauncher.app/Contents/Resources

    I did the following:

    Locked the Raw folder

    Locked individually each of the files in the 3 folders (i.e., about 33 files):
    /Applications/LotroLauncher.app/Contents/Resources/raw/de
    /Applications/LotroLauncher.app/Contents/Resources/raw/en
    /Applications/LotroLauncher.app/Contents/Resources/raw/fr

    seems to work

  24. #49
    Registriert seit
    09.07.2012
    Beiträge
    80

    Cool Downloading loading screens

    Zitat Zitat von Maegren Beitrag anzeigen
    I'm no techie, but I am currently doing this:

    In the folder:

    /Applications/LotroLauncher.app/Contents/Resources

    I did the following:

    Locked the Raw folder

    Locked individually each of the files in the 3 folders (i.e., about 33 files):
    /Applications/LotroLauncher.app/Contents/Resources/raw/de
    /Applications/LotroLauncher.app/Contents/Resources/raw/en
    /Applications/LotroLauncher.app/Contents/Resources/raw/fr

    seems to work
    I can confirm that this seems to work - at least it did for me. It is important to lock each file individually and not just the folders. It might be that once another update comes along, these files will need to be unlocked... but that is no problem.

    Very nice Maegren... that was good thinking!

  25. #50
    Registriert seit
    17.02.2007
    Ort
    Philadelphia, PA
    Beiträge
    2.649
    Zitat Zitat von HacyHo Beitrag anzeigen
    I can confirm that this seems to work - at least it did for me. It is important to lock each file individually and not just the folders. It might be that once another update comes along, these files will need to be unlocked... but that is no problem.
    Note that this does not STOP the downloads, it merely causes them to fail immediately.

    You still attempt to download all 30 screens, but because the destination files are locked, an error is generated and the launcher moves on to download the next file.

    So, since each screen is roughly 300 - 600K, it WILL cut the time involved pretty significantly - but you still get the stupid downloading messages displayed. (Note that the entire raw folder download, all 30 files, is roughly 16 meg, so the savings is pretty substantial.)

    In the longer term, assuming Turbine actually fixes this download so that the files are downloaded into the Game Client instead of the Launcher, this specific fix will no longer work nor be necessary. At that point, the original fix to the XML file will probably work again.
    Bill Magill - Mac Player - Old Timers Guild- Gladden:

    Partial cast
    Valamar: Dwarf Hunter - Level 105
    Valdicta: Dwarf Rune-keeper - Level 105
    Valanne: Beorning - Level 91

 

 
Seite 2 von 3 ErsteErste 1 2 3 LetzteLetzte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  

Diese Formular-Sitzung ist abgelaufen. Du musst die Seite neu laden.

Neu laden